Darwin Core Trivialname remains empty

Post Reply
Bongo
Posts: 64
Joined: 22 Mar 10 18:11
Location: Ingolstadt, Germany
Contact:

Darwin Core Trivialname remains empty

Post by Bongo »

I use Darwin Core and always I had the problem that the Trivialname dwc:Taxon:dwc:vernacularName is not written when saving with CTRL+S. I had already given up the problem. But now I've been able to reproduce it.

My setup:
Version: 6.7.2.4229. But I think that has not changed in version 7.
Gui Language: German
Label: assigned Trivialname.
Photo: label assigned.
Save photo with CTRL+S.
Result: Trivialname remains empty!

Workaround:
Trivialname is a multi language field.
Change in Details the language of Standard, for example in English UK. Then back in Standard.
Save photo with CTRL+S.
The Trivialname is written correctly.

I think it is related to the Gui Language German. I suspect Multi Language is an array and initially is Standard in the GUI language German undefined. With changing the language into Details, then it is correctly defined.

Another note: when I end the program and restart it, it still works.
But when I restart the computer, the problem is back.

I hope you can understand it.
Regards, Bongo
Photo Supreme V6 Single User Edition, Windows 10.
Hert
Posts: 7347
Joined: 13 Sep 03 6:24

Re: Darwin Core Trivialname remains empty

Post by Hert »

dwc:Taxon:dwc:vernacularName
I think that should be dwc:Taxon.dwc:vernacularName (no semi colon between taxon and dwc. Could be a typo though.
Version: 6.7.2.4229. But I think that has not changed in version 7.
Did you try it in V7?

It is unclear what you are doing. If I try to match the pieces then you have a catalog label that is mapped to the dwc:Taxon.dwc:vernacularName field? If so, then also check if other assigned labels also have mappings, and if so if there are conflicts.
German language, multi language should all not matter. Mappings always go to the "default".
This is a user-to-user forum. If you need product support then please send a message
Post Reply