anyone else having problems accessing "www.forum.idimager.com"

Post Reply
dlp0918
Posts: 14
Joined: 30 May 18 21:35

anyone else having problems accessing "www.forum.idimager.com"

Post by dlp0918 »

This problem started a few days ago, then went away, then returned this morning.

error message: "This site can't be reached" "www.forum.idimager.com's DNS address could not be found. Diagnosing the problem." "DNS_PROBE_POSSIBLE"

OS: Windows 10
web browser: Brave (Chrome and MS Edge do not exhibit the issue)

clicking the icon in front of the URL in the address bar reveals:
"forum.idimager.com"
"Your connection to this site is not secure..."

Not a big problem for me and this is the only site I've encountered it on, but I'd like to understand it if not make it go away.

- David P
Running Photo Supreme on Windows 10 Pro 64-bit with a Ryzen 2700X processor, 16 GB RAM, 1TB SSD, 4 TB HD/SSD hybrid
Hert
Posts: 7262
Joined: 13 Sep 03 7:24

Re: anyone else having problems accessing "www.forum.idimager.com"

Post by Hert »

The "www. forum" URL that you mention is wrong, there is no such website.
Please delete that from your history and/or bookmarks.

The one and only URL to use is:
https://forum.idimager.com
This is a user-to-user forum. If you need product support then please send a message
dlp0918
Posts: 14
Joined: 30 May 18 21:35

Re: anyone else having problems accessing "www.forum.idimager.com"

Post by dlp0918 »

That fixed it. Thank you!
Running Photo Supreme on Windows 10 Pro 64-bit with a Ryzen 2700X processor, 16 GB RAM, 1TB SSD, 4 TB HD/SSD hybrid
Post Reply