Keywords not saving to file and details self-erasing

Post Reply
peterpix
Posts: 33
Joined: 01 Jun 16 15:36

Keywords not saving to file and details self-erasing

Post by peterpix » 04 May 19 18:37

I have been merrily keywording and uploading to a stock library (Shutterstock) all day.

Everything has been fine. except for one file.

My workflow has been to add labels to a file, upon which PSU adds them to the file (jpg). I then add a Headline and Description and also import a Profile with copyright and author information, and then press the OK button at the bottom of the Details page. PSU does its thing (activity shown on the left hand side of the screen), everything is written to the file, and when I upload all of the keywords and the Description are duly uploaded with it, and appear in the Shutterstock submission screen as expected.

That has been happening all day and all was well.

Suddenly I have a file that won't behave. I did all of the above but most of the keywords (those added today) did not transfer to Shutterstock (oddly those added today were the ones to transfer, though they all appear in keywords in Details), and the description didnt transfer to Shutterstock either, despite being in the Details screen in PSU. There was no red dot indicating something needed to be added to the file.

I tried again, but no luck.

So I right-clicked on the image in PSU for the menu and selected Metadata/Save to file (or whatever it is - can't look as the database is compacting at the moment) and that didn't help so I thought I'd try reading from (rather than saving to) the file. That deleted everything for the file in PSU, labels, Details, etc.

So I filled it all in again, but every time I filled in the Details and clicked OK and PSU started working, the information in Details (apart from the keywords) all disappeared. I filled in again a couple of times but this kept happening each time I pressed OK in Details.

Finally I destroyed the version set and was then able to make the Details info "stick".

I then uploaded again but today's keywords and the Description in Details did not transfer with the file. So I gave up and added everything manually in Shutterstock.

That has "solved" by problem in terms of submitting the file to Shutterstock, but I still don't understand what happened. I need to transfer this file to other stock libraries and I don't know how to make the data "stick" in the file and transfer.

Does anyone have any insight into this?

EDIT: I think I just solved my problem. It appears that somehow in the course of adding synonyms to a keyword, and using ; in between the keywords to separate them, I inadvertently added some synonyms with ; on the end of them. Those were then faithfully transferred to the Details screen and also appeared in the labels screen with their ; on the end. No wonder PSU was confused? I suspect but do not know that ; may be one of those forbidden characters in the world of databases, but correct me if I'm wrong.

Hert
Posts: 21541
Joined: 13 Sep 03 7:24

Re: Keywords not saving to file and details self-erasing

Post by Hert » 06 May 19 6:44

Did you know that you can enter synonyms in the details of a catalog label?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

peterpix
Posts: 33
Joined: 01 Jun 16 15:36

Re: Keywords not saving to file and details self-erasing

Post by peterpix » 07 May 19 4:12

Yes thanks. That's where I made my mistake. I entered

label1; label 2; label 3

instead of

label1, label2, label3

Peter

Hert
Posts: 21541
Joined: 13 Sep 03 7:24

Re: Keywords not saving to file and details self-erasing

Post by Hert » 07 May 19 7:32

Synonyms should be entered one per line. So:

Synonym 1
Synonym 2
Synonym 3
Synonyms.png
Synonyms.png (163.2 KiB) Viewed 208 times
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Post Reply