more not responding

Post Reply
vkfoto
Posts: 277
Joined: 19 Oct 16 2:51

more not responding

Post by vkfoto »

Now at 6443.
I have many labels to apply so from the folder point of view, I select multiple images that have something in common and apply the appropriate label, sometimes using an existing label, sometimes creating a new one.
And then, sometimes either after having selected and applied a new label or rapidly scrolling to a new set of images, PSu will suddenly become unresponsive. no matter how long I wait, the only solution is to close the program, either from the PSu dialog box or via Task Manager.
The images are all on a local disk so no network issues. There is no CPU, disk or network activity while this is happening.
Am I scrolling too fast?
Do I need to wait for the sync service from the last selection to finish?
G8DHE
Posts: 678
Joined: 21 Aug 17 12:58

Re: more not responding

Post by G8DHE »

Not seen this type of problem myself. I don't always wait for the "Sync" process to complete either but not experienced your problems.
Have you tried a "Verify Binary" check and maybe a Compact Catalog operations just to make sure the DB has no problems ?
Geoff Mather (G8DHE)
vkfoto
Posts: 277
Joined: 19 Oct 16 2:51

Re: more not responding

Post by vkfoto »

Just selected 76 images, applied a label and tried to scroll to other images when things got stuck. Have been doing the compact catalog and thumbs thing regularly. Will have to try a "verify binary", once I get control back.
vkfoto
Posts: 277
Joined: 19 Oct 16 2:51

Re: more not responding

Post by vkfoto »

Did another compact and even a verify binary.
Continued to select and adjust the labels of many multiple images. Thought everything was going smoothly when after selecting 302 images and while the sync was at about 11% I tried to select the next set and everything froze. Ended the foreground process and waited for the background process to end, as per Task Manager.
G8DHE
Posts: 678
Joined: 21 Aug 17 12:58

Re: more not responding

Post by G8DHE »

Just tried it here, created a "test" label under Misc, selected 400 images using folders, selected all the images then dragged & dropped the new label. It started Sync them, then selected another 500 images from different folders and repeated d&d they images were added and completed updating the Sync a few 10's seconds later. This was on a base set of 60,000 images on the laptop here.
I wonder what your PC setup is ? MIne below;
OS Name Microsoft Windows 11 Home
Version 10.0.22631 Build 22631
Processor 12th Gen Intel(R) Core(TM) i9-12900HK, 2900 Mhz, 14 Core(s), 20 Logical
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.7 GB
Geoff Mather (G8DHE)
vkfoto
Posts: 277
Joined: 19 Oct 16 2:51

Re: more not responding

Post by vkfoto »

Just an older Windows 10 Home with 16 GB of RAM.sing an i7-7700 @3.6GHz.
Did another Verify Binary followed by a Compact DB and Thumbs when I got "database disk image is malformed" What does that mean? How do I reform it?
Also interesting is that every time I restart, 108 thumbnails have to be processed. Let it complete and the next time 108 thumbs again have to be processed. A quick look as they are processed shows them to be from many different folders.
PS: compacting the database by itself works.
G8DHE
Posts: 678
Joined: 21 Aug 17 12:58

Re: more not responding

Post by G8DHE »

Try using the States|Repository|Possible Corruption and also the Drop Down on the top tabs (when connected to Internet) and select "Items without Thumbnails" between the two options it will identify those oddities in most cases and let you sort them, see viewtopic.php?t=35290
Geoff Mather (G8DHE)
vkfoto
Posts: 277
Joined: 19 Oct 16 2:51

Re: more not responding

Post by vkfoto »

Tired "Items without Thumbnails" and the only result is PSu "Not responding". Task Manager reports 15 - 25% CPU activity so perhaps it is compiling a list in the background. This would be a good place to have a status report dialog, if nothing else to at least reassure the user that all is not lost.
Hert
Posts: 7788
Joined: 13 Sep 03 6:24

Re: more not responding

Post by Hert »

vkfoto wrote: 29 May 24 12:23Compact DB and Thumbs when I got "database disk image is malformed" What does that mean? How do I reform it?
If you have a corrupt database then I'm not surprised that you get all these hangs.
Which one is corrupt? The Catalog or the Thumb database? Compact them separately to find out which one gives the error.
This is a user-to-user forum. If you need product support then please send a message
vkfoto
Posts: 277
Joined: 19 Oct 16 2:51

Re: more not responding

Post by vkfoto »

Ok, the catalog database compacts normally. The Thumbnail database is malformed. How do I reform it?
Hert
Posts: 7788
Joined: 13 Sep 03 6:24

Re: more not responding

Post by Hert »

Close the application

If you have a backup of the thumbs database then restore that. Then check again if it compacts correctly.

If you don’t have a backup then rename (or delete if you prefer) the current thumbs database and on startup it will be recreated.
This is a user-to-user forum. If you need product support then please send a message
vkfoto
Posts: 277
Joined: 19 Oct 16 2:51

Re: more not responding

Post by vkfoto »

Replaced the thumbnail database with a slightly older version, and after redoing a load of thumbnails, I ran the compact thumbs. No more malformed database and just now, the compacting was finished.

Good reason to always have a good recent backup of both.
Now to see if the not responding issue also went away.
vkfoto
Posts: 277
Joined: 19 Oct 16 2:51

Re: more not responding

Post by vkfoto »

Just updated to build 6450.
Resumed adding labels to existing images. After a few folders were done, I selected the next set and pointed to the appropriate label value for them all when PSu went into (Not responding) mode. I think the previous set was still synching. Checking in Task Manager, there is no activity for the CPU or disk. There is a regular Network blip every few seconds but nothing changes.
Both the catalog and thumbnail databases were good before the upgrade.
PS, there appears to be minor CPU activity once in a long while. Will let it sit and wait. Luckily it's on another PC so I can continue to work.
RobiWan
Posts: 196
Joined: 03 Nov 17 8:14

Re: more not responding

Post by RobiWan »

Maybe stupid question - you wrote explicit - pictures are stored on local disk. But where is your database stored? On local disk too or maybe network drive or something else?
vkfoto
Posts: 277
Joined: 19 Oct 16 2:51

Re: more not responding

Post by vkfoto »

While obvious at my end, not so for others. The local disk with the current images also hosts the PSu databases. And that is all that is on that disk. And yes that whole disk is exempt from automatic virus scanning. I do scan it manually from time to time. There is also plenty of space left on it, about 0.99 TB.
Post Reply