Zenfolio Exception

Bethcee
Posts: 25
Joined: 20 Dec 22 21:42

Zenfolio Exception

Post by Bethcee »

Hi Hert

been meaning to post this for a while but the Zenfolio uploader does not connect. Zenfolio is weird in having 2 types of account - the older "classic" one and a newer one. I believe an api is available for both. Can the Zenfolio app be made to work with the newer API ?
image_2023-10-18_091726278.png
image_2023-10-18_091726278.png (46.76 KiB) Viewed 19722 times
Many thanks
B
Bethcee
Posts: 25
Joined: 20 Dec 22 21:42

Re: Zenfolio Exception

Post by Bethcee »

Any thoughts on this Hert - would be very useful to have this working :)
Hert
Posts: 7765
Joined: 13 Sep 03 6:24

Re: Zenfolio Exception

Post by Hert »

No idea. Works fine here.
This is a user-to-user forum. If you need product support then please send a message
Bethcee
Posts: 25
Joined: 20 Dec 22 21:42

Re: Zenfolio Exception

Post by Bethcee »

Are you using the older "Classic" zenfolio account or the newer one, because that would make a difference
Hert
Posts: 7765
Joined: 13 Sep 03 6:24

Re: Zenfolio Exception

Post by Hert »

My account was created maybe 10 or 15 years ago. I guess that’s classic.
This is a user-to-user forum. If you need product support then please send a message
Bethcee
Posts: 25
Joined: 20 Dec 22 21:42

Re: Zenfolio Exception

Post by Bethcee »

Hert wrote: 18 Oct 23 20:26 My account was created maybe 10 or 15 years ago. I guess that’s classic.
I guess. I don't totally understand how or why Zenfolio maintains 2 different types of account but it seems there is a difference in implementation. Some of the Zenfolio guidance makes a distinction which can sometimes be confusing!

But...is there any possibility of there being an extension of the current PS options to include the new API? :D
Hert
Posts: 7765
Joined: 13 Sep 03 6:24

Re: Zenfolio Exception

Post by Hert »

Didn't Zenfolio remove the API for its new accounts?
This is a user-to-user forum. If you need product support then please send a message
Bethcee
Posts: 25
Joined: 20 Dec 22 21:42

Re: Zenfolio Exception

Post by Bethcee »

Hert wrote: 19 Oct 23 8:22 Didn't Zenfolio remove the API for its new accounts?
There must be an API I am guessing because there is a 3rd party Lightroom plugin I use that connects to the new accounts
msbc
Posts: 5
Joined: 21 Mar 24 7:16

Re: Zenfolio Exception

Post by msbc »

New PSu user here and on a Zenfolio trial. Just tried the Zenfolio uploader and got the error posted by the OP. Has this issue not been resolved?
Hert
Posts: 7765
Joined: 13 Sep 03 6:24

Re: Zenfolio Exception

Post by Hert »

Check the latest build
This is a user-to-user forum. If you need product support then please send a message
msbc
Posts: 5
Joined: 21 Mar 24 7:16

Re: Zenfolio Exception

Post by msbc »

The error has changed to E_INVALIDCREDENTIALS even though the user/pass used are correct:
Attachments
Screenshot 2024-05-25 at 3.48.42 PM.jpg
Screenshot 2024-05-25 at 3.48.42 PM.jpg (101.99 KiB) Viewed 2204 times
Hert
Posts: 7765
Joined: 13 Sep 03 6:24

Re: Zenfolio Exception

Post by Hert »

Apparently Zenfolio thinks that your login details are incorrect.

Maybe you should try to login again in Psu. Did you create a sharing profile(?) then try to reauthenticate there.
This is a user-to-user forum. If you need product support then please send a message
msbc
Posts: 5
Joined: 21 Mar 24 7:16

Re: Zenfolio Exception

Post by msbc »

Hert wrote: 25 May 24 10:56 Did you create a sharing profile(?) then try to reauthenticate there.
Authenticating in a sharing profile is where this problem is happening.
I downloaded the Desktop Loader from Zenfolio site and used the same credentials with that successfully.
Hert
Posts: 7765
Joined: 13 Sep 03 6:24

Re: Zenfolio Exception

Post by Hert »

I just tried it here and have no issue authenticating Zenfolio.

PSU has no control over Zenfolio either approving or disapproving a login combination. The error is in the message you are getting..."Invalid credentials". It is Zenfolio that raises the error that your credentials are incorrect, not PSU.
Maybe you should contact Zenfolio support about this.
This is a user-to-user forum. If you need product support then please send a message
msbc
Posts: 5
Joined: 21 Mar 24 7:16

Re: Zenfolio Exception

Post by msbc »

My credentials are correct. They work in a web browser, Zenfolio's Desktop Loader and Lightroom plugin.

PSu is the only integration point that fails with the exact same credentials.

PSu does not have control over Zenfolio's authentication but it does have control over the API's, protocols and encryption used by it's sharing profile feature. Clearly, based on the evidence of 3 other interfaces working correctly with the same input data, PSu is not using the API's correctly.
Post Reply