Details Tab speed issue

Post Reply
henalds
Posts: 24
Joined: 15 Jun 21 7:29

Details Tab speed issue

Post by henalds »

I have a large number of videos (~55000) with my own XMP schema.

I have added about 30-40 of these tags as custom XMP fields so that they show up in the details tab and I can use them to quickly filter my files.

Only problem is its very slow. for example, clicking 'Your Custom Tags' can take a few minutes just to show the list of my tags. After that its just as slow when I click on any of them.

How can I speed this up? or is it just because I have a lot of files, each with a lot of tags?
Hert
Posts: 7347
Joined: 13 Sep 03 6:24

Re: Details Tab speed issue

Post by Hert »

Please share the catalog to test with. Best to upload a ZIPPED copy of the cat.db file to your cloud space and send a download link to support@idimager.com.
This is a user-to-user forum. If you need product support then please send a message
henalds
Posts: 24
Joined: 15 Jun 21 7:29

Re: Details Tab speed issue

Post by henalds »

Hi Hert,

Apologies, this task was put on hold so sorry for my slow response.

unfortunately due to the nature of my work I cant share the catalog with you. All I can say is that the 'Categories' work fast, and it is just the 'Details' that are slow. We also have ~30 different custom fields which contains about 10 unique values each. we also have about 55,000 videos. So you could replicate the problem yourself.
Hert
Posts: 7347
Joined: 13 Sep 03 6:24

Re: Details Tab speed issue

Post by Hert »

In Photo Supreme 7.3 the speed in the Details section is improved. The latest build today is 7.3.0.4459. If you are a V7 user then best to upgrade to the latest build.
This is a user-to-user forum. If you need product support then please send a message
henalds
Posts: 24
Joined: 15 Jun 21 7:29

Re: Details Tab speed issue

Post by henalds »

since upgrading to the newest build you provided, Non of the details tab works anymore. However when I click on my files I can see all my custom XMP tags still there, I just cant search with them.

I have re-read the metadata for all images and reimported with no success, what else can I do?
G8DHE
Posts: 480
Joined: 21 Aug 17 12:58

Re: Details Tab speed issue

Post by G8DHE »

Working here OK, you do need to expand the items to get the Counts now as was mentioned in the changes file.
Windows 10
Geoff Mather (G8DHE)
Hert
Posts: 7347
Joined: 13 Sep 03 6:24

Re: Details Tab speed issue

Post by Hert »

Could be that there's an active filter that filters out the results?
Make sure that the Filter Bar is not active and that there's no Catalog Filter active
This is a user-to-user forum. If you need product support then please send a message
henalds
Posts: 24
Joined: 15 Jun 21 7:29

Re: Details Tab speed issue

Post by henalds »

Hi Hert,

When I click the drop down arrow on any details tab it just shows nothing. I do not have any filter applied.

When I click the 'Your Custom Fields' tabs, I can see all my custom fields but they are empty and clicking on them or expanding them does nothing.
Hert
Posts: 7347
Joined: 13 Sep 03 6:24

Re: Details Tab speed issue

Post by Hert »

Did you check if there's perhaps a filter active that leads to no results?

If not then can you let me know how long the database conversion took for the 7.3 update? Was that seconds, minutes, or hours?
This is a user-to-user forum. If you need product support then please send a message
henalds
Posts: 24
Joined: 15 Jun 21 7:29

Re: Details Tab speed issue

Post by henalds »

No There was no filter active. That is besides the point anyway, the issues is not that I dont get results, its that it doesnt find the details tab categories in the first place.

Eg, It shows Temperature, but not the values Low, Medium and High which is used to (and there are tens of thousands of files with those values).

The upgrade took a couple of hours.
Post Reply