Labels > AI > Detect Labels API error

Post Reply
andrew.heard
Posts: 205
Joined: 16 Jun 10 0:36

Labels > AI > Detect Labels API error

Post by andrew.heard »

I have the GEO API working ref. viewtopic.php?t=29969 and the Cloud Vision API is added/ enabled however I get the following message box when I click Detect Labels from the LAP:
x.png
x.png (48.36 KiB) Viewed 662 times
I'm using the latest EXE 7.1.0.4306. I've gone through the latest versions of the manuals for 1) Setup Google API key 2) Artificial Intelligence without success. Thanks for any help.
Hert
Posts: 7260
Joined: 13 Sep 03 7:24

Re: Labels > AI > Detect Labels API error

Post by Hert »

Check if your API restriction is still valid, if there’s an IP restriction and your IP has changed then the API will fail

Check that your payment method in the Google account is still valid

If you still cannot get it to work then contact Google. They should be able to tell you why their API generates this message for you. Google typically responds fast.
This is a user-to-user forum. If you need product support then please send a message
andrew.heard
Posts: 205
Joined: 16 Jun 10 0:36

Re: Labels > AI > Detect Labels API error

Post by andrew.heard »

Thanks Hert - would you expect the PSu GEO mapping functionality to be still be working if the IP restriction settings were wrong though? I doubt this is an issue. Address from https://whatsmyip.idimager.com hasn't changed since I 1st set everything up last year.

Does the Google Cloud (free) account expire i.e. no longer free after some period? It's not important enough to me that I want to pay Google for the service.

The Google Cloud Platform dashboard says "all services normal". Although I can understand the requirement, it's complicated when part of a products functionality is provided by a 3rd party, as to who is responsible when an issue like this arises. The Google "dashboard" is a bit overwhelming in where to even go to check settings.

>If you still cannot get it to work then contact Google
any suggestion where?
Hert
Posts: 7260
Joined: 13 Sep 03 7:24

Re: Labels > AI > Detect Labels API error

Post by Hert »

andrew.heard wrote: 22 May 22 5:40 Thanks Hert - would you expect the PSu GEO mapping functionality to be still be working if the IP restriction settings were wrong though? I doubt this is an issue. Address from https://whatsmyip.idimager.com hasn't changed since I 1st set everything up last year.
Google runs the Google Vision service. PSU doesn't have any access to the Google's backend. There is no way for anyone (PSU included) to know how an API is configured at Google.
Does the Google Cloud (free) account expire i.e. no longer free after some period? It's not important enough to me that I want to pay Google for the service.
If up to now you were using the Google One Year (I believe) trial account and that has now expired then that explains why your API no longer works. You have to visit the Billing section in the Google account first to accept the continuation of your use.

From the PSU Setup Google PI manual:
Google Vision is not free to use, but it
comes with a monthly free bundle to make it cost free for average home use. For more
information about Google Vision’s pricing, you can check this page:
https://cloud.google.com/vision/pricing.
Photo Supreme caches Google Vision results to prevent unnecessary API calls or optional API
costs.
As stated there, Google Vision comes with free monthly bundles. In addition, if you want to control the Google cost then setup a Budget limit in your Google account. Visit the API console, then click the upper left hamburger menu, then select Billing. In Billing, select "Budgets & alerts" and create a new budget there to control your costs or even prevent any costs outside of the free bundle.
>If you still cannot get it to work then contact Google
any suggestion where?
GoogleSupport.png
GoogleSupport.png (42.34 KiB) Viewed 605 times
This is a user-to-user forum. If you need product support then please send a message
andrew.heard
Posts: 205
Joined: 16 Jun 10 0:36

Re: Labels > AI > Detect Labels API error

Post by andrew.heard »

Thanks for all your help Hert. I may just delete the existing account & start from scratch, when I get a chance. It still seems odd that part of the API is working - GEO whereas another part of the API is not - Detect Labels. But no need for reply/ comment.
Post Reply