V7: square aspect ratio states/filter issues?

Post Reply
davidge
Posts: 4
Joined: 20 Nov 20 16:29

V7: square aspect ratio states/filter issues?

Post by davidge »

After I initially installed V7 yesterday (I upgraded from V6) I tried the States>Aspect Ration>Ratio Square option and it returned 522 photos, 134 that were square and the remainder not square (e.g. included 4:3s, 3:2s, 16:9s, wider panoramas etc. as well as a images with various non-standard crop sizes). Yet today it now appears to be working correctly returning only square photos (great!) but the count still shows 522, not 134 (which I believe is about correct although I can't easily eyeball all of my 10939 photos to absolutely check). Is this normal...does the database have to 'settle down' or need some sort of trigger to work this this out?

Today I also tried the 'Filter by aspect ratio' function to find square photos in folders. When I did this across my complete set of photos (i.e. the top level folder containing all 10939 photos, albeit that are in sub-folders) it returned only 3 (i.e. not 134) and the count in the tab stated 10939 items. When applying that filter to individual sub-folders of photos within the main folder, mostly the count of items in the tab matched the number returned, but sometimes not (e.g. returned 36 photos, but the count said 2010 items).

Just to add to the confusion, I tried a filter selecting State=Ratio Square in the drop-down list rather than the repository option across all 10939 photos it then still returned 522 photos of various aspect ratios (as described in paragraph 1 above), yet when I do the same on the subfolder that returned 36 photos yet reported 2010 as an example (see paragraph 2 above), it did return 36 photos and the count of items was correctly 36.

I can't be 100% sure of this - take me too long to go through 10K+ photos to check - but at first glance it appears the above issues do not occur when selecting other aspect ratios.
davidge
Posts: 4
Joined: 20 Nov 20 16:29

Re: V7: square aspect ratio states/filter issues?

Post by davidge »

To follow up...
Following advice on how to remove V6 from my system, I backed up the database, uninstalled V7 and V6 then reinstalled V7.
All works fine except...
Filtering to find square photos is back to where it was when I initially installed V7 yesterday - that is all over the place returning non-square photos with incorrect item counts etc.

From what I can ascertain:

1. Filter by aspect ratio square generally works returning square photos with a count that matches the photos returned - but is slow.
2. Filter by state>ratio square sometimes works and sometimes returns a mixture of aspect ratios (depends on which folder I am filtering - but is fast
3. States>Aspect Ratio>Ratio Square returns a mixture of aspect ratio - but is fast

I assume the first method (1) works because the software is trawling the database (although I have had it return the occasional non-square photo), and for the other two methods (2 and 3) it is almost as if the database has not worked work out what the States>Aspect Ratio>Ratio Square photos are.
jstartin
Posts: 418
Joined: 23 Aug 06 13:47
Location: UK

Re: V7: square aspect ratio states/filter issues?

Post by jstartin »

Do you have photographs in version sets, and if so are there some versions in the sets that do have a square aspect ratio, and others that do not?
Jim (Photo Supreme: AMD Quad-Core A8-5500 Accelerated Processor 3.2 GHz; SSD; 16GB DDR3 SDRAM; Win10x64)
Hert
Posts: 7282
Joined: 13 Sep 03 7:24

Re: V7: square aspect ratio states/filter issues?

Post by Hert »

Select all thumbs in the Ratio Square section. Then manually up date the thumbs (Ctrl-Alt-T or Cmd-Opt-T)
This is a user-to-user forum. If you need product support then please send a message
davidge
Posts: 4
Joined: 20 Nov 20 16:29

Re: V7: square aspect ratio states/filter issues?

Post by davidge »

Thanks Hert
That sorted the problem out but I had to do it multiple times. The first run with all the thumbs still left in a dozen or so non-square photos which I had to remove from the square state by updating each thumbnail individually. After that now all works fine whether I filter by the square state or use the aspect ratio>square state directly.

I did notice that the square state and the filter by ratio>square have different interpretations of what is square. The former shows only absolutely square photos (i.e. height=width), whereas the latter includes nearly square photos. For example the latter returns a photo that is 3140x3250px whereas the former does not. I think I may have seen this also when filtering by other aspect ratios (e.g. get 'nearly' 3:2 or 'nearly' 4:3 etc). Not a big deal though - actualy could be quite useful!
Post Reply