Keyword handling problems

Post Reply
Ulrich
Posts: 7
Joined: 14 Jul 21 12:59

Keyword handling problems

Post by Ulrich » 16 Jul 21 9:01

Hi all,
I'm new to Photo Supreme and have quite huge problems with the keyword handling.
Up to now I have used Lightroom for my photo management, but because of RAW development quality reasions reguarding fuji files I changed to Photo Supreme + Capture One. I'm not going to use lightroom in future.

I have imported my former lightroom catalog in Photo Supreme (including all keywords).

My problems are following:
1. Some of my former keywords are shown as categories AND keywords in photo supreme, others are only visible as keywords (in the details page) but not as categories. Why?

2. I deleted some of the keywords, saved the keywords to the file and re-read the keywords from the file. Result: The deleted keywords are there again.
How can I permanently delete some of the keywords?

3. When I select several files (with not 100% identical keywords) the keyword section at the details page is gone, so I can only dete keywords there one by one, which is impossible for many thousand files.

Does anyboady has a hint for me how to get out of this mess?
Is it eventually possible to find a script anywhere which I could customize to delete keywords in several files?

Hert
Posts: 6874
Joined: 13 Sep 03 7:24

Re: Keyword handling problems

Post by Hert » 17 Jul 21 10:31

A warm welcome to the forum.
You are missing one crucial part: Catalog Labels.

I assume that you've used the Lightroom Import feature. That means that your keywords from Lightroom are read as Catalog Labels in Photo Supreme. You should understand first that Catalog Labels become your keywords when you write to file. And that keywords become catalog labels when you read from the file (depending on your sync settings, but lets assume you have everything at default there).

That also means that to remove a keyword from an image, you should remove the Catalog Label. In other words, there's no need to edit keywords in the Image Details (you could but then you should know/realize very well how that interacts with Catalog Labels).

I recommend that you also at least skim through the Cataloging Manual.

1) That is correct. Keywords become Catalog Labels (and Catalog labels are in a top level Category like People or Events)

2) Unassign the Catalog Label instead. You can do that in the Label Assignment Panel (click Labels from the command bar below the thumbnails)

3) While you should have no need to edit keywords directly, the following: you can select multiple thumbs and open the Image Details (as you did). With multiple thumbs selected, each editor field gets a command button. Click that button to select what operation should take place. You can choose from "Replace", "Append", "Clear". This applies to every single field, the keywords included.

MultiEditing.png
MultiEditing.png (44.19 KiB) Viewed 169 times

More questions? Ask!
This is a user-to-user forum. If you need product support then please send a message

Ulrich
Posts: 7
Joined: 14 Jul 21 12:59

Re: Keyword handling problems

Post by Ulrich » 19 Jul 21 12:36

Dear Hert,
thank you very much! but indeed, I have to ask again.
Of cause I have read the cataloging manual before I have posted my question.
Possibly I didn't understand everything, but I guess the answer for my problem is not in there.

I tried to describe my problem in detail and with some screenshots.
Therefore I added a PDF with the description and screenshots. Please be so kind and find it in the attachment.
The example foto is there as well.

It would be very kind when you could have a look.

Thanks in advance!
Ulrich
Attachments
20160409_61_0064-2.xmp
(12.05 KiB) Downloaded 4 times
20160409_61_0064-2.jpg
20160409_61_0064-2.jpg (248.82 KiB) Viewed 126 times
ProblemDescription.pdf
(558.98 KiB) Downloaded 7 times

Mke
Posts: 596
Joined: 15 Jun 14 15:39

Re: Keyword handling problems

Post by Mke » 19 Jul 21 15:06

I have no problem importing the photo; all the catalog labels appear and all can be deleted. Which doesn't help in fixing it, of course...

CatLabels.png
CatLabels.png (3.3 KiB) Viewed 117 times

Hert
Posts: 6874
Joined: 13 Sep 03 7:24

Re: Keyword handling problems

Post by Hert » 19 Jul 21 15:56

Can you share a screenshot of your Synchronize settings for Writing (see Preferences). It's this one:
SyncSettings.png
SyncSettings.png (79.03 KiB) Viewed 114 times
This is a user-to-user forum. If you need product support then please send a message

Ulrich
Posts: 7
Joined: 14 Jul 21 12:59

Re: Keyword handling problems

Post by Ulrich » 19 Jul 21 18:07

Sure,
here they are.

Thanks' for your help!
Attachments
1.png
1.png (51.41 KiB) Viewed 104 times
2.png
2.png (13.03 KiB) Viewed 104 times
3.png
3.png (44.78 KiB) Viewed 104 times
4.png
4.png (6.39 KiB) Viewed 104 times

Hert
Posts: 6874
Joined: 13 Sep 03 7:24

Re: Keyword handling problems

Post by Hert » 19 Jul 21 18:39

Thank you. That’s what I figured.

You have your write setting config set to “merge”, meaning that catalog labels will be merged with keywords. And so in the end this #4 keywords remains.

Set that to “replace”.
Even better: leave all settings at their default. There’s a button to reset it to default.
This is a user-to-user forum. If you need product support then please send a message

Ulrich
Posts: 7
Joined: 14 Jul 21 12:59

Re: Keyword handling problems

Post by Ulrich » 20 Jul 21 6:11

OK, I set everything to the default.
Look good for now!
Thank you for your help! :D

Post Reply