Public Beta for Photo Supreme Online

Hert
Posts: 6874
Joined: 13 Sep 03 7:24

Re: Public Beta for Photo Supreme Online

Post by Hert » 07 Jan 21 14:30

The beta is silently updated every now and then. Progress is mostly in the backend. Make sure to install the software as explained in the PDF in the opening post here.
If you become an active user of the PSO beta then please report here.
This is a user-to-user forum. If you need product support then please send a message

Dismayed
Posts: 46
Joined: 22 Sep 09 21:42
Location: Boston, MA

Re: Public Beta for Photo Supreme Online

Post by Dismayed » 11 Jan 21 5:28

I just installed the PSO software. It works, but I don't have much catalogued yet, so more feedback will come in the coming weeks.
“There are three kinds of men. The ones that learn by readin’. The few who learn by observation.
The rest of them have to pee on the electric fence for themselves.”
~ Will Rogers

Hert
Posts: 6874
Joined: 13 Sep 03 7:24

Re: Public Beta for Photo Supreme Online

Post by Hert » 11 Jan 21 10:29

That's great! Looking forward to your feedback
This is a user-to-user forum. If you need product support then please send a message

Username
Posts: 280
Joined: 18 Feb 18 22:21

Re: Public Beta for Photo Supreme Online

Post by Username » 08 Feb 21 14:32

Sorry for a longer time of absence.

Anyway, the naming of downloaded jpegs still contain the full source path instead of it's name only.
_Volumes_filmstaden_Foto_Fotografier Nikon NEF - Original_2020_01_10__ACT6341.NEF.jpg

Should be:
_ACT6341.NEF.jpg
PSu Server 6 & Postgres 12 on macOS 10.15
PSO 6 on Windows Server 2016

- I'm the user

gcurrie
Posts: 39
Joined: 02 May 10 2:55

Re: Public Beta for Photo Supreme Online

Post by gcurrie » 04 May 21 21:05

I just installed this on my server after upgrading to PS 6.

If I open a browser on my LAN to 192.168.1.101:8081 then it immediately redirects to 192.168.1.101:8081/#/. At the bottom of the browser window is a line "The service is currently unavailable. Please try again later."

The firewall shows that Photo Supreme Web Service module is allowed through Domain/Private/Public. The service is running.

Any ideas on what to look at?

[edit] If I remote into my server, I can run PSO. It just cannot communicate with the rest of the LAN.
[edit2] I initially neglected to change the Web Config API Url to 192.168.1.101 from localhost. Working now.
Gordon Currie
Photo Supreme 6.1 PostgreSQL on Windows Server Essentials 2016

gcurrie
Posts: 39
Joined: 02 May 10 2:55

Re: Public Beta for Photo Supreme Online

Post by gcurrie » 05 May 21 0:18

I can now see the Photo Supreme Online window, with a login box.

I tried to login with Photo Supreme user/passwords, but it seems to ONLY want postgres as the username.

error: Cannot load options; [FireDAC][Phys][pg][libpg] password authentication failed for user "postgres"

followed by

error: fail to handle API request (stage beforeExecution) [FireDAC][Phys][pg][libpg] password authentication failed for user "postgres"
Gordon Currie
Photo Supreme 6.1 PostgreSQL on Windows Server Essentials 2016

Hert
Posts: 6874
Joined: 13 Sep 03 7:24

Re: Public Beta for Photo Supreme Online

Post by Hert » 05 May 21 12:58

You should enter your Photo Supreme username and password in the login page, not your PostgreSQL username and password.

But based on your error, it looks like you have not entered the correct PostgreSQL password in the configuration dialog. Please run through the configuration settings again and use the test button to test the connection to your database. You can find it in the Windows menu.
This is a user-to-user forum. If you need product support then please send a message

gcurrie
Posts: 39
Joined: 02 May 10 2:55

Re: Public Beta for Photo Supreme Online

Post by gcurrie » 05 May 21 16:31

In the configuration, the PostgreSQL password is correct, as I can use the Test button and it reports a connection. On both main and thumbs database.

I enter the Photo Supreme User/password for that machine (not the PostgreSQL user/password).
Gordon Currie
Photo Supreme 6.1 PostgreSQL on Windows Server Essentials 2016

gcurrie
Posts: 39
Joined: 02 May 10 2:55

Re: Public Beta for Photo Supreme Online

Post by gcurrie » 05 May 21 23:26

Follow up - I rebooted the server and the authentication now works as designed.

I'll post more as soon as I use it more. Looks very useful here as we sometimes just want to review or display photos without using the full program.

I'm guessing that I can use ANY modern device with a browser to display? If so, that is even more useful, as I can use an iPhone or iPad for browsing images.
Gordon Currie
Photo Supreme 6.1 PostgreSQL on Windows Server Essentials 2016

Hert
Posts: 6874
Joined: 13 Sep 03 7:24

Re: Public Beta for Photo Supreme Online

Post by Hert » 06 May 21 12:47

Great that you're up and running.
I'm guessing that I can use ANY modern device with a browser to display? If so, that is even more useful, as I can use an iPhone or iPad for browsing images.
Yes you can :)
This is a user-to-user forum. If you need product support then please send a message

Hert
Posts: 6874
Joined: 13 Sep 03 7:24

Re: Public Beta for Photo Supreme Online

Post by Hert » 13 Jul 21 11:52

The installer was updated to support the recent changes and performance improvement...those benefits also apply to PSO.
This is a user-to-user forum. If you need product support then please send a message

Post Reply