Import CSV Data

Post Reply
RobertB
Posts: 11
Joined: 31 May 20 15:01

Import CSV Data

Post by RobertB » 02 Aug 20 1:08

I am using the "Import CSV Data" script to load some keywords from a CSV file (first line in file is FileName,dc:subject). The keywords are loaded properly to Keywords under Details and the corresponding Catalog Labels are properly created. However the existing Catalog Labels for the file are removed. Any idea why this may be happening?

Thanks

Hert
Posts: 6342
Joined: 13 Sep 03 7:24

Re: Import CSV Data

Post by Hert » 02 Aug 20 18:08

Check in your Preferences-Read settings. There you probably have configured that keywords should replace catalog labels. Set that to merge.

But Replace is in a daily operation the better choice so I recommend to set it back to replace after the import.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

RobertB
Posts: 11
Joined: 31 May 20 15:01

Re: Import CSV Data

Post by RobertB » 02 Aug 20 19:24

Under the tab Read settings I changed "Keywords processing" to "Merge keywords with existing Catalog labels" but the results are the same.

Hert
Posts: 6342
Joined: 13 Sep 03 7:24

Re: Import CSV Data

Post by Hert » 03 Aug 20 9:43

I just had a quick look at the script and the script is the one that removes the catalog labels if keywords are part of the import. You can disable line 164 to prevent that by adding two slashes in front of it. This is how that should become:

Code: Select all

        if AReconstruct then
        begin
          //PublicCatalog.RemovePropsFromItem(ACatItem);
          PublicCatalog.ReConstructFromXMPObjectKeywords(ACatItem, AXmp, PublicOptions.XMPSyncReadSettings, False);
        end;
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

RobertB
Posts: 11
Joined: 31 May 20 15:01

Re: Import CSV Data

Post by RobertB » 05 Aug 20 0:26

That works.

Thanks!

Post Reply