Not launching on macos

Post Reply
Al_M
Posts: 23
Joined: 21 Jun 19 14:09
Location: Kansas City, USA

Not launching on macos

Post by Al_M » 25 May 20 15:56

This morning I tried to open PSu on my laptop (Macbook Pro) and PSu will not open. No messages, no bouncing dock icon, nothing.

First I tried a re-boot. Same thing.

Then I tried to re-install. Same thing.

Then I tried deleting plist. Same thing.

I did a complete un-install and re-install.

Still nothing....

So I launched again while watching the system console. Here is what the console messages displays:
default 11:46:07.069648-0500 Dock LAUNCHING:0x0-0x62062 Photo Supreme foreground=1 bringForward=1 seed=142 userActivityCount=0
default 11:46:07.077955-0500 loginwindow -[PersistentAppsSupport applicationReady:] | App: Photo Supreme, ready, updating active tracking timer
default 11:46:07.078032-0500 loginwindow -[ApplicationManager checkInAppContext:eventData:] | ApplicationManager: Checked in app : Photo Supreme
default 11:46:07.129867-0500 IDimagerSU Current system appearance, (HLTB: 2), (SLS: 1)
default 11:46:07.132884-0500 IDimagerSU Post-registration system appearance: (HLTB: 2)
fault 11:46:07.180571-0500 IDimagerSU Invalid dylib load. Clients should not load the unversioned libcrypto dylib as it does not have a stable ABI.
fault 11:46:07.180901-0500 IDimagerSU Invalid dylib load. Clients should not load the unversioned libssl dylib as it does not have a stable ABI.
default 11:46:07.181406-0500 IDimagerSU Received configuration update from daemon (initial)
default 11:46:07.187901-0500 IDimagerSU FRONTLOGGING: version 1
default 11:46:07.187918-0500 IDimagerSU Registering, pid=1475
default 11:46:07.188673-0500 IDimagerSU CHECKIN: pid=1475
default 11:46:07.204941-0500 IDimagerSU CHECKEDIN: pid=1475 asn=0x0-0x62062 foreground=1
default 11:46:07.206664-0500 loginwindow -[ApplicationManager checkInAppContext:eventData:] | ApplicationManager: Checked in app : Photo Supreme
default 11:46:07.208600-0500 IDimagerSU Registered, pid=1475 ASN=0x0,0x62062
default 11:46:07.208847-0500 IDimagerSU Registered, pid=1475 cgConnectionID=7fabb
default 11:46:07.210638-0500 IDimagerSU BringForward: pid=1475 asn=0x0-0x62062 bringForward=1 foreground=1 uiElement=0 launchedByLS=1 modifiersCount=1 allDisabled=0
default 11:46:07.210697-0500 IDimagerSU BringFrontModifier: pid=1475 asn=0x0-0x62062 Modifier 0 hideAfter=0 hideOthers=0 dontMakeFrontmost=0 mouseDown=0/0 seed=0/0
default 11:46:07.210984-0500 IDimagerSU BringForward: pid=1475 asn=0x0-0x62062
default 11:46:07.211180-0500 IDimagerSU SetFrontProcess: asn=0x0-0x62062 options=0
default 11:46:07.299916-0500 loginwindow -[PersistentAppsSupport applicationQuit:] | for app:Photo Supreme, _appTrackingState = 2
default 11:46:07.299948-0500 loginwindow -[PersistentAppsSupport applicationQuit:] | App: Photo Supreme, quit, updating active tracking timer
Funny thing is that its working fine on my desktop (Mac Pro) with the same PSu version (Single-user 5.4.1 build 2929) and macOS version (10.15.4).

Any ideas?
Photo Supreme V5 Server Edition (build 2971)
PostgreSQL 12
macOS 10.15.4 (Catalina)
Mac Pro (Late 2013), 3.0 GHz 8-Core Xeon E5, 64 GB DDR3
MacBook Pro (Mid 2015), 2.5 GHz Quad-Core i7, 16 GB DDR3L

Hert
Posts: 6256
Joined: 13 Sep 03 7:24

Re: Not launching on macos

Post by Hert » 26 May 20 14:34

Thank you for message. These two lines are apparently killing your instance;

Code: Select all

fault 11:46:07.180571-0500 IDimagerSU Invalid dylib load. Clients should not load the unversioned libcrypto dylib as it does not have a stable ABI.
fault 11:46:07.180901-0500 IDimagerSU Invalid dylib load. Clients should not load the unversioned libssl dylib as it does not have a stable ABI.
PSU doesn't deploy these files and uses whatever is already on your system. The files are part of openSSL.
Apparently you have/had some software installed that comes with "unversioned" dylibs which macOS 10.15.4 doesn't like.
Your desktop is probably a newer installation than your laptop or at one point you've installed software on the laptop that wrote new openSSL libraries and overwrote the ones from macOS.

PSU will come with an update that eliminates openSSL completely (openSSL was already abandoned in build 2756). But keep in mind that you will have communication problems with any other software on your laptop that uses openSSL (most application use openSSL). This simply because the versions that you have installed will not load
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Hert
Posts: 6256
Joined: 13 Sep 03 7:24

Re: Not launching on macos

Post by Hert » 26 May 20 15:12

In build 2935 (now on the website), the dependency on openSSL libraries was removed. Can you run PSU on the laptop now?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Al_M
Posts: 23
Joined: 21 Jun 19 14:09
Location: Kansas City, USA

Re: Not launching on macos

Post by Al_M » 27 May 20 22:20

Hert,

Thank you for quickly implementing a preventive measure.
However, I was able to isolate the issue to just my user account. I logged into my “Admin” account (for troubleshooting) and found that I could run PSu (in trial mode since the license is on the other user account Documents folder).
So whatever made changes as you described was only affecting my account. I created a new user account and migrated all my files to it. All is well again.
Sorry I was not able to test your latest build in the affected account as I deleted it.
Photo Supreme V5 Server Edition (build 2971)
PostgreSQL 12
macOS 10.15.4 (Catalina)
Mac Pro (Late 2013), 3.0 GHz 8-Core Xeon E5, 64 GB DDR3
MacBook Pro (Mid 2015), 2.5 GHz Quad-Core i7, 16 GB DDR3L

Post Reply