Find missing thumbnails

Sigi
Posts: 33
Joined: 07 Mar 19 8:28

Find missing thumbnails

Post by Sigi » 14 Mar 20 16:03

Hello,
out of curiosity I clicked on "Find missing thumbnails" for the whole catalog . PSU did it's thing and found 249 missing thumbnails and then built those missing thumbnails.
After that I checked again and PSU found again 249 missing thumbnails. I did it a 3rd time and again 249 missing thumbnails.

Is this a bug or am I missing something.

Thanks

Hert
Posts: 6439
Joined: 13 Sep 03 7:24

Re: Find missing thumbnails

Post by Hert » 14 Mar 20 16:26

Looks like PSU can't build a thumb for these 249 files. Try looking up one of them.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Sigi
Posts: 33
Joined: 07 Mar 19 8:28

Re: Find missing thumbnails

Post by Sigi » 14 Mar 20 16:51

Just had a look in a folder which was listed a few times during "building thumbnails" and nothing special. All thumbnails there as far as I can see.

User avatar
G8DHE
Posts: 247
Joined: 21 Aug 17 13:58

Re: Find missing thumbnails

Post by G8DHE » 14 Mar 20 19:41

Must admit I've been finding this of late, using the Filters with "Filter without thumbnail" on the entire collection gives me this, I assume that perhaps its Thumbnails&Previews that might be missing but can't see anything that's actually wrong, even when opening the Preview window ?
Even tried Removing such files from the database, and then re-importing them, cures it initially but they then seem to return after a short while.
Image

Oh and its happening on both this smaller database on the laptop as well as the much larger one on the main workstation.
Geoff Mather (G8DHE)

Sigi
Posts: 33
Joined: 07 Mar 19 8:28

Re: Find missing thumbnails

Post by Sigi » 18 Mar 20 18:58

Hert - any idea what could be the cause?

Hert
Posts: 6439
Joined: 13 Sep 03 7:24

Re: Find missing thumbnails

Post by Hert » 18 Mar 20 19:43

Probably the preview is missing. And since you get it every time, that probably means no preview can be built. Open the image in the viewer. Is there a preview? What file format is it? And if you select the file and press Cmd+Alt+T to update the thumb and preview manually.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Sigi
Posts: 33
Joined: 07 Mar 19 8:28

Re: Find missing thumbnails

Post by Sigi » 19 Mar 20 7:46

Hello Hert,

I did now "Build missing thumbnails and rebuild" It found 249 and PSU rebuilt the thumbnails. After that I filtered for missing thumbnails like Geoff above. I get now 228 files listed but ALL with a nice thumbnail. Same result like you see in the screenshot from Geoff above.

Could other forum members run the same test? Would be interesting to see their outcome.

Sigi

Hert
Posts: 6439
Joined: 13 Sep 03 7:24

Re: Find missing thumbnails

Post by Hert » 19 Mar 20 8:58

You see thumbnails, but there are thumbnails and previews. likely you have a thumbnail but no preview.

Did you try Cmd+Opt+T to manually rebuild the thumb and preview? Did you open the image and see if you get an instant display (that is the preview while loading the full image)? Also, what image format is this?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Sigi
Posts: 33
Joined: 07 Mar 19 8:28

Re: Find missing thumbnails

Post by Sigi » 19 Mar 20 9:44

We talk mainly Cr2, a few tiff and jpg and a few mov files.
I filtered now for missing thumbnails and used Cmd+Opt+T on all of them.
After that I ran "Build missing thumbnails and rebuild" - this time PSU found 242 instead of 249.
I then filtered again for "missing thumbnails" and found 228 files.
When I double-click on the thumbnails I get an almost instant display

Also clicking spacebar or Shift+Enter on a thumbnail I get an almost instant preview


Sigi

User avatar
G8DHE
Posts: 247
Joined: 21 Aug 17 13:58

Re: Find missing thumbnails

Post by G8DHE » 20 Mar 20 0:24

When you run the "Build missing thumbnails & previews" tool, it says;

Image

Does this mean it is deleting from the thumbs.db Thumbnails & Previews that have not been used in some given time period,
OR
is it only referring to deleting of records where the thumbnails and/or previews have been left from previously deleted images ?
Geoff Mather (G8DHE)

Hert
Posts: 6439
Joined: 13 Sep 03 7:24

Re: Find missing thumbnails

Post by Hert » 20 Mar 20 9:44

Well spotted!! That is it. The cleaning cleans too much :)
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Sigi
Posts: 33
Joined: 07 Mar 19 8:28

Re: Find missing thumbnails

Post by Sigi » 20 Mar 20 12:28

Hert - so you found the solution to the problem?

User avatar
G8DHE
Posts: 247
Joined: 21 Aug 17 13:58

Re: Find missing thumbnails

Post by G8DHE » 20 Mar 20 12:51

I would assume so -
"Build 2777; Fix for Thumb Cleaning, which is called simultaneous with Build Missing Thumbs and Previews"

about to test it now ....
Geoff Mather (G8DHE)

User avatar
G8DHE
Posts: 247
Joined: 21 Aug 17 13:58

Re: Find missing thumbnails

Post by G8DHE » 20 Mar 20 13:12

Seems to have worked OK on my test database, after a clean no additional missing thumbnail etc.

Many tks Hert
Geoff Mather (G8DHE)

Sigi
Posts: 33
Joined: 07 Mar 19 8:28

Re: Find missing thumbnails

Post by Sigi » 20 Mar 20 14:13

For me the problem is not solved. Still the same as with the previous build. This is on Mac, Mojave,everything updated.

Geoff - what system are you using?

Post Reply