Very slow application response with file sets

Post Reply
blpierson
Posts: 2
Joined: 07 Jun 19 18:25

Very slow application response with file sets

Post by blpierson » 10 Oct 19 22:06

I recently imported 900 files - half are .ARW format and half are the corresponding .JPG format. After the import, I assigned all the files a label and then went to a view containing only the labels. Within the view, the files are displayed as sets (one .ARW, one .JPG in each). When I attempt to enter a headline for one set, the response is ridiculously slow - each character takes almost 1 second to be displayed. It then takes a long time for the sync process to start up to record the information. I am having to wait for each data item to be completed, make sure the sync process runs, and then go to the next data item. I tried the same process on an image that was not part of a set - it was just a single. jpg file. Response was as expected. I have backed up the database, compacted the database and the thumbnails, I have restarted the application as well as the computer multiple times, backups are not concurrently running, and virus detection is not concurrent. I am running on an iMac 10.14.6 with 8mb of RAM. When I do any actions with the file sets, the CPU spikes up to 100%+. There is plenty of available memory on the system. Would really appreciate any assistance as I have a lot of pictures that I would like to get processed.

Hert
Posts: 5869
Joined: 13 Sep 03 7:24

Re: Very slow application response with file sets

Post by Hert » 10 Oct 19 22:11

Are you running the latest build (2436)?
https://www.idimager.com/what-s-new-in-photo-supreme-v5

And make sure that you compact your database (Catalog - Compact from the hamburger menu)
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

blpierson
Posts: 2
Joined: 07 Jun 19 18:25

Re: Very slow application response with file sets

Post by blpierson » 11 Oct 19 15:09

Yes, I am on the latest build. The database has been compacted - both primary database (633mb) as well as thumbnail database (13gb). I have about 32K images in the database. Plenty of memory and disk space available. The slow behavior occurs when I am looking at a folder with the images, or in a category view with the images. The cpu usage of the app also stays very high when I have a "set" selected even if I am not doing anything with the app. Example: I went into the folder view and selected a .jpg image. I added a headline (slowly....). The synchronization finished. I went to the browser and also opened up the activity monitor. CPU activity on PhotoSupreme stayed high (90+%) for several minutes - and I am doing nothing at all in the app. I went back to the app and unselected the image. The CPU usage then dropped down to 0%.

Hert
Posts: 5869
Joined: 13 Sep 03 7:24

Re: Very slow application response with file sets

Post by Hert » 11 Oct 19 19:34

What do you mean with “a set selected”? A version set or a stack or a set of selected thumbs? I just tried it again here and entering texts in the details is as usual.
Maybe you can add some screenshots or even better a video to illustrate
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Post Reply