Building Thumbnails

Post Reply
MikeNaylor
Posts: 102
Joined: 13 Nov 16 14:40
Location: Spain
Contact:

Building Thumbnails

Post by MikeNaylor » 03 May 19 17:43

Is there a way to prevent PSu re-Building Thumbnails for no apparent reason? Every time this happens (which seems to be every time I click on anything), the program become unresponsive and I have to wait a very long time till it finishes.
Apple iMac (Retina 5K, 27-inch, Late 2015), macOS Mojave, Photo Supreme 4, Lightroom CC Classic.

fbungarz
Posts: 3187
Joined: 08 Dec 06 5:03
Location: Arizona, USA

Re: Building Thumbnails

Post by fbungarz » 04 May 19 1:47

The program builds thumbnails and previews only once. Though building the thumbs takes little time, generating the previews may take a long time depending on your settings in preferences >> catalog. the higher the quality & resolution, the longer it may take until all previews are built. A higher quality allows yo to take PSu "on the road", i.e., without having to carry along the images themselves.
If you experience slow-downs, likely you have some demanding settings in your preferences. I have the resolution at 1280 and 85% quality.

If you initially have thousands and thousands of files for which the previews have not been generated it will slow you down a lot. Once all the previews have been built it no longer should be an issue. It is a problem when you start with thousands of images from scratch and load them all into PSu at once. It may take days for the thumbnail/preview database to build. Then, if you routinely import smaller batches it no longer is an issue.

Hert
Posts: 16002
Joined: 13 Sep 03 7:24

Re: Building Thumbnails

Post by Hert » 04 May 19 6:26

Frank is spot on.
In addition; after making many changes to the Catalog, make sure to Compact the database. Make a habit of doing that about once every week.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

MikeNaylor
Posts: 102
Joined: 13 Nov 16 14:40
Location: Spain
Contact:

Re: Building Thumbnails

Post by MikeNaylor » 04 May 19 13:20

The only things I'd clicked on, have imported 400 images and waited for the build to complete, were to select between various panels and inspecting various metadata. I did not change or edit anything and the preferences were as per the default having only just installed it. This was a fresh install, but it quickly became obvious because of coastal RE-Building and spinning balls. It may well be 64 bit, but it's certainly not mufti-threading as one would expect.
Apple iMac (Retina 5K, 27-inch, Late 2015), macOS Mojave, Photo Supreme 4, Lightroom CC Classic.

Hert
Posts: 16002
Joined: 13 Sep 03 7:24

Re: Building Thumbnails

Post by Hert » 05 May 19 6:47

Do you have ICS reading on or off in the preferences-sync-read settings?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Post Reply