Seems I crashed my catalog by verifying the root folder

Post Reply
Robosoc
Posts: 12
Joined: 11 Apr 10 9:56
Location: Germany

Seems I crashed my catalog by verifying the root folder

Post by Robosoc » 21 Feb 21 7:22

Yesterday I updated my PSU to the latest version of PSU 5.
After the update I was asked by the system if I also would like to update my database, which I confirmed.
Everything seems normal and working after that.

I then verified my one and only root folder (a NAS folder) by right click on the folder, and click on "verify all" (not sure if that is exactly the wording, as I am using the german version AND currently I can not check anything anymore, as PSU is frozen.

The verification showed me many changes in all the categories, which was expected by me as I did not do this for a long while and there have been many changes, since my last usage of PSU.

I quickly checked all suggestios and accepted them...the tasks or processes startet right away ... so far everything was normal.

After a while I checked the progress and realized that nothing happend. Many progresses stuck at 0%, only the last two where at 1,5% and 1,7%. Half an hour later there was still no change in this. But PSU seemed to still work. I dicided to close PSU and restart it again and since then PSU directly goes frozen after start (it says in the menubar and task manager "not responding"), when I click into the open programm after start, the programm blures out in grey - see screenshot.
The Task Manager of windows says, that there is activity of the cpu for PSU at ~16-17%.
Screenshot 2021-02-21 071557.jpg
Screenshot 2021-02-21 071557.jpg (24.64 KiB) Viewed 79 times
As you may see in the screenshot at least the folder structure is loaded before freeze.

Any recommandations?
Stupid as I was: Unfortunatly there is no up-to-date backup of the catalog...I could only set up a new project and Import all the metafiles from the images (I mainly do tag-ing and rating with PSU and write thos informations into the file as well. But I fear to loose all settings and folder caegories.

Robosoc
Posts: 12
Joined: 11 Apr 10 9:56
Location: Germany

Re: Seems I crashed my catalog by verifying the root folder

Post by Robosoc » 21 Feb 21 7:29

I add some informations:
  • Moving my three thumbnail database files out of the catalog folder and restarting the PSU application did not help unfortunatly. The programm still freezes and the thumb-files are not generated from skretch (I did not expect that either, as I am not able to rebuild the thumbnails in PSU, just wanted to add this in case this is of interest somehow).
  • Moving all six catalog files out of the catalog folder and restarting PSU, leads to the point where I can start a brand new catalog - as expected - which works out. So it points me to the conclusion, that I destroyd my catalog somehow.
  • And I tried severyl hours to keep PSU active in the froozen state. As there is CPU activity I hoped there is someting going on in the backgroud that will be done after a long while. Was not the case until now.

Robosoc
Posts: 12
Joined: 11 Apr 10 9:56
Location: Germany

Re: Seems I crashed my catalog by verifying the root folder

Post by Robosoc » 21 Feb 21 7:44

Now I realized that with the brand new and empty catalog there only exist two permanent catalog and thumbnail files...not six. So 4 ofthem are only temporary and do vanish after closing PSU by itself. That was not the case, when I used my crashed databases...

So I deleted the two new files of the catalog I just build to test PSU without my big "crashed" catalog.
I then moved back only the relevant files idimager.cat and idimager.thumbs from my "crashed" collection, but not the 4 other files (idimager.cat.db-shm, idimager.cat.db-wal, idimager.thumbs.db-shm, idimager.thumbs.db-wal)

AND YEEEAAAH, it seems as PSU works again with all my datan kept...first thing is a backup now :-)

Post Reply