Crash calling Build Missing Thumbnails and Previews

Post Reply
Sigi
Posts: 55
Joined: 07 Mar 19 8:28

Crash calling Build Missing Thumbnails and Previews

Post by Sigi » 19 Feb 21 8:59

Hello,

Working on my test catalog - around 14000 files in there - if I click on Tools "Build Missing Thumbnails and Previews" I have a crash.
This happens consistently. I am on Mac, Catalaina, all updated.

Sigi

[Edit Hert; updated the topic title to better describe the topic]

Hert
Posts: 6682
Joined: 13 Sep 03 7:24

Re: V6 - Crash

Post by Hert » 19 Feb 21 9:17

Is that while building thumbs and previews?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Sigi
Posts: 55
Joined: 07 Mar 19 8:28

Re: Crash calling Build Missing Thumbnails and Previews

Post by Sigi » 19 Feb 21 10:29

yes

Sigi
Posts: 55
Joined: 07 Mar 19 8:28

Re: Crash calling Build Missing Thumbnails and Previews

Post by Sigi » 19 Feb 21 11:44

just updated to the latest build - same problem.
It starts the process and after about 10sec I have a crash.

Hert
Posts: 6682
Joined: 13 Sep 03 7:24

Re: Crash calling Build Missing Thumbnails and Previews

Post by Hert » 19 Feb 21 12:51

I'm not having a crash when using Build Missing Thumbs and Previews. Tried on an Intel and an M1 machine, both running macOS 11.2.1.
Also tried on a test machine running Mojave 10.14.6 without issues.

Maybe you can provide additional information? An Apple crash report or a PSU report?
And did you check that if there is sufficient disk space on the system drive?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Sigi
Posts: 55
Joined: 07 Mar 19 8:28

Re: Crash calling Build Missing Thumbnails and Previews

Post by Sigi » 19 Feb 21 13:24

I will send the Apple crash report. Disk space is OK 1.9 TB used of a 3TB fusion drive.

paulrbarnard
Posts: 28
Joined: 14 Dec 18 15:55

Re: Crash calling Build Missing Thumbnails and Previews

Post by paulrbarnard » 19 Feb 21 17:34

Just sent a problem report. I have a similar crash. In my case it is when the verify folder finds catalogue entries for missing files. Selecting to remove the files results in a crash. It might be related as the synchronise process runs which seems to be the trigger for my crash. V6 3556 running on macOS 11.2.1 (Big Sur)

paulrbarnard
Posts: 28
Joined: 14 Dec 18 15:55

Re: Crash calling Build Missing Thumbnails and Previews

Post by paulrbarnard » 19 Feb 21 17:55

OK mine just crashed building thumbnails as well.

crash log

Process: IDimagerSU [52727]
Path: /Applications/Photo Supreme.app/Contents/MacOS/IDimagerSU
Identifier: com.idimager.idimagersu
Version: 6.0.0 (3556)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: IDimagerSU [52727]
User ID: 502

Date/Time: 2021-02-19 16:50:39.755 +0000
OS Version: macOS 11.2 (20D5029f)
Report Version: 12
Bridge OS Version: 3.0 (14Y908)
Anonymous UUID: DFFA8C60-172A-8080-D930-85E5F467FDF7

Sleep/Wake UUID: A4E6E313-A0CD-4B1B-BF9D-F7B4EB33D52F

Time Awake Since Boot: 220000 seconds
Time Since Wake: 1600 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGILL)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: IDimagerSU [52727]

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.idimager.idimagersu 0x000000010003dca0 CLASSES$_$TSTRINGS_$__$$_CHECKSPECIALCHARS + 0
1 com.idimager.idimagersu 0x000000010003f4c1 CLASSES$_$TSTRINGS_$__$$_GETTEXTSTR$$ANSISTRING + 105
2 com.idimager.idimagersu 0x000000010055e5f5 UXOMNOTIFIER$_$TXOMSYNCTHREADOBJECT_$__$$__EXECUTE + 469
3 com.idimager.idimagersu 0x0000000100373875 COCOAINT$_$TCOCOAWIDGETSET_$__$$_APPPROCESSMESSAGES + 229
4 com.idimager.idimagersu 0x00000001000641f1 FORMS$_$TAPPLICATION_$__$$_PROCESSMESSAGES + 89
5 com.idimager.idimagersu 0x000000010045d287 TNTFORMS_$$_TNTPROCESSMESSAGES + 31
6 com.idimager.idimagersu 0x000000010055e5f5 UXOMNOTIFIER$_$TXOMSYNCTHREADOBJECT_$__$$__EXECUTE + 469
7 com.idimager.idimagersu 0x0000000100373875 COCOAINT$_$TCOCOAWIDGETSET_$__$$_APPPROCESSMESSAGES + 229
8 com.idimager.idimagersu 0x0000000100066185 FORMS$_$TAPPLICATION_$__$$_HANDLEMESSAGE + 45
9 com.idimager.idimagersu 0x000000010006665f FORMS$_$TAPPLICATION_$__$$_RUNLOOP + 79
10 com.idimager.idimagersu 0x00000001003734b7 -[TCocoaApplication run] + 71
11 com.idimager.idimagersu 0x000000010037378a COCOAINT$_$TCOCOAWIDGETSET_$__$$_APPRUN$TAPPLICATIONMAINLOOP + 106
12 com.idimager.idimagersu 0x0000000100066607 FORMS$_$TAPPLICATION_$__$$_RUN + 95
13 com.idimager.idimagersu 0x0000000100001c28 P$IDIMAGERSU_$$_MAIN + 1424


[edit hert; truncated the Apple Report to the relevant part]

Sigi
Posts: 55
Joined: 07 Mar 19 8:28

Re: Crash calling Build Missing Thumbnails and Previews

Post by Sigi » 19 Feb 21 18:02

Interesting - seems I am not alone. It worked perfectly in V5. I have not changed anything.

Hert
Posts: 6682
Joined: 13 Sep 03 7:24

Re: Crash calling Build Missing Thumbnails and Previews

Post by Hert » 22 Feb 21 11:01

This should be resolved in build 3562. Can you confirm this? Thank you
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Sigi
Posts: 55
Joined: 07 Mar 19 8:28

Re: Crash calling Build Missing Thumbnails and Previews

Post by Sigi » 22 Feb 21 15:02

Yes, it works. I can confirm. Building thumbnails right now and no crash.

Post Reply