wrong next/prev image displayed in preview and full screen viewer

Post Reply
snowman1
Posts: 304
Joined: 01 Jan 07 3:13
Location: UK

wrong next/prev image displayed in preview and full screen viewer

Post by snowman1 » 19 Feb 21 0:05

I'm seeing a really odd effect, one I've never noticed before. Either I'm tired and doing something stupid or possibly it's a bug. I'm on the latest V5 version.

I have a selected a label in the categories panel. I am then filtering the images - in this case any image that has a colour label assigned. Images are being sorted by photodate ascending.

In preview mode, or full screen viewer, if I press right arrow for next image, I don't always get the image I'm expecting - I'm expecting the next one in the sequence displayed in the thumbnail view but am getting another one. Same if I use left arrow to go back. In fact if I go right 4 times (say) and left 4 times I won't see the same pictures.

It seems random what will come up but the images shown are all from the filtered set, i.e. all from the selected label and with a colour label assigned.

Happy to raise in Mantis.
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

snowman1
Posts: 304
Joined: 01 Jan 07 3:13
Location: UK

Re: wrong next/prev image displayed in preview and full screen viewer

Post by snowman1 » 19 Feb 21 11:32

No joy, still does it. I'd also previously restarted PSU and compacted the database when prompted on the restart.
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

Hert
Posts: 6682
Joined: 13 Sep 03 7:24

Re: wrong next/prev image displayed in preview and full screen viewer

Post by Hert » 19 Feb 21 11:40

Close the viewer
Press F5 (or Cmd+R on macOS) to reload the active collection
Try again
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Post Reply