Not Responding

Post Reply
vkfoto
Posts: 192
Joined: 19 Oct 16 3:51

Not Responding

Post by vkfoto » 05 Jan 21 0:40

What could make PSU not respond?
I open the application and change to Folders
I click on the black triangle beside the path to the images to expand the view and everything freezes. Task Master shows 0% CPU and 0% Disk. The catalog is excluded from my anti-virus.In Explorer I can quickly see all of the folders and their images.-
How long should I wait?

vkfoto
Posts: 192
Joined: 19 Oct 16 3:51

Re: Not Responding

Post by vkfoto » 05 Jan 21 3:06

Don't know if it's me but after forcing PSu to close and rebooting since there was a not Responding instance in memory (as per Resource monitor) that was not showing in Task Manager. Restarted PSu and this time i couldn't even go to the Folders before everything froze. 2021 is not starting very well as far as my DAM is concerned.
For what it's worth, these four are always left, even the 0 byte ones.
frozen leftovers.JPG
frozen leftovers.JPG (20.8 KiB) Viewed 216 times
Leaving them or deleting them makes no difference to the freezing

vkfoto
Posts: 192
Joined: 19 Oct 16 3:51

Re: Not Responding

Post by vkfoto » 05 Jan 21 3:37

Ah, I think it WAS me. While looking at my disks, I saw the photo drive (SSD) was getting full. All those back ups take up a lot of space. After deleting half of them, PSu started normally again.

note to self, make sure the PSu catalog has lots of free space.

User avatar
G8DHE
Posts: 277
Joined: 21 Aug 17 13:58

Re: Not Responding

Post by G8DHE » 05 Jan 21 12:08

There all part of your database Write Ahead Logic see https://www.sqlite.org/walformat.html#t ... r_shm_file
Geoff Mather (G8DHE)

Hert
Posts: 6564
Joined: 13 Sep 03 7:24

Re: Not Responding

Post by Hert » 05 Jan 21 12:12

Indeed, and you should never delete these SHM and WAL files. SQLite will handle those when it opens the database again. Deleting the SHM or WAL files may cause permanent corruption.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

vkfoto
Posts: 192
Joined: 19 Oct 16 3:51

Re: Not Responding

Post by vkfoto » 23 Jan 21 5:01

Well now my SSD drive has lots of room. I only tried to select a second image in the same folder in order to apply the same labels. I held down the Ctrl key and before I could select the second image PSU became not responding. Task Manager shows 0% CPU, Disk and Network activity for IDimagerSU. It is still using 301.1 MB of memory. It doesn't seem to matter how long I wait, it never comes back. If I close PSU, Resource Monitor reports there is still an IDimagerSU in suspended mode.The only way to close that is to reboot.

Hert
Posts: 6564
Joined: 13 Sep 03 7:24

Re: Not Responding

Post by Hert » 23 Jan 21 12:49

Kill the hanging process in Windows Task Manager and start PSU again. If you can reproduce this then please let me know
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

vkfoto
Posts: 192
Joined: 19 Oct 16 3:51

Re: Not Responding

Post by vkfoto » 23 Jan 21 14:48

Sometime during the night it untangled itself and by morning memory usage had shot up to over 1000 MB. I was able to complete that action I started before it became not responding. Then closed and restarted PSU, just to start fresh. Is that a lot for only 641 images? It's a new database for scanned photos that will eventually be integrated into the main photo database.

Post Reply