Problem batch assigning metadata

Post Reply
babarnc
Posts: 18
Joined: 20 Jun 20 12:13

Problem batch assigning metadata

Post by babarnc » 30 Jun 20 15:31

I have Imported all my photos from lightroom and encouter the following issues:
  • for some reason a lot of photos from place "A" get the proper label - BUT- many photos whose iptc fields are correctly set to place "A" do not get the label
=> how can we force PSU to read the iptc/xmp field and reassign the label correctly
  • Some of my photos are set to country "A" city "B" and some photos of the same batch are set to Country "A" only .So when I select all of the photos including the photos with city "B" and try to write in the corresponding iptc field - city "B" nothing seems to happen
    However if I select just a few photos (with country "A" and city "B" AND country "A" only) then the photos that did not have city "B" as city get the city "B" assigned
    => so I do not understand how to batch edit the iptc/xmp field. I do not undersatnd what I do wrong
One thing I noticed also and that could be improved:

when you select several photos some of which have a given iptc/xmp field with a value and some of which do not have a value for this field: the field appears empty.
It would be nice to have a different behavior:
  • if the value is the same for all the photos and there is no empty field, then the textbox should be filled with the common value
  • if the value is the same for most photos and the other photos have no value for this field, then the textbox should be filled with the common value and use a special police such as italic or gayedout police - this way people understand that among the selection some photos have no value for the reviewed iptc/xmp field - clicking on the textbox should propose to complete the field with the common value so that the photos missing the value get it as well
  • if the value is different from one photos to another then the textbox should display a "mixed value" text in italic, clicking on the textbox should propose to complete the field with a list of the available values
To have a drop down list of choice is nice as it avoids misspelling which would end-up in creating a new label

The green button that appears next to each text box when you select sevral photos could also be used :
  • green = all photos have the same value
  • orange = most photos have a common value, some have no value
  • red = photos have mixed values

Hert
Posts: 6250
Joined: 13 Sep 03 7:24

Re: Problem batch assigning metadata

Post by Hert » 01 Jul 20 0:41

If your metadata in IPTC-IIM is not in-sync with XMP then that is something you must fix, because PSU is fully XMP driven and keeps IPTC-IIM in sync. Fix with right click-Metadata-Convert metadata to XMP.
btw Lightroom is also fully XMP driven so IPTC should already be in XMP
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

babarnc
Posts: 18
Joined: 20 Jun 20 12:13

Re: Problem batch assigning metadata

Post by babarnc » 01 Jul 20 18:19

Hi Hert
thats my issue All of my data are both in iptc and xmp. I do not know what happened here. I first thought it was a refresh issue but no.
By the way I have many refresh issue. Like if I add a label it does not refresh its counter until I collapse all labels and redevelop them...

Post Reply