Wrong image counts in Catalog Tree

Hert
Posts: 6356
Joined: 13 Sep 03 7:24

Re: Wrong image counts in Catalog Tree

Post by Hert » 15 Aug 20 6:19

Let’s start with installing the client libraries for 12. They will most probably also work for a 9.x server. If that doesn’t help then the next try is to upgrade to 12 server.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

gcurrie
Posts: 34
Joined: 02 May 10 2:55

Re: Wrong image counts in Catalog Tree

Post by gcurrie » 15 Aug 20 23:29

Installing newest version and selecting PostgreSQL 12 (to install client libraries) did not work.

Is there a guide anywhere to upgrading the server AND how to upgrade the PS database? It's been a few years.
Gordon Currie
Photo Supreme 5.4 PostgreSQL on Windows Server Essentials 2016

Hert
Posts: 6356
Joined: 13 Sep 03 7:24

Re: Wrong image counts in Catalog Tree

Post by Hert » 17 Aug 20 8:46

The Quick Start Maintenance manual is now updated with a chapter about upgrading to a new PostgreSQL version. You can find the manual in the left sidebar's <<?>> icon.
Please let me know if you have additional questions
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

gcurrie
Posts: 34
Joined: 02 May 10 2:55

Re: Wrong image counts in Catalog Tree

Post by gcurrie » 21 Aug 20 3:19

I finally was able to update PostgreSQL to v 12. After restoring the databases, the Timeline counts returned (and expanding the years works).

Maybe it was corruption in the db? No idea, but it stopped working no more than a month ago, and there were no other odd behaviors.

Is there an updated version of QuickInstall-PostgreSQL9-PhotoSupreme.pdf? And are there updated optimization suggestions for pg_hba.conf and postgresql.conf?

Thanks for the help!
Gordon Currie
Photo Supreme 5.4 PostgreSQL on Windows Server Essentials 2016

Hert
Posts: 6356
Joined: 13 Sep 03 7:24

Re: Wrong image counts in Catalog Tree

Post by Hert » 21 Aug 20 8:20

Great that the upgrade works. Seems like 9.x is starting to show its age then.

The instructions for PostgreSQL 12 can be found here:
https://manualsu.idimager.com/version5/ ... upreme.pdf
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Bongo
Posts: 25
Joined: 22 Mar 10 19:11

Re: Wrong image count of sub collections

Post by Bongo » 26 Sep 20 16:12

This seems to have been a problem with the server version.

I have the single edition Build 3143 with the current Windows 10. The same as Alfons. The count is also zero.
Hert wrote:
29 Jul 20 16:19
Apparently you only have this in your catalog. Please send me a copy of your catalog database (no thumbs needed) if you like me to look into this.
Was there a solution to this?
Regards, Bongo
Photo Supreme V5 Single User Edition, Windows 10.

Hert
Posts: 6356
Joined: 13 Sep 03 7:24

Re: Wrong image counts in Catalog Tree

Post by Hert » 27 Sep 20 17:57

This seems to have been a problem with the server version.
This was always in the Single Edition, not the Server Edition

This is fixed for the next build.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Alfons
Posts: 53
Joined: 03 Mar 10 19:05

Re: Wrong image counts in Catalog Tree

Post by Alfons » 29 Sep 20 14:49

This is fixed with build 3157. The image numbers are now displayed correctly.

Post Reply