V5 still running slow for me with external monitor

Post Reply
greenorange
Posts: 2
Joined: 28 May 20 12:26

V5 still running slow for me with external monitor

Post by greenorange » 28 May 20 12:38

Hi,

I've been using Photo Supreme for a while now, after migrating from IViewMedia. For a while, everything worked fine, but since at least a few weeks assigning catalog labels has become veeery slow, indeed... It's not changing with any of the new updates.

I've read that there were problems if one is working on a laptop with an additional, larger monitor, using only the external monitor for displaying Photo Supreme, the laptop monitor is blank. I've been doing that from the start and in the beginning, it wasn't a problem (not running slow), but now it is. I need to work on the bigger monitor because the other one is just too small.

I'm working on Windows 10 with a database of around 75.000 files. Do you think there will be a solution to this problem in the future and is there a workaround that does not involve disconnecting the external monitor? I don't quite understand what the problem is... Would appreciate some help. Thanks!

Katja

Hert
Posts: 6216
Joined: 13 Sep 03 7:24

Re: V5 still running slow for me with external monitor

Post by Hert » 28 May 20 14:52

The performance issue with displaying on a second monitor was fixed months ago in build 2827 (also see https://whatsnew.idimager.com/).

My first thoughts are:
1. Try to compact the catalog and thumbs/previews database. Use Tools -> Catalog -> Compact from the upper left hamburger menu.
2. Make sure that the catalog database files are stored on your fastest internal drive, preferably an SSD
3. Make sure that the catalog folder is excluded for *any* virus scanner, including Windows' own Defender
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

greenorange
Posts: 2
Joined: 28 May 20 12:26

Re: V5 still running slow for me with external monitor

Post by greenorange » 28 May 20 15:33

Hi Hert,

Thanks so much for your quick answer! The exception for Kaspersky Antivirus did the trick... So happy now :D

Best regards

Katja

Post Reply