PSU hung after importing photos

Hert
Posts: 5874
Joined: 13 Sep 03 7:24

Re: PSU hung after importing photos

Post by Hert » 29 Oct 19 8:30

rfcat wrote:
29 Oct 19 6:20
Hi Hert,
crashed again, bu this time I let it run and the error message was the disk is full, not sure which disk because my main disk has approx 80gb free.
Ian
Go under the Apple menu to About This Mac and then More Info... click on the Storage tab and see how much free space you show remaining. Also note what may be taking up so much room on your internal hard drive. Post a screen shot if you can.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

snowman1
Posts: 250
Joined: 01 Jan 07 3:13
Location: UK

Re: PSU hung after importing photos

Post by snowman1 » 29 Oct 19 13:16

This is unlikely to have any bearing on your case but perhaps worth mentioning just in case: in some circumstances PSU can report the wrong disk in error messages. But this related to the mirror disk, and to it being offline rather than full. https://mantis.idimager.com/view.php?id=3365
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

rfcat
Posts: 56
Joined: 21 Feb 07 11:38
Location: Australia

Re: PSU hung after importing photos

Post by rfcat » 30 Oct 19 4:57

Hi Hert,
deleted lots of stuff and then found why my profile is about 115gb.
Screen Shot 2019-10-30 at 14.54.38.png
Screen Shot 2019-10-30 at 14.54.38.png (43.46 KiB) Viewed 806 times
Ian
Ian M
Photography, understanding how to catalogue so I can find my photos. :D .

rfcat
Posts: 56
Joined: 21 Feb 07 11:38
Location: Australia

Re: PSU hung after importing photos

Post by rfcat » 30 Oct 19 23:21

I will move the PSU library to the new 1TB SSD that I use for storing photos. That should fix the storage space issue.
Ian
Moved the PSU folders and re-ran the compression, took over an hour and ran to successful completion.
Now manually backup then delete the old folder. :D
Ian M
Photography, understanding how to catalogue so I can find my photos. :D .

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Synchronization bug?

Post by Larry56 » 01 Nov 19 19:02

I've been having problems importing to catalog on Windows 10 and PSU 5.1.1.2473 single user. Doing some further testing I find it's not so much importing as synchronizing.

I've tested using 3 cameras - Sony A7iii, Panasonic GX9, Panasonic G9. The A7iii had 82 files imported (RAW+jpg), GX9 had 28 files, G9 had 110 files.

Each camera has its own import profile with one detail profile used on two cameras and a separate detail profile on the other. None have stacking or versioning applied. All files were imported without any problems. Detail profiles were only copyright and creator info.

In each case the problem was when Activity went to Synchronize. The A7iii completed applying details and then displayed "Synchronization Service" but hung at 0.0% and displayed "Synchronizing" below that. I had to force quite at 6 minutes with Not Responding when clicking anywhere on the screen. After forced quit I re-started PSU and all the files showed out of sync icon.

The GX9 got to 32.1% and the G9 got to 35.2% before having to force quit. I waited 3 minutes for the GX9 and 4 minutes for the G9 in case PSU was just processing in background but clicking anywhere on screen also resulted in not responding.

Anything I should check to see if this is a bug or something else is going on? Anyone else having same problem?

rfcat
Posts: 56
Joined: 21 Feb 07 11:38
Location: Australia

Re: PSU hung after importing photos

Post by rfcat » 02 Nov 19 0:06

Hi Larry,
I would suggest checking your catalogue size and disk space.
Ian
Ian M
Photography, understanding how to catalogue so I can find my photos. :D .

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Re: PSU hung after importing photos

Post by Larry56 » 02 Nov 19 4:26

I'm not sure how my Synchronization post got under PSU hung after importing. I'm pretty sure I posted as a separate thread. Maybe Hert moved here? Or maybe I've had too much coffee today.

Anyway, thanks rfcat but my catalog size is only 1.2gb and about 21gb for the thumbnails. Also I have about 637gb free on SSD. I forgot to mention too that I had compacted the catalog before importing.

Hert
Posts: 5874
Joined: 13 Sep 03 7:24

Re: PSU hung after importing photos

Post by Hert » 02 Nov 19 11:51

@Larry, your issue was identical to the hanging after import....it's the sync process that is hanging after import

Please download and install build 2487 from the website (there's no in-app webupdate yet). This fixes the post-import issue.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

rfcat
Posts: 56
Joined: 21 Feb 07 11:38
Location: Australia

Re: PSU hung after importing photos

Post by rfcat » 02 Nov 19 11:51

Hi Larry,
just to provide some support, my synchronisation has stuck at 0.0% for some hours after I imported some photos into the move catalogue. I will let it run overnight. Also getting strange abort errors at startup so I suspect my did not go smoothly.
Ian
Ian M
Photography, understanding how to catalogue so I can find my photos. :D .

Hert
Posts: 5874
Joined: 13 Sep 03 7:24

Re: PSU hung after importing photos

Post by Hert » 02 Nov 19 12:59

rfcat wrote:
02 Nov 19 11:51
just to provide some support, my synchronisation has stuck at 0.0% for some hours after I imported some photos
Ian, that is exactly what build 2487 fixes. Did you already install it?
Please download and install build 2487 from the website (there's no in-app webupdate yet). This fixes the post-import issue.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Re: PSU hung after importing photos

Post by Larry56 » 02 Nov 19 16:39

Thanks Hert. build 2487 does fix the synchronization hang up.

The only thing is now all the imported images are assigned Red color label where in the details profile there is no color label selected.

rfcat
Posts: 56
Joined: 21 Feb 07 11:38
Location: Australia

Re: PSU hung after importing photos

Post by rfcat » 02 Nov 19 22:10

Hi Hert,
No I haven't though I thought I had, not sure why 2487 did not install. I will download it again.
Ian
Ian M
Photography, understanding how to catalogue so I can find my photos. :D .

rfcat
Posts: 56
Joined: 21 Feb 07 11:38
Location: Australia

Re: PSU hung after importing photos

Post by rfcat » 03 Nov 19 1:46

All appears to be good at this stage. Even got geotaging working, that was a strain.
Ian
Ian M
Photography, understanding how to catalogue so I can find my photos. :D .

User avatar
G8DHE
Posts: 150
Joined: 21 Aug 17 13:58

Re: PSU hung after importing photos

Post by G8DHE » 03 Nov 19 14:12

Argh, having problems now with v2487. I had Auto sync turned off and after making changes to labels it would then lock up repeatedly. After forcing a closure and restarting the changes had been made to the labels, but the program had hung after these changes. No activity etc version 2487.

Image

Edit: After several unsuccessful attempts I tried compacting the database and the error below kept appearing;

Code: Select all

IDI.v5.ApplicationException

----- details -----

ExceptionTimeStamp=2019-11-03T21:51:14.438Z
ExceptionThreadName=Main Thread
ExceptionClass=EDatabaseError
Exception=Transaction not set
Build=5.1.2.2487
Edition=Single
Architecture=64 bit
Platform=Windows
OperationSystem=Windows 10 64bit (Version: 10.0.18362)
Display=1920x1200
AvailableMemory=27 GB of 31.9 GB
ProcessorCores=12
Trial=no
UptimeSecs=267
SystemID=284B564E0F11D90A2B2734D8CF89B7D5
CallStack=  $00000001004362B0  DATABASEERROR,  line 2264 of ../../../nfreepascal/source/fpc/packages/fcl-db/src/base/db.pas
  $000000010044BE6A  EXECUTEDIRECT,  line 1302 of ../../../nfreepascal/source/fpc/packages/fcl-db/src/sqldb/sqldb.pp
  $000000010044BD84  EXECUTEDIRECT,  line 1292 of ../../../nfreepascal/source/fpc/packages/fcl-db/src/sqldb/sqldb.pp
  $000000010048275C  EXECUTEDIRECT,  line 1221 of ../../XOM/idsqlite3conn.pp
  $000000010077E6FB  BASECOMPACTDATABASE,  line 6252 of ../idDataModule.pas
  $00000001007A4BFC  COMPACTANDREPAIRDATABASE,  line 15540 of ../idDataModule.pas
  $00000001000FB2D4  COMPACTANDREPAIRDATABASE,  line 4814 of ../uCatalog.pas
  $0000000100251C50  COMPACTDATABASE,  line 10335 of ufmain.pas
  $000000010027296A  ASKOPENCATALOG,  line 17733 of ufmain.pas
  $000000010037CB5F  CLICK,  line 83 of include/menuitem.inc
  $000000010037D388  DOCLICKED,  line 293 of include/menuitem.inc
  $00000001000111F3  DISPATCH,  line 674 of ../inc/objpas.inc
  $0000000100328484  DOWINDOWPROC,  line 2078 of win32/win32callback.inc
  $0000000100329E37  WINDOWPROC,  line 2696 of win32/win32callback.inc
  $00007FF96F6463ED
  $00007FF96F645DE2
  $000000010032AF5E  APPPROCESSMESSAGES,  line 407 of win32/win32object.inc
DatabaseSystem=SQLite
ActiveCollectionCount=0
ActiveForm=  frmMain[TfrmMain]
ActiveForm.ActiveControl=  frmMain[TfrmMain]
  vxScene1[TvxScene]
ActiveForm.Scene.Focused=  Root1[TvxBackground]
  loApplication[TvxLayout]
  loApplicationContent[TvxLayout]
  loClientArea[TvxLayout]
  loCollectionViewer[TvxLayout]
  [TvxCollectionViewerTabComponent]
  [TvxCollectionViewerTabSheet]
  [TvxCollectionViewer]
ActiveForm.Scene.Hovered=  Root1[TvxBackground]
  loApplication[TvxLayout]
  loApplicationContent[TvxLayout]
  loClientArea[TvxLayout]
  loCollectionViewer[TvxLayout]
  [TvxCollectionViewerTabComponent]
  [TvxCollectionViewerTabSheet]
  [TvxCollectionViewer]

Geoff Mather (G8DHE)

Hert
Posts: 5874
Joined: 13 Sep 03 7:24

Re: PSU hung after importing photos

Post by Hert » 04 Nov 19 12:04

Your log shows that you're trying to change to a different database in the application (which probably wants to compact).

Try this;
1. Enable the login dialog in the preferences
2. Start PSU
3. Select your catalog in the login dialog and continue
4. In the application select Catalog -> Compact Database
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Post Reply