Alternating Red Folders

Post Reply
paulrbarnard
Posts: 19
Joined: 14 Dec 18 15:55

Alternating Red Folders

Post by paulrbarnard » 09 Oct 19 14:00

Not sure if this is a bug or something I'm doing so thought I would ask here before raising in Mantis.
I've upgraded to v5 and followed each update as it has come out, currently on build 2346. I've just noticed a problem with folders. I have one set of folders showing in Red. If I remap them then I get the message 0 folders remapped and restarting PS then results in the alternate folder set being Red.
Here is what I have (I have one set of folders that contain my active collection and a second set that contain my 'offline' images that I don't use regularly.)
Here is the folder structure in one state
Image
This is what I get when I remap RAWImages to the right folder. Incidentally it defaults to the right folder in the selection dialogue...
Image
The folders for that tree stay red
If I then exit PS and relaunch it I get this alternative situation
Image

I've been running with two seperate folder trees for quite some time on V4 but only just noticed this on V5 today

paulrbarnard
Posts: 19
Joined: 14 Dec 18 15:55

Re: Alternating Red Folders

Post by paulrbarnard » 09 Oct 19 16:34

I see the problem, I think. In the first scenario the drive is listed as FastRAID and in the second it is MacintoshHD. The RAWImages and the OfflineRAWImages are on different physical drives. It seems to be getting confused. When I select to re-map the drive it does bring up the dialogue with the correct path on the correct drive though.
I mentioned above that i changed the folder names. I originally had symbolic links to both folders from my Pictures folder on the Macintosh HD so the root path was the same. Now I'm linking them directly to their physical locations.

paulrbarnard
Posts: 19
Joined: 14 Dec 18 15:55

Re: Alternating Red Folders

Post by paulrbarnard » 10 Oct 19 11:47

I just created a new catalogue and imported my RAWImages folder and immediately it is showing the wrong path and is red. I'll raise something in mantis but this is looking very odd.

Hert
Posts: 5866
Joined: 13 Sep 03 7:24

Re: Alternating Red Folders

Post by Hert » 10 Oct 19 12:48

Your screenshot images don't show in the topic, probably due to a authorization restriction of your cloud service. You can attach the screenshots to your opening post.

Without seeing the screenshots I can't help. But for your understanding;

A volume is identified as "unique" by :
1. The drive type (internal, external, network)
2. The drive serial number
3. The volume name

You mention
I originally had symbolic links to both folders from my Pictures folder on the Macintosh HD so the root path was the same. Now I'm linking them directly to their physical locations.
To me that sounds like before your had one "logical" volume (the symbolic link). And now your have removed the symbolic link and want to link to the separate physical drives. And here I need the screenshots. What you apparently did (from a PSU point of view) is that you "split" a volume that it was managing as one into two separate volumes. So I need screenshots to know how you had that symbolic link constructed, and how the two physical drives were joined/combined in the symbolic link. Either way, remapping the top level won't help you, because you can't re-map one into two.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Post Reply