Slow moving to different folder

Post Reply
Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Slow moving to different folder

Post by Larry56 » 28 Sep 19 0:45

In v4 I could select a few thumbs and then drag and drop to another folder. After confirmation of the move all PSu did was very quick. Now in v5.0.0.2401 it's extremely slow. After confirmation Activity shows briefly and then says no activity but most of the time the thumbs of the photos I am moving disappear but all other info still shows along with the highlight showing what I wanted to move. After several seconds I get an Activity indication and then systematization. Sometimes all thumbs displayed disappear before Activity.

I've compacted database and settings are the same as I had in v4 as far as I can tell. The moving is to a different folder on same ssd as the computer.

Windows 10.

Any ideas why this in v5? Anyone else seeing this behavior?

Hert
Posts: 5866
Joined: 13 Sep 03 7:24

Re: Slow moving to different folder v5

Post by Hert » 28 Sep 19 8:09

Moving files with drag/drop is a direct file operation. Can you please try this again after restarting the computer.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Username
Posts: 207
Joined: 18 Feb 18 22:21

Re: Slow moving to different folder v5

Post by Username » 28 Sep 19 8:55

I tried this on PSu Single User my macOS and drag and drop to move images happened immediately. The activity view does not even opens.
I then tried in windows 10 home in my VirtualBox VM. With the same images which I had moved into the VM.
It was far slower. And it appeared as is PSu rebuilt the thumbs every time I moved them between the folders.

I've attached the full debug log to the mantis report.
https://mantis.idimager.com/view.php?id=3379
PSu Server 5 & Postgres 10 on macOS 10.14
- I'm the user

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Re: Slow moving to different folder v5

Post by Larry56 » 28 Sep 19 17:31

I tried again and moving two files (24mg ARW and 10mg jpg) from one folder to another took 22 seconds. During that time the activity indicator first said no activity then some activity then building thumbnails. The thumbs in the browser pane disappeared for a few seconds while this was happening

If helpful I did a video recording of moving two files.

edit: I wonder if my first installing along side of v4 contributes to the problem. Should I uninstall v5 (v4 is already removed) and then re-intall?

Hert
Posts: 5866
Joined: 13 Sep 03 7:24

Re: Slow moving to different folder v5

Post by Hert » 30 Sep 19 9:58

A drag/drop in Folders calls the OS to do the file operation. If that runs slow then typically the OS is the cause. Could it be that you have a virus scanner running that interferes with the process? And are you dragging between local folders or between network shares?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Re: Slow moving to different folder v5

Post by Larry56 » 30 Sep 19 16:22

I have my virus scanner set to exclude my whole photos folder and have not made any changes since using v4. The dragging is on the same SSD local drive.

I'll uninstall and reinstall to see if that helps and will report back.

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Re: Slow moving to different folder v5

Post by Larry56 » 30 Sep 19 17:45

I uninstalled v5 and reinstalled but it was same 22 seconds to move two files.

I then uninstalled v5, installed v4 and copied a an old v4 from March to the catalog folder. I started v4 and had it update database.After the database update I updated the database by adding newer folders and images. Once done I exited v4, rebooted, and started v4 again. It took about 2 seconds to move the two files.

I was able to duplicate the 2 seconds in v4 with other files.

Hope that helps.

gcorbin
Posts: 48
Joined: 21 Aug 06 12:31
Location: Brisbane

Re: Slow moving to different folder v5

Post by gcorbin » 02 Oct 19 12:49

I see the same issue when moving files to a different folder. This happened in V4 and it still happens in V5.0.0.2423. I seldom move photos and rebuilding thumbnails in a move, while strange, has never bothered me too much.

In V5.0.0.2423, moving 31 JPGs to a new folder takes 22 seconds of the cursor spinning with no screen updated followed by 15 seconds of Building Thumbnails. Disabling my virus scanner drops 2 and 1 seconds of the times respectively. I even uninstalled my virus scanner and tested with Defender and saw 20 and 8 seconds respectively.

My PC is windows 10, i7 fourth generation, 16G RAM, SSD hard disk and running Photo Supreme V5.0.0.2423 single user.

By the way Hert, I like V5. It is noticeably quicker and I like the new features like stacks. A great update.

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Re: Slow moving to different folder v5

Post by Larry56 » 02 Oct 19 19:00

FWIW, I posted as a bug in Mantis.

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Re: Slow moving to different folder v5

Post by Larry56 » 03 Oct 19 19:15

Since I'm currently running v4 is there a way to tell when v5 may have a fix without installing v5?

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Re: Slow moving to different folder v5

Post by Larry56 » 08 Oct 19 23:38

Hert, were you able to duplicate my issue?

Hert
Posts: 5866
Joined: 13 Sep 03 7:24

Re: Slow moving to different folder v5

Post by Hert » 09 Oct 19 0:37

I’ve mentioned before that I can’t reproduce this. Copying a file is PSU telling the OS (Windows Explorer in your case) to do a file copy. This was like that in V4, and is unchanged in V5. It can’t be different, since it’s the same code.
How long a file copy takes for Windows to do is out of PSU’s control.
If drag/drop is slow, then use cut/paste instead (Ctrl-X, Ctrl-V). Does that work better?
Since I'm currently running v4 is there a way to tell when v5 may have a fix without installing v5?
Changes for each build are listed here: https://whatsnew.idimager.com
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Larry56
Posts: 372
Joined: 05 Jul 10 6:57

Re: Slow moving to different folder

Post by Larry56 » 09 Oct 19 16:11

I installed v5 over v4 and now moving in v5 is just fine. I haven't made any changes so I don't know why it's working OK now. Maybe I caused a problem when I tried to install v5 in a separate folder from v4? In any case everything has worked out and am running v5 now.

Hert
Posts: 5866
Joined: 13 Sep 03 7:24

Re: Slow moving to different folder

Post by Hert » 09 Oct 19 20:36

That’s great. Glad it got ironed out.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Post Reply