Maps elevation lookup fails after one use

Post Reply
Stubb
Posts: 50
Joined: 03 Jun 14 13:26
Location: Atlanta, GA
Contact:

Maps elevation lookup fails after one use

Post by Stubb » 03 Jun 19 13:34

My first elevation lookup from maps works, then next one pops up the attached error message.

I tried to set up a billing account, etc., but there's clearly something still missing.

Maybe we need a companion to the API key video but for setting up all the other backend nonsense with Google.

Preference would be an alternative to Google Maps. I have grown to despise the company and do not want to be feeding locations information into their data-mining operation.
Attachments
Screen Shot 2019-06-03 at 08.29.01.png
Screen Shot 2019-06-03 at 08.29.01.png (220.6 KiB) Viewed 98 times

Hert
Posts: 21431
Joined: 13 Sep 03 7:24

Re: Maps elevation lookup fails after one use

Post by Hert » 03 Jun 19 13:44

Make sure that you also add the Maps Elevation API to your key in the Google Console.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Stubb
Posts: 50
Joined: 03 Jun 14 13:26
Location: Atlanta, GA
Contact:

Re: Maps elevation lookup fails after one use

Post by Stubb » 03 Jun 19 13:50

The issue was that Google tied the billing info to "My First Project" instead of "Photo Supreme". It's not just a matter of (1) following the instructions in the video to create an API key and (2) giving Google your billing info, but you need to (3) make sure that they're correctly linked together.

I would pay full price for a point upgrade to PSU with Google Maps removed. Strike that, I'd pay 2x full price for a version without Google Maps.

Post Reply