PSU startup

Post Reply
Larry56
Posts: 419
Joined: 05 Jul 10 6:57

PSU startup

Post by Larry56 » 19 Dec 18 23:54

I know this is odd, but is there a way to have PSU display a splash screen from the time the icon is double clicked to when it's actually ready to be used? On Windows computer there can be a noticeable delay between double clicking on the icon on the desktop to actually being in the program. I only ask because when my wife goes to view some photos she'll double click but thinks nothing is happening so she does it again, and again. I've seen her have 3 instances running because she doesn't know she has to be patient.

Hert
Posts: 21556
Joined: 13 Sep 03 7:24

Re: PSU startup

Post by Hert » 20 Dec 18 10:16

Startup delays are typically caused by open tabs, which PSU tries to restore on startup...and depending on their "volume" this may take longer. If startup time is important then try to keep not too many tabs open before closing the application.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Username
Posts: 205
Joined: 18 Feb 18 22:21

Re: PSU startup

Post by Username » 23 Dec 18 1:10

Sounds like a feature request begs to be filed. :)
A setting to automatically close tabs on quit or ask about closing tabs on quit. :)
PSUServer 4 & Postgres 10 on macOS 10.13
- I'm the user

Larry56
Posts: 419
Joined: 05 Jul 10 6:57

Re: PSU startup

Post by Larry56 » 24 Dec 18 1:47

I'm probably alone on the request and reasons. As far as tabs, I rarely have more than 2 so I think the delay is more "normal" for my system.

andrew.heard
Posts: 182
Joined: 16 Jun 10 0:36

Re: PSU startup

Post by andrew.heard » 24 Dec 18 6:03

+1
Hey Larry56 you're not alone. I guess my PC isn't super fast compared to most of users on this forum, so there is a considerable delay (6s) from starting PSu until the login screen is displayed, then another considerable delay (16s) until the main screen is displayed. I think a splash screen during these periods would be beneficial.

tstoddard
Posts: 584
Joined: 07 Sep 12 12:51

Re: PSU startup

Post by tstoddard » 27 Dec 18 19:21

I agree with Andrew and Larry. I'm running on SSD and all other applications open very quickly. Photo Supreme takes its time. I understand from previous discussions that this is due to optimizations that are taking place on startup and I'm okay with it. The delay, however, is long enough for me to sometimes question whether or not I actually clicked the PSU icon to launch the program or if my click even registered. I agree that a splash screen or some sort of indication that the program is opening would be a good idea.
Tom Stoddard

HaraldE
Posts: 398
Joined: 29 Apr 07 22:30
Location: Bålsta, Sweden

Re: PSU startup

Post by HaraldE » 28 Dec 18 0:00

+1
I too would benefit from a way to "see" that PSU has been started, Harald

User avatar
G8DHE
Posts: 115
Joined: 21 Aug 17 13:58

Re: PSU startup

Post by G8DHE » 28 Dec 18 12:06

+1 I've got used to it but its still nice to have that confirmation of a click.
Geoff Mather (G8DHE)

Larry56
Posts: 419
Joined: 05 Jul 10 6:57

Re: PSU startup

Post by Larry56 » 28 Dec 18 23:33

I've just posted a request on Mantis.

Hert
Posts: 21556
Joined: 13 Sep 03 7:24

Re: PSU startup

Post by Hert » 29 Dec 18 10:08

Build 1834 was uploaded to the website (no webupdate triggered for this build). This version should have a slightly faster (about 15%) startup time.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Username
Posts: 205
Joined: 18 Feb 18 22:21

Re: PSU startup

Post by Username » 29 Dec 18 11:55

Love you Hert.
In a “you rock” way. :)
PSUServer 4 & Postgres 10 on macOS 10.13
- I'm the user

Larry56
Posts: 419
Joined: 05 Jul 10 6:57

Re: PSU startup

Post by Larry56 » 29 Dec 18 19:03

Thank you Hert. I'll put to ultimate test later - my wife. :D

andrew.heard
Posts: 182
Joined: 16 Jun 10 0:36

Re: PSU startup

Post by andrew.heard » 29 Dec 18 22:56

Larry56 wrote:
28 Dec 18 23:33
I've just posted a request on Mantis.
thanks Larry56 - URL?

Larry56
Posts: 419
Joined: 05 Jul 10 6:57

Re: PSU startup

Post by Larry56 » 31 Dec 18 19:25

I guess this will work as URL to Mantis.

https://mantis.idimager.com/view.php?id=3318

Post Reply