google maps for "development purposes only"

weidmic
moderator
Posts: 4468
Joined: 04 Dec 06 22:21

google maps for "development purposes only"

Post by weidmic » 28 Oct 18 15:33

After a long time off with photography and PSU I wanted to get back and now I stumbled over a few problems.

First problem is that I get a script error and then a for development purposes only map.
Anyone else who ran into that problem?

I did create a new API key to make sure it is not the key and verified it is the correct key!

I use 4.3.0.1721 pg (64 bit)

Best Regards,
Michael

[edit Hert; changed title to better match topic]
Attachments
for development puroses.JPG
for development puroses.JPG (153.79 KiB) Viewed 736 times
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

weidmic
moderator
Posts: 4468
Joined: 04 Dec 06 22:21

Re: google maps probplem...

Post by weidmic » 28 Oct 18 15:43

here a screenshot from the script error

[edit hert] removed the screenshot that showed your google api key. Keep in mind that this key may be misused
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

snowman1
Posts: 391
Joined: 01 Jan 07 3:13
Location: UK

Re: google maps probplem...

Post by snowman1 » 28 Oct 18 16:33

Hmm. Mine hadn't been working for some time, despite adding the keys. Today, I was getting an error message, IIRC both on the getag panel and on shift-G (display on map). As I was getting a bit fed up I looked at the whole issue again, and checked out the idimager youtube vid on the subject. But everything appeared to be as it should be. I re-copied the key and re-pasted in PSU - though it hadn't changed - and then it partially worked. After a restart of PSU it seems to fully work. Well, at least apart from the "For development purpose only" watermarks on the maps [edit#1 - watermarks are only on shift-G, not in geotag panel]... so I have no idea what has been going on. But I suspect Google. I always do. If in doubt, suspect Google!

Edit #2 - Also I am getting an occasional error saying "an error has occurred in the script on this page" URL maps.googleapis.com/maps//ap/js/?..." (parameters to this page including v=3.3.2, the key, language, and callback=initialise)
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

weidmic
moderator
Posts: 4468
Joined: 04 Dec 06 22:21

Re: google maps probplem...

Post by weidmic » 28 Oct 18 18:10

Thanks Snowman for your response!
I also watched the video to double check and I even created a second api key and copied it into the appropriate field.
The error message appears every time I start PSU with a geotagged photo selected.

I suspect google too... (because I believe it worked some days ago, when I started to update all the software on my PC)

Cheers,
Michael
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

RobiWan
Posts: 114
Joined: 03 Nov 17 9:14

Re: google maps probplem...

Post by RobiWan » 28 Oct 18 18:39

Hi,

I'm not sure - but your screenshot - did you enter your credit card?

Robert

weidmic
moderator
Posts: 4468
Joined: 04 Dec 06 22:21

Re: google maps probplem...

Post by weidmic » 28 Oct 18 18:42

No - I have never been asked for a CC - it always worked before...
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

snowman1
Posts: 391
Joined: 01 Jan 07 3:13
Location: UK

Re: google maps probplem...

Post by snowman1 » 28 Oct 18 18:44

Same here.
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

Roland
Posts: 6
Joined: 14 Feb 14 20:36

Re: google maps probplem...

Post by Roland » 28 Oct 18 18:48

Hi ,
I also get the same script error message from time to time. After clicking "OK" to continue the map basically is fine. I do not see the development marking on the map and reverse lookup also works fine. But I am no longer able to retrieve altitude values. Clicking the relevant button seems to do nothing at all.
I have double checked myAPI key. Key and billing are basically OK.
I have already opened a ticket in Mantis (0003301) regarding the script error. Hert meant I shouldn't bother about the message box.
But the issue regarding the altitude is pending.

Roland

RobiWan
Posts: 114
Joined: 03 Nov 17 9:14

Re: google maps probplem...

Post by RobiWan » 28 Oct 18 19:35

Without payment Google Maps works only 2 times/ day (or Week?)

RobiWan
Posts: 114
Joined: 03 Nov 17 9:14

Re: google maps probplem...

Post by RobiWan » 28 Oct 18 19:37

This is why you see "for development purposes only"

weidmic
moderator
Posts: 4468
Joined: 04 Dec 06 22:21

Re: google maps probplem...

Post by weidmic » 28 Oct 18 19:39

RobiWan,

Is this new?
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

weidmic
moderator
Posts: 4468
Joined: 04 Dec 06 22:21

Re: google maps probplem...

Post by weidmic » 28 Oct 18 19:44

Just found the answer (I googled) - 'google maps is no longer free' - That's what I just read! :(
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

RobiWan
Posts: 114
Joined: 03 Nov 17 9:14

Re: google maps probplem...

Post by RobiWan » 28 Oct 18 19:45

Since a few weeks Google has completely implemented everything the promises have :(
I had exactly the same problem myself and ... well without credit card nothing works

Hert
Posts: 21299
Joined: 13 Sep 03 7:24

Re: google maps probplem...

Post by Hert » 29 Oct 18 0:05

Tip; after adding a credit card, also set billing restrictions. And most important; make sure to never expose your api key to others.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

snowman1
Posts: 391
Joined: 01 Jan 07 3:13
Location: UK

Re: google maps probplem...

Post by snowman1 » 29 Oct 18 15:12

Giving Google my credit card details is absolutely the last thing I want to do. While it's understandable that they charge for bulk usage it's frustrating that they are enforcing cc entry for everyone instead of just those who do or want to exceed the free limits.
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

Post Reply