Unable to login to forum on Firefox

Post Reply
snowman1
Posts: 401
Joined: 01 Jan 07 3:13
Location: UK

Unable to login to forum on Firefox

Post by snowman1 » 25 May 18 23:01

Unable to log in on Firefox. Not sure whether this relates to a change in the forum - it started asking for cookie consent - or in FF - which I believe no longer accepts sites with mixed secure and non-secure content. Am on FF 60.0.1 (i.e. the latest version).

Site still works on Chrome 66.0.3359.139 (I think not the latest version)

Is it just me that has this issue on FF? Though I guess we might not know if people affected cannot logon to report it.
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

Username
Posts: 195
Joined: 18 Feb 18 22:21

Re: Unable to login to forum on Firefox

Post by Username » 26 May 18 0:11

It's a bit strange.
The forum is correctly using a wildcard cert for *.idimager.com but on this page it breaks because your snowman avatar is directly linked to your site over http and not uploaded to the idimager https domain.

Also the web font used and a wrongly named brother but one have the incorrect suffix .woff2 instead of woff and it give a 404. So it should be removed.

fontawesome-webfont.woff
and
fontawesome-webfont.woff2
- I'm the user

Hert
Posts: 21433
Joined: 13 Sep 03 7:24

Re: Unable to login to forum on Firefox

Post by Hert » 26 May 18 1:58

Good point. I’ve now disabled remote avatars. Avatars can be uploaded in your profile.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

snowman1
Posts: 401
Joined: 01 Jan 07 3:13
Location: UK

Re: Unable to login to forum on Firefox

Post by snowman1 » 26 May 18 11:34

Good detective work guys. I could confirm (using Chrome) that my avatar no longer appeared. Even after this I still could not login on FF - it just kept returning me to the login screen without any error messages. Restarting FF, refreshing page etc did not help. Then I deleted all cookies for the site, and that did the trick - on refreshing it asked me for cookie consent again, after which I could login ok.
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

jstartin
Posts: 446
Joined: 23 Aug 06 13:47
Location: UK

Re: Unable to login to forum on Firefox

Post by jstartin » 26 May 18 13:46

I have also had this problem logging in from Firefox for a couple of days. Deleting all board cookies from the option on the forum screen did not help, but I have finally got back in by deleting all idimager related cookies with a third-party tool.
Jim (Photo Supreme: AMD Quad-Core A8-5500 Accelerated Processor 3.2 GHz; internal AMD Radeon™ HD7560D; 4GB DDR3 SDRAM; Win10x64)

snowman1
Posts: 401
Joined: 01 Jan 07 3:13
Location: UK

Re: Unable to login to forum on Firefox

Post by snowman1 » 26 May 18 15:36

Jim, you can do that from within FF by right-clicking on the page, click on "view page info", select the security tab and then on the "cookies" button. That shows you all the cookies related to the site and lets you delete them. (You can also get there from the "(i)" button / padlock on the left of the address bar.)
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

jstartin
Posts: 446
Joined: 23 Aug 06 13:47
Location: UK

Re: Unable to login to forum on Firefox

Post by jstartin » 26 May 18 22:14

snowman1 wrote:
26 May 18 15:36
Jim, you can do that from within FF by right-clicking on the page, click on "view page info", select the security tab and then on the "cookies" button. That shows you all the cookies related to the site and lets you delete them. (You can also get there from the "(i)" button / padlock on the left of the address bar.)
Yes, I know there are many ways to do it. The important point I was documenting is that the facility to "Delete all board cookies" on the forum page, which is the most obvious/accessible method, wasn't enough to allow me to log in.
Jim (Photo Supreme: AMD Quad-Core A8-5500 Accelerated Processor 3.2 GHz; internal AMD Radeon™ HD7560D; 4GB DDR3 SDRAM; Win10x64)

Larry56
Posts: 418
Joined: 05 Jul 10 6:57

Re: Unable to login to forum on Firefox

Post by Larry56 » 28 May 18 18:11

I've had problems too (in fact just sent an email to Hert but then I was able to get in). I also had same problem with Chrome and Vivaldi. I could enter login info but the screen would change to the forum header with login dialog box below. It didn't show me as logged in. Same thing for all browsers even after I cleared all browsing history and cookies but that didn't make a difference.

I exited Vivaldi (my default browser) and went to idimager.com to email Hert. Sent email form then went back to search for something in the forum and I was logged in. I have no idea why all this happens. This happened to me a couple days ago too but for some unexplained reason I suddenly was logged in.

dlp0918
Posts: 5
Joined: 30 May 18 21:35

Re: Unable to login to forum on Firefox

Post by dlp0918 » 30 May 18 22:44

Looks like I'm part of the group having trouble logging in to the forum. I've been unsuccessful when using Chrome Version 66.0.3359.181.

On a different computer I've registered to the forum under a new name using Edge browser. After that I've been able to access the forum with my new credentials using Internet Explorer on the original computer.

At this point getting to my old account is not a big deal, I can manage fine with the new account, so this is just an FYI.

- David P
Running Photo Supreme on Windows 10 Pro 64-bit with a Ryzen 2700X processor, 16 GB RAM, 1TB SSD, 4 TB HD/SSD hybrid

Hert
Posts: 21433
Joined: 13 Sep 03 7:24

Re: Unable to login to forum on Firefox

Post by Hert » 31 May 18 21:27

You need to remove cookies for all idimager.com domains.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

HaraldE
Posts: 398
Joined: 29 Apr 07 22:30
Location: Bålsta, Sweden

Re: Unable to login to forum on Firefox

Post by HaraldE » 31 May 18 23:36

Morning, I had this issue, removed all cookies, no problems since then, Harald

laeha
Posts: 2
Joined: 24 May 18 22:35

Re: Unable to login to forum on Firefox

Post by laeha » 01 Jun 18 8:13

Good morning, I had the same issue 1 week ago. Since I could not login via Firefox, I signed in with my alternative Email as a new user. Just for information, my new user name is laeha, not uweba anymore. Since I use only the Chrome browser there are no problems with login.

Hert
Posts: 21433
Joined: 13 Sep 03 7:24

Re: Unable to login to forum on Firefox

Post by Hert » 01 Jun 18 10:52

Deleting the cookies should be sufficient. The reason is that the cookie domain for the forum was changeed from idimager.com to forum.idimager.com and so you should delete the cookies for *all* idimager.com domains, not only for forum.idimager.com
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

nikcob
Posts: 18
Joined: 13 Jun 16 15:30

Re: Unable to login to forum on Firefox

Post by nikcob » 14 Aug 18 10:41

I had the same: unable to login or reset password. Taking another browser solved the problem and than I'm reading ON THE FORUM that I have to delete the cookies first to get access to the forum! :D :D :D Next time perhaps an announcement on the site before the login?

Post Reply