Connection to database & pow authentification failed

rdv4rjm
Posts: 83
Joined: 08 May 18 22:29

Re: Connection to database & pow authentification failed

Post by rdv4rjm » 21 May 18 6:24

The attachment Screen Shot 2018-05-21 at 12.21.50 AM.png is no longer available
The attachment Screen Shot 2018-05-21 at 12.21.50 AM.png is no longer available
Attachments
Screen Shot 2018-05-21 at 12.21.50 AM.png
Screen Shot 2018-05-21 at 12.21.50 AM.png (27.08 KiB) Viewed 848 times

rdv4rjm
Posts: 83
Joined: 08 May 18 22:29

Re: Connection to database & pow authentification failed

Post by rdv4rjm » 21 May 18 6:26

Screen Shot 2018-05-21 at 1.16.10 AM.png
Screen Shot 2018-05-21 at 1.16.10 AM.png (35.5 KiB) Viewed 848 times

Username
Posts: 195
Joined: 18 Feb 18 22:21

Re: Connection to database & pow authentification failed

Post by Username » 21 May 18 11:13

Hmm

Is the server in DMZ or on the inside?

Are the server as well as clients on the same sub net?
192.168.8.x

Do the client try to connect to the servers IP or hostname?

Some routers offers settings for wireless isolation which will prohibit wifi clients from talking to each other.
It can be called AP Isolation or wireless isolation.
Could that be the case?
- I'm the user

amartel
Posts: 15
Joined: 16 Jul 16 17:03

Re: Connection to database & pow authentification failed

Post by amartel » 21 May 18 13:16

Hi,

I think the problem is that your postgresql server doesn't listen on the correct IP address (only localhost - 127.0.0.1).
Edit file postgresql.conf to update line:
listen_addresses = '*'

Then restart postgresql server. You should see in postgresql logfile that server is now listening on your 192.168.8.xxx IP address

Username
Posts: 195
Joined: 18 Feb 18 22:21

Re: Connection to database & pow authentification failed

Post by Username » 21 May 18 15:39

Thank you amartel. :)
I totally missed that setting.

That should sort everything for rdv4rjm!
- I'm the user

rdv4rjm
Posts: 83
Joined: 08 May 18 22:29

Re: Connection to database & pow authentification failed

Post by rdv4rjm » 21 May 18 17:57

Hi amartel

I think the problem is that your postgresql server doesn't listen on the correct IP address (only localhost - 127.0.0.1).
Edit file postgresql.conf to update line:
listen_addresses = '*'

I DID MODIFY POSTGRESQL.CONF AS SUGGESTED:
2018-05-21 11:54:07.834 EDT [537] LOG: listening on IPv4 address "127.0.0.1", port 5432
2018-05-21 11:54:07.835 EDT [537] LOG: listening on Unix socket "/tmp/.s.PGSQL.5432"
2018-05-21 11:54:08.014 EDT [538] LOG: database system was shut down at 2018-05-21 11:53:56 EDT
2018-05-21 11:54:08.019 EDT [537] LOG: database system is ready to accept connections

rdv4rjm
Posts: 83
Joined: 08 May 18 22:29

Re: Connection to database & pow authentification failed

Post by rdv4rjm » 21 May 18 18:14

Hi username

Is the server in DMZ or on the inside?
NO SERVER IS NOT IN DMZ.


Are the server as well as clients on the same sub net?
192.168.8.x
YES CLIENTS AND SERVER ARE ON SAME SUB NET.

Do the client try to connect to the servers IP or hostname?
WHEN CONNECTING USING IP: "is server running on host "192.168.8.24" and accepting connections on port 5432"?
WHEN USING HOSTNAME: could not translate hostname to address: codename nor servname provided, or not known


Some routers offers settings for wireless isolation which will prohibit wifi clients from talking to each other.
It can be called AP Isolation or wireless isolation.
Could that be the case?
OPTION NOT FOUND IN ROUTER.

Would unsuccessful hostname to address translation identify a name resolution issue?

rdv4rjm
Posts: 83
Joined: 08 May 18 22:29

Re: Connection to database & pow authentification failed

Post by rdv4rjm » 21 May 18 18:25

I setup a new router, disabled firewall, hard wired server and 3 clients.
Added Mac client to 2 other Windows clients.

ssh remote connection is successful from client to server, and server to client : ssh "hostname"@"ip address"

Post Reply