Errors in Technical Data section

Post Reply
Tester63
Posts: 10
Joined: 26 Apr 18 13:10

Errors in Technical Data section

Post by Tester63 » 26 Apr 18 13:28

HI,

I am testing version 4.1 and I have a big problem in Detail section. Technical data is all scrambled. E.g. for my Nikon lens 17-55 mm 2.8, it is posted "Lens Information" instead of 17-55mm , all exposure time are unknown, Camera Make is "NIKON,RATION,ION,CORP..." instead of NIKON CORPORATION, Camera Model is "NIKON,300,D300" instead of NIKON D300 etc...

Thank you for answering.

I am using Photo Supreme 4.1 build 1402

Username
Posts: 142
Joined: 18 Feb 18 22:21

Re: Errors in Technical Data section

Post by Username » 26 Apr 18 13:58

Hello

Are these NEFs or jpegs?
Have they been processed by another application prior to importing them to PS?
Are you able to attach one of them and I'll take a peek at it.

I have not seen this with my Nikons lenses.

Here's a screen shot of the Detail section of my D3X and 14-24.
PS_D3X_14-24.png
PS_D3X_14-24.png (153.21 KiB) Viewed 622 times
- I'm the user

Tester63
Posts: 10
Joined: 26 Apr 18 13:10

Re: Errors in Technical Data section

Post by Tester63 » 26 Apr 18 14:58

Hi,

Sorry, I am talking about the DETAILS in the upper section not the one you showed, this one is correct.

Just take a look at the attachment.

Thank you
Attachments
PSU-01.jpg
PSU-01.jpg (72.2 KiB) Viewed 613 times

weidmic
moderator
Posts: 4454
Joined: 04 Dec 06 22:21

Re: Errors in Technical Data section

Post by weidmic » 26 Apr 18 15:35

That is how it looks like on my system:
details.JPG
details.JPG (119.19 KiB) Viewed 599 times
I see that you are using a localization. I don't think this is related to it, but maybe you switch to English to test it out?


Best Regards,
Michael

BTW: A test file would be great as requested by username would be great.
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

Tester63
Posts: 10
Joined: 26 Apr 18 13:10

Re: Errors in Technical Data section

Post by Tester63 » 26 Apr 18 15:53

Hi Michael,

All my data was looking the same as in your system. The problem happened after re-importing metadata as suggested in What's New in 4.1 item 10.

"Nikon lens descriptions for prime lenses are cleaner (e.g. "20mm 1.8" instead of "20mm-20mm 1.8-1.8". If you need existing lens descriptions to be updated then re-importing the metadata by pressing Ctrl+Alt+S (Cmd+Opt+S on macOS)"

So may be you can test in re-importing just a few files, it cannot be changed back.

Thank you

weidmic
moderator
Posts: 4454
Joined: 04 Dec 06 22:21

Re: Errors in Technical Data section

Post by weidmic » 26 Apr 18 15:57

Have you compacted your DB?

Hamburger Menu|Tools|Catalog|Compact Current Catalog

I never reimport images, but I do read metadata from files on a regular basis, which is kind of the same thing ;)

EDIT: Please provide a file if you don't mind
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

Hert
Posts: 21056
Joined: 13 Sep 03 7:24

Re: Errors in Technical Data section

Post by Hert » 26 Apr 18 16:03

PSU was just updated to build 1426. In this build the "NIKON,RATION,ION,CORP" issue is resolved. After installing 1426, run this small script with hamburger -> Tools -> Scripter
For large database this will take a while to complete; so best to run it at a convenient time;

Code: Select all

PublicCatalog.BuildSearchData;
Say('Done');
You can download the 1426 update from the website. Does that help?

EDIT, I notice that you only have this with a few files. Select these files in 1426, and press Ctrl+Alt+S (Cmd+Opt+S on Mac) to re-import the metadata to the catalog.
1. Click the counter for NIKON,RATION,ION,CORP to open the 19 files
2. Select all files
3. Press Ctrl+Alt+S on Windows or Cmd+Opt+S on macOS
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

weidmic
moderator
Posts: 4454
Joined: 04 Dec 06 22:21

Re: Errors in Technical Data section

Post by weidmic » 26 Apr 18 16:05

Hert, I was just about to ask about the search script :)
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

Tester63
Posts: 10
Joined: 26 Apr 18 13:10

Re: Errors in Technical Data section

Post by Tester63 » 26 Apr 18 16:21

My DB was just converted when I started 4.1 bd 1402 for the fist time. Everything was fine in 4.0.1 bd 1201. All my files are ok. All the data as seen in the "Detail Panel" is ok, see the attachment. As I wrote, the problem happened after I read back metadata in bd 1402 as I wanted to clean the lens description. Have you re-read metadata with bd 1402?

Thank you
Attachments
PSU-02.jpg
PSU-02.jpg (108.28 KiB) Viewed 575 times

Tester63
Posts: 10
Joined: 26 Apr 18 13:10

Re: Errors in Technical Data section

Post by Tester63 » 26 Apr 18 16:46

Thank you Hert,

Everything is back to normal! But, the lens description is not totally clean ... as you expected!

See attachment.
Attachments
PSU-03.jpg
PSU-03.jpg (9.9 KiB) Viewed 572 times

Hert
Posts: 21056
Joined: 13 Sep 03 7:24

Re: Errors in Technical Data section

Post by Hert » 26 Apr 18 17:25

That’s great.

Can you try this for the lens;

Select one or more of the images with prime lens
Right click
Select Metadata-Convert Metadata to XMP
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Tester63
Posts: 10
Joined: 26 Apr 18 13:10

Re: Errors in Technical Data section

Post by Tester63 » 26 Apr 18 18:59

Hi Hert,

Sorry for the delay. I tried your suggestion and now the description for the lens is "clean". I guess I have do the same for all the other pictures ...

Thank you

Tester63
Posts: 10
Joined: 26 Apr 18 13:10

Re: Errors in Technical Data section

Post by Tester63 » 26 Apr 18 19:41

Hi Hert,

"Convert metadata to XMP" changes the Software field to "Photo Supreme v 4.1 ...". Is it possible to prevent this modification?

Thanks for your help.

weidmic
moderator
Posts: 4454
Joined: 04 Dec 06 22:21

Re: Errors in Technical Data section

Post by weidmic » 26 Apr 18 22:23

Yes that is possible...
Please take a look at my signature and follow the link :)
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

Post Reply