Wrong sorting order (photo date) of images?

Post Reply
freudenthaler
Posts: 91
Joined: 07 Aug 12 20:57
Location: Austria

Wrong sorting order (photo date) of images?

Post by freudenthaler » 04 Mar 18 11:56

I've set the sorting order for my thumnail panel to "photo date - ascending".Image photo date (%ImagePhotoDate) is displayed in the thumnails info panel. I have pictures of two different cameras shown in my panel (no active filter).

Unexpectedly, sorting order is not correct, because the two cameras don't mix up in terms of photo date in the panel (see image attached). First my smartphone pictures show up, then my cameras picture start again with earlier photo date.

Any suggestions?
v4_SortingOrder.png
v4_SortingOrder.png (154.3 KiB) Viewed 529 times
Robert | glass stories | Fuji X | LR Classic CC | PSU 4 | Win 10/64 on AMD FX |

Hert
Posts: 21022
Joined: 13 Sep 03 7:24

Re: Wrong sorting order (photo date) of images?

Post by Hert » 04 Mar 18 13:41

Your screenshot shows a set as out of sync. Make sure they are in sync as during the sync proces the Photo date is stored in the database, which on its turn is used for the sorting

Check “States-Out of sync”, If you want to read the metadata to the catalog, then select one or more thumbs right click on a thumb -> Metadata -> Read metadata from file
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

freudenthaler
Posts: 91
Joined: 07 Aug 12 20:57
Location: Austria

Re: Wrong sorting order (photo date) of images?

Post by freudenthaler » 05 Mar 18 22:24

First of all: syncing all my images did do the trick, they now are in the right order in terms of photo date, thanks Hert.

Still I have two questions:
  • I always thought that synchronizing means writing PSu metadata back to the image. But sorting is done based on some dates, which are stored in PSu's database. So why does syncing affect the sorting display order?
  • Up to PSu v3 I used to display xmp::created date in my custom thumb info panel (as a result of Herts answer to my question, which date fields are used for performing a catalog search by date --> viewtopic.php?f=57&t=22708; I learned that PSu can use a sequence of dateTime fields) but since v4 no value is displayed anymore for this xmp-variable - not on a single image anymore?! Any explanations?

v4xmpCreateDate2.png
v4xmpCreateDate2.png (173.24 KiB) Viewed 435 times
Robert | glass stories | Fuji X | LR Classic CC | PSU 4 | Win 10/64 on AMD FX |

Hert
Posts: 21022
Joined: 13 Sep 03 7:24

Re: Wrong sorting order (photo date) of images?

Post by Hert » 05 Mar 18 23:22

I always thought that synchronizing means writing PSu metadata back to the image. But sorting is done based on some dates, which are stored in PSu's database. So why does syncing affect the sorting display order?
Sorting takes place in the database, if you don't synchronize the images then there's no date in the database and so they won't sort.
but since v4 no value is displayed anymore for this xmp-variable - not on a single image anymore?! Any explanations?
The "xap" is an outdated prefix that was once introduced in the first releases of the XMP specifications. Later that prefix got changed to xmp. With the release of V4, PSU switched from xap to xmp as well.

Use %xmp:xmp:CreateDate instead
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

freudenthaler
Posts: 91
Joined: 07 Aug 12 20:57
Location: Austria

Re: Wrong sorting order (photo date) of images?

Post by freudenthaler » 06 Mar 18 21:46

Sorting takes place in the database, if you don't synchronize the images then there's no date in the database and so they won't sort.
Sorting is done via PSu's DB - that's what I said, Hert. But aren't the date values in the DB filled during the image import? Otherwise the %ImagePhoteDate variable couldn't show the right value. So what's the value of syncing for sorting (as syncing only performs a write operation and no read operations)?
The "xap" is an outdated prefix that was once introduced in the first releases of the XMP specifications. Later that prefix got changed to xmp. With the release of V4, PSU switched from xap to xmp as well.

Use %xmp:xmp:CreateDate instead
xmp vs. xap - thanks for pointing me to this Hert, I have to confess that I overlooked the different terms.
Robert | glass stories | Fuji X | LR Classic CC | PSU 4 | Win 10/64 on AMD FX |

Post Reply