For those who like a functional rating bar

weidmic
moderator
Posts: 4454
Joined: 04 Dec 06 22:21

Re: For those who like a functional rating bar

Post by weidmic » 01 Mar 18 23:40

You mean the star with the number in it?
If so, no, that is not possible...
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

fbungarz
Posts: 3163
Joined: 08 Dec 06 5:03
Location: Galapagos, Ecuador

Re: For those who like a functional rating bar

Post by fbungarz » 02 Mar 18 1:13

That star is part of PSU's default rating system. If you have not rated an image you can hover over the area, where this star will appear, a small arrow appears, you click on that arrow to open a rating bar and assign the star(s). Once you thus assigned a rating to your image, the star with the number appears automatically.
Obviously, once you use the script here to crate a rating bar this entire functionality becomes redundant. The rating bar essentially emulates a way this worked in a previous system. Personally I find the default implementation how to apply a rating to an image a bit of a challenge. One needs quite a bit of dexterity and several clicks to get it working. In my opinion this script to add a functional rating bar is fantastic. I can live with that other now redundant star still showing up ...

Hert
Posts: 21022
Joined: 13 Sep 03 7:24

Re: For those who like a functional rating bar

Post by Hert » 02 Mar 18 10:52

The script in the opening post was just updated.
@Mke; does that fix the Access Violation on your machine?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Mke
Posts: 433
Joined: 15 Jun 14 15:39

Re: For those who like a functional rating bar

Post by Mke » 03 Mar 18 12:02

Hert wrote:
02 Mar 18 10:52
@Mke; does that fix the Access Violation on your machine?
The previous version of the code has actually been working OK since I removed the 'phantom code' (viewtopic.php?f=57&t=26749&start=15#p118974).
But the new code is working fine too.

...although I did get a crash (details below) after pasting in the code and on applying my first rating. Not reproducible - just a one-off.

Problem Event Name: APPCRASH
Application Name: IDimagerSU.exe
Application Version: 4.0.1.1032
Application Timestamp: 00000000
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.3.9600.18666
Fault Module Timestamp: 58f33794
Exception Code: e0465043
Exception Offset: 00000000000095fc
OS Version: 6.3.9600.2.0.0.768.101
Locale ID: 2057
Additional Information 1: 0f33
Additional Information 2: 0f33396c542a776f42769b20b7878a90
Additional Information 3: 75f7
Additional Information 4: 75f78c3aa0df9d315aa67e203de154b8

Problem Event Name: APPCRASH
Application Name: IDimagerSU.exe
Application Version: 4.0.1.1032
Application Timestamp: 00000000
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.3.9600.18666
Fault Module Timestamp: 58f33794
Exception Code: c000041d
Exception Offset: 00000000000095fc
OS Version: 6.3.9600.2.0.0.768.101
Locale ID: 2057
Additional Information 1: 5319
Additional Information 2: 53199e52b225fb9ac90d19fb5123b900
Additional Information 3: bb5d
Additional Information 4: bb5dedb13109489cffdf4661bf32cfb7

Post Reply