PS won't open

Post Reply
fsalveson
Posts: 27
Joined: 19 Jun 11 20:26

PS won't open

Post by fsalveson » 19 Jun 16 11:58

Hi,

I was using PS, left it open while I did something else, and when I came back it seemed frozen, so I rebooted. When I rebooted, PS wouldn't open. I got the 'code 740', with the added message that 'the requested operation requires elevation'. I've followed all instructions (here and elsewhere) regarding running the program with and without admin rights, and this does not appear to be the reason PS won't open.

I read dpaine's post 28 regarding the fix you suggested that worked for him, specifically running the following query on the database(s): delete from idimageData where where DataName = 'LASTACTIVETABS', however, I wasn't sure where to run that query from, and the places I attempted to run it from indicated that the term 'delete' was not recognized as an internal or external command, etc. Obviously, I wasn't running the Query properly.

I suppose I could reinstall the program and restore the backups, though the last backup was a few days ago, so I'd lose some recent work. I was wanting to try all practical options to open the program first before resorting to a complete reinstall.

Appreciate any help I can get. Thank you,
Franklin

weidmic
moderator
Posts: 2854
Joined: 04 Dec 06 22:21

Re: PS won't open

Post by weidmic » 19 Jun 16 16:14

Did you use SQlite Expert? It's a free tool...

Michael
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

fsalveson
Posts: 27
Joined: 19 Jun 11 20:26

Re: PS won't open

Post by fsalveson » 20 Jun 16 19:14

Ok, I downloaded SQLite Expert Professional on a 30-day trial basis, and I was able to access the IDimager databases using the SQL program, but then I was lost and didn't know how to apply the above mentioned query. It looks like a relatively big learning curve to know how to use the SQL program.

Can someone either advise how to apply the delete Query or have another suggestion as to how I might resolve the issue of not being able to open PS?

Franklin

fsalveson
Posts: 27
Joined: 19 Jun 11 20:26

Re: PS won't open

Post by fsalveson » 03 Jul 16 10:59

I'm still unable to open my PS program, as I'm not sure how to use the SQLite to run the "delete" query as mentioned above. First, is the corruption likely to be in both the catalogue and thumbs databases, or just one of them? The catalogue database is small and maybe I could email it to someone who might be able to run the query for me and look at it, but if it's the thumbs database, it's large so I'd need to upload it for downloading. Not sure if this is practical or if someone is willing and able to help.

I did test installing (restoring) the last backed up databases on another computer, and the program ran ok, but since I was missing some of the information that was categorized since the last backup, I still preferred correcting whatever current problem exists if possible, since that would save me having to go thru the recent imports to make sure all the information is there. I'm presuming that the problem is likely with the databases and not with the program itself. Or, should I not make that presumption? But, if I reinstalled the program, I would still have to restore the last backed up databases instead of using the old ones that are still on the computer after an uninstall, isn't that correct? In which case, I'd still be missing information since the last backup.

Other suggestions as to the best way to proceed would be appreciated.

Thanks, Franklin
Last edited by fsalveson on 03 Jul 16 11:23, edited 1 time in total.

Hert
Posts: 15909
Joined: 13 Sep 03 7:24

Re: PS won't open

Post by Hert » 03 Jul 16 11:15

To rule out if it's the catalog or thumbs database:
1. Close PSU
2. Rename the thumbs db file in %localappdata%\IDimager Systems, Inc.\Catalog
3. Start PSU

No error? Then it's the thumbs database. Still an error? Then it's the catalog database.

If it's the catalog database then restore your backup
If it's the thumbs database then just rebuild the thumbnails with Tools->Build missing thumbs and previews
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

fsalveson
Posts: 27
Joined: 19 Jun 11 20:26

Re: PS won't open

Post by fsalveson » 03 Jul 16 11:46

Ok, I renamed the thumbs database and PSU still wouldn't open. So, to restore the backup, since PSU won't open at all, I'm assuming that I need to uninstall PSU and delete the both databases, then download and install PSU again and restore the backup. Is that the best procedure?

Hert
Posts: 15909
Joined: 13 Sep 03 7:24

Re: PS won't open

Post by Hert » 03 Jul 16 14:35

Copying the two database files from the backup to your catalog folder should do
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Post Reply