Beta 3.3 version

tstoddard
Posts: 584
Joined: 07 Sep 12 12:51

Re: Beta 3.3 version

Post by tstoddard » 27 Apr 16 21:54

snowman1,

Assuming you are using the stand alone version of PSU, I think you will want to upgrade and then restore. I think the reason for this had to do with an issue I experienced with an earlier build of the beta version. Apparently it was caused when the database was converted by the beta version the first time I installed it. I'm assuming something was lost or changed in the database during that conversion that caused my issue. If you restore before upgrading, that same issue may arise. You need to install build 2425 of the beta version and then restore. I don't think you'll need to restart again after the restore.
Tom Stoddard

snowman1
Posts: 395
Joined: 01 Jan 07 3:13
Location: UK

Re: Beta 3.3 version

Post by snowman1 » 28 Apr 16 19:56

Thanks Tom, will give that a try.
Snowman1
http://www.flickr.com/photos/snowman-1/
--------------------------------------

fbungarz
Posts: 3185
Joined: 08 Dec 06 5:03
Location: Arizona, USA

Re: Beta 3.3 version

Post by fbungarz » 30 Apr 16 11:44

Hi,
after installing the beta version and running it for the first time on my database the following warning pops up:
PSu-Convert_Warning.jpg
PSu-Convert_Warning.jpg (51.05 KiB) Viewed 6847 times
Is it safe to go ahead?
Thanks,
Frank

Hert
Posts: 15922
Joined: 13 Sep 03 7:24

Re: Beta 3.3 version

Post by Hert » 30 Apr 16 11:53

This is harmless and occurs when you cancel the upgrade message
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

fbungarz
Posts: 3185
Joined: 08 Dec 06 5:03
Location: Arizona, USA

Re: Beta 3.3 version

Post by fbungarz » 30 Apr 16 12:07

Actually it pops up, when I "accept" the upgrade!

Hert
Posts: 15922
Joined: 13 Sep 03 7:24

Re: Beta 3.3 version

Post by Hert » 30 Apr 16 12:42

Then click OK to continue
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

weidmic
moderator
Posts: 2855
Joined: 04 Dec 06 22:21

Re: Beta 3.3 version

Post by weidmic » 30 Apr 16 16:43

Frank,
after you OK'd what happens next?
Will PSU run or is another error message popping up?

Best Regards,
Michael
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

fbungarz
Posts: 3185
Joined: 08 Dec 06 5:03
Location: Arizona, USA

Re: Beta 3.3 version

Post by fbungarz » 30 Apr 16 16:55

Hi Michael,
It is a bit odd. I first cancelled it. Then, when I tried it again, a different message popped up, telling me the database was being updated by another process. I clicked "ignore" and the catalog opened up, apparently just fine, but I am still checking things...
Cheers,
Frank

Hert
Posts: 15922
Joined: 13 Sep 03 7:24

Re: Beta 3.3 version

Post by Hert » 06 May 16 20:10

The beta was updated again. Mainly internal changes and a fix for XMP mappings to structures (which revealed when using the new Darwin schema/editors).
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

weidmic
moderator
Posts: 2855
Joined: 04 Dec 06 22:21

Re: Beta 3.3 version

Post by weidmic » 07 May 16 1:04

Does this apply to the server version too?
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

Hert
Posts: 15922
Joined: 13 Sep 03 7:24

Re: Beta 3.3 version

Post by Hert » 07 May 16 5:05

Yes, all versions are updated.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

fbungarz
Posts: 3185
Joined: 08 Dec 06 5:03
Location: Arizona, USA

Re: Beta 3.3 version

Post by fbungarz » 10 May 16 9:12

Dear Hert,
just wanted to quickly say, I much appreciate the full support for Darwin Core XMP in this new version. This is great!!!
I also noticed that date entries now can be copied or cleared from one field to the next. Also, it is fantastic that GEO coordinates can now also be changed directly from the Details panel. Both changes are much appreciated as well !!!
Finally:
CTRL+F finally is fast again and I can confirm that the 'jumping cursor' bug has been eliminated (unfortunately the issue with not finding synonyms persists, also I noticed the CTRL+F search box is often obscured by the search list; both filed in Mantis).
I am sure there are many other improvements I have not yet noticed.
Overall I am impressed. Well worth upgrading.
Cheers,
Frank

weidmic
moderator
Posts: 2855
Joined: 04 Dec 06 22:21

Re: Beta 3.3 version

Post by weidmic » 10 May 16 13:39

Not sure if it is suppoesed to work (or related to the beta) so I post it here first before creating a mantis ticket...

I have used star rating the first time during the import process. Normally I do this after all images are ingested.
This time I tried it different and while selecting photos to import I applied star ratings.

However, after the import is done, none of my ratings are applied to the images.
My question here is: Should that work? If so, is there a setting I have apply?
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

LifeIsLong
Posts: 104
Joined: 09 Oct 08 2:22

Re: Beta 3.3 version

Post by LifeIsLong » 10 May 16 21:37

I didnt think assigning data before importing worked. I could be wrong, but I tried assigning catalog labels before importing and had issues.

I guess I figured that since the assign and details panes could be used from the importer, I could just do all of my metadata and then import.

fbungarz
Posts: 3185
Joined: 08 Dec 06 5:03
Location: Arizona, USA

Re: Beta 3.3 version

Post by fbungarz » 11 May 16 16:23

To me it would seem very strange if (by design?) PSu really does not read star and color labels from the files during import. It reads other metadata too, right? So, why would it not pick up ratings and color labels? After all they are stored as XMP too! I noticed this already in IDI. When I used FastPictureViewer to rate my images, IDI would not pick up these ratings. Now I learn this to be the same (apparently?) in PSu.
If this is by design, I find this not only odd, but also rather inconvenient: Currently I use FastPictureViewer to cull my images. The import wizard of PSu is pretty fast, generating thumbs quickly enough that I could perhaps do the culling there. Since the ratings in FastPictureViewer would not stick, I just used the program to only distinguish between "keepers" and "loosers". But doing the culling and rating in one go (inside PSu) would make quite a bit of sense (i.e., only keep the ones that get star ratings...). And it would be eliminating one more step ...

Locked