Request help regarding tag delineation

Post Reply
TheNewNo2
Posts: 2
Joined: 21 Mar 15 14:03

Request help regarding tag delineation

Post by TheNewNo2 » 21 Mar 15 14:19

I'm hoping someone can help me with a cataloguing issue I have.

I have previously been doing all my photo management in Windows Live Photo Gallery. However I've generated so many tags it's become unwieldy, so I was hoping Photo Supreme could sort that out. As you can probably understand I don't want to have to go through 100,000 photos manually adding categories, so I was hoping that the tags can be merged into categories. And so they have, however, it hasn't done it very well when spaces enter the equation.

Say I have for instance a tag "London Underground", PS adds the categories "London" and "Underground", which is incredibly unhelpful. I have tried setting the preferences to read delineated keywords and reimporting, but this didn't help. The software also doesn't seem to read most of the tags - for instance I know that every file I have imported had probably at least 10 metadata tags, and that of the 300 or so about 50 would have been tagged "Brighton", but it only found 9 with that tag.

vlad
Posts: 895
Joined: 01 Sep 08 15:20

Re: Request help regarding tag delineation

Post by vlad » 22 Mar 15 19:26

Could you provide a picture which hasn't been correctly cataloged upon importing? This way, we might be able to replicate the problem and/or offer specific advice.

TheNewNo2
Posts: 2
Joined: 21 Mar 15 14:03

Re: Request help regarding tag delineation

Post by TheNewNo2 » 26 Mar 15 21:04

http://mattbuck.irongalaxy.com/temp/IMGP0878.JPG, according to the metadata, has the following tags:

England; United Kingdom; Europe; Water; Sunset; Photos by Matt; January; Waves; Sussex; English Channel; Brighton; Camera: Pentax K-50; Lens: Sigma 18-250mm; 2015; Holiday 2015;

However when imported into Photo Supreme it only kept the keyword "Sussex".

http://mattbuck.irongalaxy.com/temp/IMGP0556.JPG has tags

Lens: Sigma 18-250mm; Essex; United Kingdom; Europe; England; Great Western Main Line; Wessex Main Line; Camera: Pentax K-50; Royal Mail; Heart of Wessex Line; Bristol; Severn Beach Line; Cross Country Route; Bristol Temple Meads railway station; 2015; Bristol to Exeter Line; Railways; Mainline railways; January

However in Photo Supreme it only came out with "Beach", "Line", and "Severn" - so it clearly took the tag "Severn Beach Line", reduced it to its component words, and added those.

Mke
Posts: 509
Joined: 15 Jun 14 15:39

Re: Request help regarding tag delineation

Post by Mke » 27 Mar 15 0:29

Just tried importing them into PSU here.

IMGP0878.JPG only has "Sussex" listed as a keyword in the details panel and in the LAP
IMGP0556.JPG only has "Bristol" listed in the details panel, but 20 labels are shown in the LAP (including "Photos by Matt" from the EXIF data, but not in your list above)

In both cases I see that the "creator" in the details panel is given as "Matt" "Buck" too - i.e. as two separate tags, rather than one.

I can't see any obvious reason for such behaviour, or why it would differ between you and me, and between the handling of the two images - in short, it looks like a bug (and a serious one, if you have 100,000 images where it may have got it wrong). I suspect that there's a link to the issue at http://forum.idimager.com/viewtopic.php?f=57&t=23770 - which also relates to problems reading and writing keywords (including sometimes splitting them into their component parts). I'll add a note to the Mantis ticket (http://bugs.idimager.com/view.php?id=2828) to that effect. You may wish to register and add your comments / file a separate bug report.

vlad
Posts: 895
Joined: 01 Sep 08 15:20

Re: Request help regarding tag delineation

Post by vlad » 27 Mar 15 13:07

Mke wrote:Just tried importing them into PSU here.

IMGP0878.JPG only has "Sussex" listed as a keyword in the details panel and in the LAP
IMGP0556.JPG only has "Bristol" listed in the details panel, but 20 labels are shown in the LAP (including "Photos by Matt" from the EXIF data, but not in your list above)

In both cases I see that the "creator" in the details panel is given as "Matt" "Buck" too - i.e. as two separate tags, rather than one.
I can confirm Mke's findings, down to the last detail.
I can't see any obvious reason for such behaviour, or why it would differ between you and me, and between the handling of the two images - in short, it looks like a bug (and a serious one, if you have 100,000 images where it may have got it wrong).
I completely agree.

Post Reply