Custom input fields + Versions + assignment = confusion

Post Reply
David Grundy
Posts: 241
Joined: 13 May 07 16:40
Location: Hong Kong

Custom input fields + Versions + assignment = confusion

Post by David Grundy » 29 Jul 13 17:22

I am experimenting with custom input fields.
But I have a problem when assigning value to Versioned files and hopefully someone can help.

Here's what I observe:
Sometimes when I search for "Version Sets", and then select some or all thumbnails, and then apply a value to a custom input field, the value gets applied to all Versions of the selected files.
Sometimes, it only seems to be applied to the Main Version.
Sometimes, the value I type in is shown in the input field after I have typed it, but then when I move away and then return to the same files, the value has not been applied.

Does anyone know how to predict which of these behaviours will occur? Is there some sort of indication which I'm not noticing as to what will happen?

... David

(All a bit frustrating ... I just saw my evening's work disappear due to values being unexpectedly applied to all versions when I thought I was just tidying up main versions. That wasn't what seemed to be happening earlier in the evening when I thought I tested the exact same process. The more I experiment, the more I can't work out what is happening!)

David Grundy
Posts: 241
Joined: 13 May 07 16:40
Location: Hong Kong

Re: Custom input fields + Versions + assignment = confusion

Post by David Grundy » 29 Jul 13 17:46

OK, I just realised it seems that PSu is very slowly working through the list and assigning the values to the files one by one. PSu does not report any processes active - Activity (no processes) - but each time I search for files containing the values I just tried to assign, it finds more files. It seems to be assigning maybe 20 files per minute.

I have not initiated any sync process but I can see ongoing disk activity which appears to be from PSu. (This is an external USB3 SS disk.) PSu is using between 1%-6% of CPU so not a heavy load.

Is this behaviour expected? It makes the custom input fields difficult to use in the way I had in mind.

... David

David Grundy
Posts: 241
Joined: 13 May 07 16:40
Location: Hong Kong

Re: Custom input fields + Versions + assignment = confusion

Post by David Grundy » 29 Jul 13 18:36

Things seem to work much more consistently in offline mode - the changes apply only to the version whose thumbnail is shown. Or at least, that's the way it looks.
Maybe what was happening before was that PSu was automatically starting to push out the field values to the files (although I never started a sync ) and wasn't finished whenever I did whatever I tried to do next each time. I can't remember the long sequence of things I did, so it could just be the effect of not knowing that each step's changes had not been applied.

In which case the next thing to do is for me to report a bug - that the application of custom input field values is very slow, and there is no warning that it's not finished, and additionally there is no progress indicator while it's all happening.

I will try to run more tests later in the week. I'm not yet sure that this is the answer.

... David

Hert
Posts: 5857
Joined: 13 Sep 03 7:24

Re: Custom input fields + Versions + assignment = confusion

Post by Hert » 29 Jul 13 20:13

David,

Could it be that you have auto-sync switched on?

Hert
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

David Grundy
Posts: 241
Joined: 13 May 07 16:40
Location: Hong Kong

Re: Custom input fields + Versions + assignment = confusion

Post by David Grundy » 30 Jul 13 2:23

Hert, that's a good point and I hadn't thought of checking. I just had a look. Here's what I have:
SyncSettings.jpg
SyncSettings.jpg (62.06 KiB) Viewed 1942 times
SyncSettingsRead.jpg
SyncSettingsRead.jpg (60.61 KiB) Viewed 1942 times
Looking at the keywords section I suspect this is not best practice. (Actually I am slightly confused generally about what to do with the keyword settings. I will look at this topic separately unless it's relevant to this particular discussion.)

Still, is there anything there which would contribute to the behaviour I'm seeing? I'm not actually 100% sure what a couple of those settings do.

Thanks
... David

David Grundy
Posts: 241
Joined: 13 May 07 16:40
Location: Hong Kong

Re: Custom input fields + Versions + assignment = confusion

Post by David Grundy » 04 Aug 13 4:41

In further testing I have found no problems assigning lots of Custom Input Field values when in Offline mode.

But it still seems to be true that in Online mode:
- Assigning values to custom input fields immediately triggers a file operation, even though "automatically write out Catalog changes to the image file" is unchecked in the preferences.
- The file operation can be quite slow - in major cases, I have seen this take more than a minute (working with an external disk)
- While the file operation is in progress there is no indication that the process is underway
- While the file operation is in progress, searches on the contents of the Custom Input Fields return results consistent with the partially completed state of the file operation. The results are different when the same search is run a few seconds later, as more files have been updated in the meantime. There is no indication that this is happening.

I am about to log all this as an issue in Mantis.
... David

Post Reply