Search doesn't return expected results

Post Reply
David Grundy
Posts: 241
Joined: 13 May 07 16:40
Location: Hong Kong

Search doesn't return expected results

Post by David Grundy » 07 Jul 13 18:55

I'm trying to find a way to display for a group of images the following versions:
- Album Display Version if it exists
- Main Version if there is no Album Display version.

I'm trying to set up a favourite search for this so that I can use it as a filter or as part of a dynamic search later.

I was sure I had a method that would work, but the search doesn't work and I don't understand why. Can anyone explain?

Here's what I do.
(1) Search for all Album Display versions
(2) To every one of these I add the (private) label VX Album Display which I have created to signify "Version exists: Album Display". Searching on this label should then get me every version set with an Album Display Version.
(3) To every one of the files in the CV I add the Text YV2Display in the custom data field QV2Display which is a data field specifically to hold the searchable string YV2Display for files which are set as Album Display versions. Unlike the label in (2), I should be able to use this to find exactly this version of each image, not any other file in the same version set. (Since custom data value in such fields is unique to the file, and is not synchronised across the version set.)

(4) Search for: Excluding label "VX Album Display".
This gives me 91675 images, none of which are versioned.
The Search summary at the top of the CV says excluding (VX Album Display*)
(5) I save this as a favourite search.

(6) Clear the dynamic search box.
(7) Search for the text string "YV2Display"@XMP
which returns 628 files, all of which are album display versions
The Search summary at the top of the CV says group(tex("YV2Display"@XMP"
(8) Save this as a favourite search

(9) Clear the dynamic search box
(10) Add the favourite from (5) to the search box
(11) Add the favourite from (8) to the search box
(12) Run an "OR" search with these two items

Since there are no version sets in common between these two favourited search terms, I should get 91675 + 628 = 92303 results.
Instead I get no results at all.
The Search summary at the top of the CV says excluding (VX Album Display*) so it seems it completely ignores the second search term.

Why? Any ideas appreciated.

... David

David Grundy
Posts: 241
Joined: 13 May 07 16:40
Location: Hong Kong

Re: Search doesn't return expected results

Post by David Grundy » 07 Jul 13 19:08

Just to add ... I can meet my original objective by adding the label "YV2Display" to the main version of every image that does not have an album display version, and then filter on the text "YV2Display". However that may create some headaches for ongoing maintenance. I will post about this in a separate thread when I have figured out a couple of tweaks to make it easier to manage.
But for now, I want to understand why the query above does not work as expected.
... David

Post Reply