Testing compatibility between Lightroom 4.1 and Supreme. - J

Post Reply
dickl
Posts: 128
Joined: 06 May 06 17:02
Location: Manitoba Canada

Testing compatibility between Lightroom 4.1 and Supreme. - J

Post by dickl » 09 Apr 12 16:55

Edit- My title was clipped... This test was with a virgin JPG image.

In the interest of trying to pin some of these issues down, I ran a few tests this morning.

Download images via LR4.1 Import, and write metadata to the image file in LR4.1.

Open Supreme, and import.

All looks fine. LR4 keywords correctly translated to labels, other IPTC fields appear to be entered correctly.

In Supreme, enter a caption… and sync…

Open LR4, and LR4.1 notices a change has been made to the image file… Read metadata…

Description/Caption field correctly transferred.

All Creator fields except Creator name are cleared in LR4.1.

As a final test, I save metadata to image file from Lightroom to see if these cleared fields are passed to Supreme.

LR4.1 reports "Could not write metadata - Unknown file formats."

Hope this is useful…

Dick

Hert
Posts: 5868
Joined: 13 Sep 03 7:24

Re: Testing compatibility between Lightroom 4.1 and Supreme.

Post by Hert » 09 Apr 12 17:07

Very helpful indeed. One quick question though: what supreme version are you running, because this particular issue should have been addressed in the latest beta.

Hert
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

dickl
Posts: 128
Joined: 06 May 06 17:02
Location: Manitoba Canada

Re: Testing compatibility between Lightroom 4.1 and Supreme.

Post by dickl » 09 Apr 12 17:54

Hert/IDimager wrote:Very helpful indeed. One quick question though: what supreme version are you running, because this particular issue should have been addressed in the latest beta.

Hert
Am using ver 1.0.0.32 Hert.

Am adding another test I ran this morning ...

Dick

dickl
Posts: 128
Joined: 06 May 06 17:02
Location: Manitoba Canada

Re: Testing compatibility between Lightroom 4.1 and Supreme.

Post by dickl » 09 Apr 12 17:56

A new LR4/Supreme test. This time begin by importing from Supreme rather than LR.

Apply saved detail profile in Supreme.

Import went ok… But detail profile had a Description that did not belong to the image - my Profile was incorrect. Deleted description, and tried to sync. Sync went ok, but for some reason the unsynch'd icon (orange dot) did not clear.

Looked at synch'd jpg file with Mac's Preview… Description had indeed indeed cleared…???

Now for LR4.1 compatibility.

Import from folder using LR4.1 Add preset (ie. no metadata preset applied by LR4.1 - just read image metadata from the image files in the folder.)

Creator Metadata not imported at all except for Creator name.

Edited caption not cleared - Still shows the incorrect description from the Supreme download! Perhaps Supreme's unsynch'd icon is indeed correct? Interesting… Mac's Preview showed the caption/description field as being cleared… Wonder if I am reading the same file? or there are more than one Description/Caption tags in the file???)

Now try to reread the Supreme image file to see if the fields get updated/populated…

Read metadata from LR4.1…

No change… LR4.1 shows metadata picked up on import was correct, and no new field updates took place. Description still shows the incorrect data from the Supreme profile...

Now edit (remove) description as I did in Supreme, and try to save metadata…

Fails. LR4.1 reports "Could not write metadata. Unknown file formats."

Abort, and try to re-read image file…

No problem. LR4.1 will not write to the Supreme downloaded image file, but it will read it picking up some of the metadata fields…

I conclude there is some incompatibility between Supreme and LR4.1 interpretation of metadata?


Hope this helps…

Dick

Post Reply