PS6 very slow when folder is missing NAS connection

Post Reply
oliverkalt
Posts: 12
Joined: 24 Feb 07 21:59

PS6 very slow when folder is missing NAS connection

Post by oliverkalt » 15 May 21 20:40

When a NAS drive is not connected, my PS gets very slow when loading (just timed an app restart with the missing connection at 58sec vs about 3sec otherwise) and any accidental touch of the missing drive in the folder tree turns into another waiting game.

A likely related observation: remapping a folder to the correct NAS address can be very tricky when the connection is missing (which is typically when it is needed I assume, during a NAS relocation). On right click to open the remap menu, I got an extended period of (Not Responding) in the menu bar and the Windows wait wheel. Then the intended menu flashed for a split second before disappearing. This turned into a 30 min project of attempts, computer restart, PS restart and repeated attempts to get the menu to stick. Once the menu was up, remapping worked like a charm

(build 6.1.0.3685)
Oliver

siehorst
Posts: 40
Joined: 09 Jan 08 18:36

Re: PS6 very slow when folder is missing NAS connection

Post by siehorst » 16 May 21 8:34

Hi Oliver,
whatever the reason is for that behaviour, I am glad to learn not to be the only one struggling with that:
viewtopic.php?f=57&t=28793
horst

siehorst
Posts: 40
Joined: 09 Jan 08 18:36

Re: PS6 very slow when folder is missing NAS connection

Post by siehorst » 16 May 21 12:07

Maybe I stepped on forward: The problem occurs if I - so I did in the past - point direct to a network device (NAS). It seem to be solved if I map the device as a local drive:
https://support.microsoft.com/en-us/win ... 1475f9557d
But PS does no recognize automatically if the drive letter is going online, I have to restart PS.
horst

siehorst
Posts: 40
Joined: 09 Jan 08 18:36

Re: PS6 very slow when folder is missing NAS connection

Post by siehorst » 17 May 21 19:45

Futile hope, I give up.

Hert
Posts: 6827
Joined: 13 Sep 03 7:24

Re: PS6 very slow when folder is missing NAS connection

Post by Hert » 18 May 21 9:42

siehorst wrote:
16 May 21 12:07
But PS does no recognize automatically if the drive letter is going online, I have to restart PS.
That means that Windows doesn't report when that drive letter comes online. PSU follows the OS. As long as PSU doesn't receive a drive change notification, PSU will not re-test that drive. That for the simple reason that testing a drive's availability can take many seconds for the OS to respond.

Here's a small script that you can run that will cause PSU to retest all drives (when needed).

Code: Select all

ClearMediaCache;
Say('done');
This is a user-to-user forum. If you need product support then please send a message

siehorst
Posts: 40
Joined: 09 Jan 08 18:36

Re: PS6 very slow when folder is missing NAS connection

Post by siehorst » 18 May 21 9:55

Hi Hert,
I will test, thank you, horst

Post Reply