IDimager V5.1 released!!

News and Announcements
Hert
Posts: 21144
Joined: 13 Sep 03 7:24

IDimager V5.1 released!!

Post by Hert » 16 Sep 10 20:43

IDimager V5.1 is released. This release focuses on bringing more speed, implementing further improvements, and fixing bugs.
The Label Assignment Panel for instance is 500% faster. Importing and synchronizing images 1 twice as fast. And the overal feel is snappier. Hope you all like this update.

Additions:

- In the Transfer dialog you can specify if Tags should be generated from Catalog Labels or not (only for Transfer to photo hosting websites)
- Added support for the MOS (Leaf) RAW format

Improvements:

- You can now use Lightroom(tm) keywords *without* having to use delimited keywords
- When, in the details of a Catalog Label, performing a name lookup for a GEO location then it will include the first upper parent in the lookup (e.g. for a label "Statue of Liberty" with parent "New York" the lookup name will be "Statue of Liberty,New York")
- You couldn't get the right authorizations on Facebook due to a change in the Facebook authorization mechanism. IDimager now supports this.
- Picasaweb implemented a change in their API which resulted in a "400 Bad Request" when using "Transfer to Picasaweb". This change is now supported.
- "Sync to Catalog" and the Import process is twice as fast as in earlier versions
- The color of the captions in the Image Detail panel is a tint off compared to the values. This should give a better reading experience
- Added a CreativeCommons XMP Feeder Script that interfaces using the CC-online interface (requires a connection with the Internet)
- In the Label Assignment Panel there is an icon in the box that allows you to instantly open that catalog label
- The Sepia editing effect is improved
- The "Label Assignment Panel" and "Quick Labeling" is now 500% faster
- Assigning Ratings/Color Labels/Bookmarks is faster
- The Stretch Mode, Designer Quality, Snapping, Borders, Border Color, and Border Size are now persistent between invocations of the Print dialog
- Label Sets in the Catalog Explorer's Stored Group branch are now expandable
- You can now better manage the design of a stored group from withing the Catalog Explorer
- When dropping a vertical oriented image as the thumbnail for a catalog label then the top area of the image is used instead of the center area
- You can now right click on a catalog label and then merge or relocate the catalog label
- Macro parsing is faster
- Batch Applying Image Details is faster; also makes the Downloader faster when using Image Details in a download profile
- Time needed to start a quick slide show is heavily reduced
- When clicking the orange dot icon for the "Catalog Labels" branch now gives *all* images in catalog instead of all images that are labeled
- Uploading with FTP is implemented as a background service now
- FTP'ing to a server only uploads when a checksum fails with the file on the server
- The Label Assignment panel is faster, noticeable for very large selections
- (IDimager Pro-Desktop and IDimager Personal): Before performing a backup of the databases, an integrity check of the database is executed. This will prevent backing up an already corrupted database

Fixes:

- Sometimes the drop downs for folders (like script folder) would give odd results
- You couldn't select an XMP Feeder Script for "language alternative" fields when multiple thumbnails were selected
- The background thumbnail builder didn't respect the options settings for Preview Quality and Thumbnail Quality
- In some cases, and for images with a recipe, the preview panel would display the preview with recipe double applied
- Fixed a bug that could cause the Downloader to become unstable with using pre or post scripts
- Fixed the occasional "List index out of bounds" error that could occur in the Downloader
- Fixed the occasional "List index out of bounds" error that could occur in the Collection Viewer
- When calling the the GEO Location Map selector in the Catalog Details frequently you could run into memory problems
- "Empty Images" from the Catalog Maintenance feature wouldn't clean out all the required data from the database
- When uploading to Flickr you could (in some cases) get duplicate set names on flickr and the uploaded images would be shattered over these sets instead of all in one set
- When you use the global sync-write option to generate parent keywords then, when those were marked to *not* write to Keywords, would be added anyway
- When changing the attached meta details for a Catalog Label, the assigned images to that label were not placed out of sync
- When using "Verify and Delete" during Download then sometimes not all files got deleted
- When adding/removing recipes from the recipe icon on thumbnails then the icon color would sometimes reflect the wrong recipe state
- In some cases the "auto rotate" feature in the Downloader didn't work as expected
- When using apostrophe in ProjectName and then used this macro command in the image details then the metadata wouldn't be applied to the Downloaded images
- The Downloader setting to "skip existing files" was not respected
- Fixed an issue that would raise SQLite error 19 while performing an import and the file path was stored on a network share and the length of the total path was exactly 127 characters


Spread the word!!! Thank you

Hert
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

martin.l
Posts: 151
Joined: 19 Jun 10 9:26

Re: IDimager V5.1 released!!

Post by martin.l » 16 Sep 10 21:06

Hert,

thank you for the new version, it's really speedy :D

Martin

Tonyyd
Posts: 42
Joined: 02 Jun 10 11:42

Re: IDimager V5.1 released!!

Post by Tonyyd » 16 Sep 10 21:48

Hert,

Brilliant work! I don't know how you keep making this program faster, it really zips through tasks.

Well done!

Tony

Dierk
Posts: 244
Joined: 16 May 07 20:15
Location: Hamburg
Contact:

Re: IDimager V5.1 released!!

Post by Dierk » 17 Sep 10 20:24

Unfortunately the connection error you squashed before is definitely back. Just wanted to update the last beta to the release, had to go through the menu, got the infamous 'you are not connected ...' message.


[Edit]
Had to close and re-start IDI, then it worked [though this doesn't work every time]. => No block on my side.
Dierk Haasis
[DH² Publishing]
Writing and Imaging

Nikon D2x, Nikon D200, Capture NX2, IDimager, Adobe Creative Suite, GeoSetter

RickHeath
Posts: 314
Joined: 14 Nov 07 15:06
Location: Bolton, United Kingdom

Re: IDimager V5.1 released!!

Post by RickHeath » 17 Sep 10 20:44

Unfortunately, installing V5.1 has completely killed the downloader for me :(

I've posted in the bugs forums with more info.

Rick

dimaip
Posts: 331
Joined: 12 Aug 07 12:39
Location: Russia, Moscow
Contact:

Re: IDimager V5.1 released!!

Post by dimaip » 22 Sep 10 7:35

Hey Hert, Thanks for the update!
I have no problem with the uploader so far.
What I have caught my attention in the first place, is how fast the CE now works - it now takes about 2 sec to expand the 'people' branch of my catalog (a few hundred labels), instead of like 10 sec. Awesome!

Still waiting for a better query mechansim, as my catalog grows, it became of great need to be able to build querys without the need to scroll thru catalog tree each time.

Regards,
Dmitri.

PS: And the xmp syncs now much faster!

Lars
Posts: 919
Joined: 13 Nov 09 6:44
Location: EU

Re: IDimager V5.1 released!!

Post by Lars » 25 Sep 10 6:08

dimaip wrote:Still waiting for a better query mechansim, as my catalog grows, it became of great need to be able to build querys without the need to scroll thru catalog tree each time.
Ones I had the same opinion, but then I discovered the "Quick Search Panel"-"search catalog labels":

It accept combined search, using "+, ?, -" for "AND,OR, NOT" - Don't have to write full label names since it come up with a list of possibilities - Have you tried it? - I use it a lot and it's really useful.
W7/64bit, IDimager V5 ProSL

milutinm
Posts: 2
Joined: 24 Sep 10 23:23

Re: IDimager V5.1 released!!

Post by milutinm » 26 Sep 10 19:20

Now that the program updated itself to 5.1 i get a trial/register notice and have the trial software countdown every time i start the program...... there doesnt appear to be any way to register this program properly now

weidmic
moderator
Posts: 4463
Joined: 04 Dec 06 22:21

Re: IDimager V5.1 released!!

Post by weidmic » 26 Sep 10 19:40

Hello milutinm, welcome to the forum.

This might help you: http://forum.idimager.com/viewtopic.php?f=24&t=5856

Best Regards,
Michael
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

milutinm
Posts: 2
Joined: 24 Sep 10 23:23

Re: IDimager V5.1 released!!

Post by milutinm » 26 Sep 10 23:34

Thank you for the welcome ... and the advice.
That did the trick!

Again, thanks.
M.

saronann
Posts: 7
Joined: 17 Feb 09 11:36

Re: IDimager V5.1 released!!

Post by saronann » 27 Sep 10 16:51

Oh, great. Now I get a DEP (data execution prevention) error from Win Vista 64 when I try to use IDimage 5.1. It opens. Change a directory and DEP. Now I can't use IDImager PRO at all.

weidmic
moderator
Posts: 4463
Joined: 04 Dec 06 22:21

Re: IDimager V5.1 released!!

Post by weidmic » 27 Sep 10 17:04

Hi Saronman,

Sorry to hear that you are running in a problem with the DEP.
However, it is easy to change settings and exclude applications.
So it should be fairly easy to get IDimager back and running...

Best Regards,
Michael
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

saronann
Posts: 7
Joined: 17 Feb 09 11:36

Re: IDimager V5.1 released!!

Post by saronann » 27 Sep 10 17:35

What should I change in my setup so that IDImager won't shutdown with a DEP when it encounters an AVI, EXR or 32-bit PSD image?

Edit: No, this happens even with 8-bit JPEGs only in the directory.

Never had this problem before updating to v5.1. Why does v5.1 trigger a DEP when v5 did not - for the same images and the same directories?

weidmic
moderator
Posts: 4463
Joined: 04 Dec 06 22:21

Re: IDimager V5.1 released!!

Post by weidmic » 27 Sep 10 18:36

saronman,

I checked my settings and DEP is enabled... No problems with IDimager though
First I would check if your computer is not under attack (e.g. with the free Microsoft Security Essentials)
When you are sure there is nothing going on on your computer you may try to exclude IDimager from being shut down through DEP (http://en.wikipedia.org/wiki/Data_Execution_Prevention)

Maybe someone more experienced with DEP can chime in.

Best Regards,
Michael
PSUServer 4.x, PostgreSQL 10.x
My homepage http://www.michaelweidner.com
PSU Tips and Tricks http://www.michaelweidner.com/WP/psu/

saronann
Posts: 7
Joined: 17 Feb 09 11:36

Re: IDimager V5.1 released!!

Post by saronann » 27 Sep 10 20:52

Thanks for the reply. No, my PC is not under attack. What I do not understand is why did IDImager work fine before the update to v5.1 unless there is a problem/bug in v5.1.

Locked