Search found 39 matches

by gcurrie
20 Jun 21 23:35
Forum: Photo Supreme Online BETA
Topic: PSO - Trial expired message
Replies: 7
Views: 534

Re: PSO - Trial expired message

Hert:

E6BA9A949692B0ADB5BA9194ACBAAFA4
is expired. Can I get a reset?
by gcurrie
05 May 21 23:26
Forum: Photo Supreme Online BETA
Topic: Public Beta for Photo Supreme Online
Replies: 25
Views: 6025

Re: Public Beta for Photo Supreme Online

Follow up - I rebooted the server and the authentication now works as designed. I'll post more as soon as I use it more. Looks very useful here as we sometimes just want to review or display photos without using the full program. I'm guessing that I can use ANY modern device with a browser to displa...
by gcurrie
05 May 21 16:31
Forum: Photo Supreme Online BETA
Topic: Public Beta for Photo Supreme Online
Replies: 25
Views: 6025

Re: Public Beta for Photo Supreme Online

In the configuration, the PostgreSQL password is correct, as I can use the Test button and it reports a connection. On both main and thumbs database.

I enter the Photo Supreme User/password for that machine (not the PostgreSQL user/password).
by gcurrie
05 May 21 0:18
Forum: Photo Supreme Online BETA
Topic: Public Beta for Photo Supreme Online
Replies: 25
Views: 6025

Re: Public Beta for Photo Supreme Online

I can now see the Photo Supreme Online window, with a login box. I tried to login with Photo Supreme user/passwords, but it seems to ONLY want postgres as the username. error: Cannot load options; [FireDAC][Phys][pg][libpg] password authentication failed for user "postgres" followed by error: fail t...
by gcurrie
04 May 21 21:05
Forum: Photo Supreme Online BETA
Topic: Public Beta for Photo Supreme Online
Replies: 25
Views: 6025

Re: Public Beta for Photo Supreme Online

I just installed this on my server after upgrading to PS 6. If I open a browser on my LAN to 192.168.1.101:8081 then it immediately redirects to 192.168.1.101:8081/#/. At the bottom of the browser window is a line "The service is currently unavailable. Please try again later." The firewall shows tha...
by gcurrie
21 Aug 20 3:19
Forum: Photo Supreme
Topic: Wrong image counts in Catalog Tree
Replies: 37
Views: 7227

Re: Wrong image counts in Catalog Tree

I finally was able to update PostgreSQL to v 12. After restoring the databases, the Timeline counts returned (and expanding the years works). Maybe it was corruption in the db? No idea, but it stopped working no more than a month ago, and there were no other odd behaviors. Is there an updated versio...
by gcurrie
15 Aug 20 23:29
Forum: Photo Supreme
Topic: Wrong image counts in Catalog Tree
Replies: 37
Views: 7227

Re: Wrong image counts in Catalog Tree

Installing newest version and selecting PostgreSQL 12 (to install client libraries) did not work.

Is there a guide anywhere to upgrading the server AND how to upgrade the PS database? It's been a few years.
by gcurrie
15 Aug 20 1:15
Forum: Photo Supreme
Topic: Wrong image counts in Catalog Tree
Replies: 37
Views: 7227

Re: Wrong image counts in Catalog Tree

Thanks Hert! I am running PostgreSQL 9.6 on both Windows server and Win10 clients. It's been a few years since I set it up. I'm assuming I would need to upgrade to 12 on the server as well? I've been looking for a good reason to up to 12. Or is it only the client libraries that are the suspect here?...
by gcurrie
13 Aug 20 3:49
Forum: Photo Supreme
Topic: Wrong image counts in Catalog Tree
Replies: 37
Views: 7227

Re: Wrong image counts in Catalog Tree

I backed up the photosupreme database and put it on Dropbox. Sent a link to support@idimager.com.
by gcurrie
12 Aug 20 5:54
Forum: Photo Supreme
Topic: Wrong image counts in Catalog Tree
Replies: 37
Views: 7227

Re: Wrong image counts in Catalog Tree

Hert:

I'd be happy to. Let me know:

Format
Encoding
Dump options
Role name
by gcurrie
10 Aug 20 22:03
Forum: Photo Supreme
Topic: Wrong image counts in Catalog Tree
Replies: 37
Views: 7227

Re: Wrong image counts in Catalog Tree

The result from that script: Information ----------- 1972 1972-03 2001 2001-02 2001 2001-04 2001 2001-05 2001 2001-06 2001 2001-07 2001 2001-09 2001 2001-10 2001 2001-12 2002 2002-01 2002 2002-03 2002 2002-04 2002 2002-05 2002 2002-06 2002 2002-07 2002 2002-08 2002 2002-09 2002 2002-10 2002 2002-11 ...
by gcurrie
10 Aug 20 20:46
Forum: Photo Supreme
Topic: Wrong image counts in Catalog Tree
Replies: 37
Views: 7227

Re: Wrong image counts in Catalog Tree

Hert:

Here is the result from the script:
Information
-----------
2010
2018
2006
2003
2020
2005
2013
2009
2004
1972
2007
2012
2019
2011
2002
2001
2014
2017
2008
2015
2016


[OK]
by gcurrie
10 Aug 20 8:18
Forum: Photo Supreme
Topic: Wrong image counts in Catalog Tree
Replies: 37
Views: 7227

Re: Timeline counts all zero?

1. Yes, after at least a month with 2-3 server reboots.
2. Screenshot attached. There are no months, only years.
3. All users are admin.
4. Using the same catalog for years, no switch.

Oddly enough, the Memories section does include a small slice of images.
by gcurrie
10 Aug 20 4:45
Forum: Photo Supreme
Topic: Wrong image counts in Catalog Tree
Replies: 37
Views: 7227

Timeline counts all zero?

PhotoSupreme on a server on PostgreSQL 9.6. Clients all at build 3044.

After one of the more recent builds, noticed all years under Timeline are zero.

How do I get the Timeline sections to update?
by gcurrie
08 Jun 20 20:58
Forum: Photo Supreme
Topic: Error updating to v5 build 2960
Replies: 8
Views: 1722

Re: Error updating to v5 build 2960

Hert: Thanks for this script. I was able to update the database. I had to modify the script. When I executed "drop function process_idSearchDataUpdateFTS;" I got a syntax error. I had to DROP that function manually. Then I was able to run the next two lines without errors. Connecting an updated clie...