Finding folders takes forever

Post Reply
sgbotsford
Posts: 11
Joined: 11 Feb 12 21:48

Finding folders takes forever

Post by sgbotsford » 09 Feb 18 5:28

Day 2 of my trial.

PSu was fairly quick at importing my aperture library. (I pointed it at the masters folder)

Now
/Volumes/User_Raid/Aperture Library.aplibrary
568 ==> time find Masters/ | wc -l
29274

real 0m1.532s
user 0m0.021s
sys 0m0.092s
So there''s 29 thousand files and folders in Masters. A simple find takes 1.5 seconds to traverse the tree.

I started PSu at 10 p.m. last night. Was still running this morning at 8 o'clock. This is odd. When I unlocked at 8:30 it was at 73% done. The last quarter took 20 minutes
* Does the program stop running when my screen goes off?. (My computer is set NOT to go to sleep, and NOT to spin down it's drives)
* Is the percentage estimator out to lunch?

So we started a folder verification on that same folder at 8:50. At 3:45 it's 72.5% done. Not sure what it's doing.

Well, it finished while I was away. Came back. It had discovered 28 files.

Clicked All, then clicked folders. Took 90 seconds to come up with the 7 2nd level folders in Masters

Now I see something *really* weird.

The folders are 1 per year, then 1 per month, but all the dates are wrong.

The folder 20140719-124221 contains files shot 2013-03-26 at 4:30:14

This may be Aperture's quirkiness in filing. Checked. Yes it is. Folders become useless to me.

Click timeline. Long 10 second pause.

Click 2013. Snappy opening.
There are 5 shots total.

Go back to Aperture
Filter: Capture Year = 2013

1863 images

And 1899 has 84329 images. Out of 24,000 masters.

Click back to folders. Folders goes blue but remains small.

30 seconds
53 seconds.

What am I doing wrong?

sgbotsford
Posts: 11
Joined: 11 Feb 12 21:48

Re: Finding folders takes forever

Post by sgbotsford » 09 Feb 18 20:38

Ok. I may have remnants of a PSu 3 trial lurking about. So we will remove all files from the database, and start over.

Takes 5 minutes.

In categories I still have 32 things in Miscellaneous. Delete is greyed out.

In Portfolios I have 76695 images. But it seems to be a total. Nothing clickable.

In folders I have no folders but the same 76695 images in grey text.

In Timeline I still have thousands of images, but most of them are 1899. Raatiens I have 10 with ratings the other 76985 have no ratings. None of the categories are clickable.

Colours didn't pick up aperture colours. Types. No NEF (Nikon's raw format) and only 51 tiff. (A CD format from long ago when I shot film)

****
Quit PSu
30 seconds
60 seconds.
Force quit.

Ok. Rip out PSu.
Rip out the entire catalog tree.
Reinstall.

Next: export Aperture to referenced files so that folder structure is intact.

rfcat
Posts: 33
Joined: 21 Feb 07 11:38
Location: Australia

Re: Finding folders takes forever

Post by rfcat » 12 Feb 18 23:02

I just started a thread on PSu stopping when screen saver cuts in.
ian
Ian M
Photography, understanding how to catalogue so I can find my photos. :D .

Post Reply