TSQLServerConnection : Error 20009 :

Post Reply
ebw
Posts: 3
Joined: 11 Aug 17 1:08

TSQLServerConnection : Error 20009 :

Post by ebw » 11 Aug 17 21:03

New Install - I’m having trouble setting up a new SQLServer database. I’m not very computer literate and I sure could use some help.
I followed the instructions given in the “Installation Guide”, but when I try “Test Settings” I get the following message:

Database connection test failed
TSQLServerConnection : Error 20009 :
Unable to connect: Adaptive Server is unavailable or
does not exist

I’m not sure what to do from here?

Win7 Professional SP1
Intel® Core™ i7-4770 CPU @ 3.40GHz
16.0 GB (RAM)
64-bit Operating System

Hert
Posts: 20310
Joined: 13 Sep 03 7:24

Re: TSQLServerConnection : Error 20009 :

Post by Hert » 12 Aug 17 5:33

Try to connect using the IP address as the hostname
Also don't forget to add the instance name separated with a backslash
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

ebw
Posts: 3
Joined: 11 Aug 17 1:08

Re: TSQLServerConnection : Error 20009 :

Post by ebw » 12 Aug 17 22:03

Thank you Hert for your suggestions.

I used my IP address\postgresql-x64-9.3 and port 5432
User Name: portgres and password

But I still can’t seem to setup a new SQLServer database …
Database connection test failed
TSQLServerConnection : Error 0 :

Can you think of anything else I should look into or double check?

Hert
Posts: 20310
Joined: 13 Sep 03 7:24

Re: TSQLServerConnection : Error 20009 :

Post by Hert » 13 Aug 17 9:00

Postgresql? The error you get tells me that you installed the PSU-Sqlserver version. Make sure that you install the PSU-postgresql version if you intend to use PSU with PostgreSQL.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

ebw
Posts: 3
Joined: 11 Aug 17 1:08

Re: TSQLServerConnection : Error 20009 :

Post by ebw » 14 Aug 17 17:12

Oh my …….. I feel like the village idiot ……

Yes indeed I installed the server version of Photo Supreme. I uninstalled it and installed the correct version and everything is working properly. I’m really excited to start using Photo Supreme.

Hert – Thank you so much for your input. I never would have figured it out on my own.

Post Reply