Adding a rating (sometimes?) causes tags and descriptions to disappear

Post Reply
barneagle
Posts: 60
Joined: 13 Nov 16 13:18

Adding a rating (sometimes?) causes tags and descriptions to disappear

Post by barneagle » 18 Apr 17 20:13

I have just set about applying ratings to some photos which I had previously tagged. I noticed that, for some pictures, after applying a star rating where previously there was none the keywords disappeared from the Details panel. When I looked at the file Properties in Windows Explorer the "tags" had disappeared. Fortunately, I noticed that in the Assign panel the labels were still present in PSU and after using Ctrl-S to save the metadata the keywords reappeared in the Details panel and the tags reappeared in the Windows file properties.

In another instance I noticed that, after applying a star rating, the Keywords/Tags remained but the Description I had previously entered disappeared from the Details panel and it was no longer shown against Subject in Windows Properties. This time saving metadata did not cause the "Description" or "Subject" to reappear.

Is this behaviour to be expected? What can I be doing wrong?

Hert
Posts: 20238
Joined: 13 Sep 03 7:24

Re: Adding a rating (sometimes?) causes tags and descriptions to disappear

Post by Hert » 19 Apr 17 7:19

Sound like you have a legacy of existing discrepancies between XMP and other metadata.

Do this to fix your discrepancy:
1. Select thumb(s)
2. Right click
3. Select Metadata -> Convert Metadata to XMP

PSU will then make sure that metadata from other sections (Exif/IPTC) is correctly converted to XMP. There are unfortunately too many tools out there that write XMP sections without migrating the existing metadata to XMP...leaving you with discrepancies. Then in PSU those will become painfully clear as PSU is fully XMP driven
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

barneagle
Posts: 60
Joined: 13 Nov 16 13:18

Re: Adding a rating (sometimes?) causes tags and descriptions to disappear

Post by barneagle » 20 Apr 17 8:50

Thanks for the advice. As a matter of interest is metadata converted to xmp as part of the Import process?

jstartin
Posts: 381
Joined: 23 Aug 06 13:47
Location: UK

Re: Adding a rating (sometimes?) causes tags and descriptions to disappear

Post by jstartin » 20 Apr 17 13:45

Exif and IPTC from the file are converted to XMP (all are metadata :wink:) in the database during import provided that there is no XMP already in the file. If PSu detects that XMP already exists in the file then reconversion/further conversion does not happen automatically. If other applications have written partial or malformed XMP (many do) then you get problems. Most are fixed by forcing PSu to start again by converting Exif/IPTC to XMP explicitly. Some applications (raw converters mostly) write their own stuff into the files as XMP, but not the standard metadata. PSu may overwrite this during Convert Metadata to XMP causing some information loss.
Jim (Photo Supreme: AMD Quad-Core A8-5500 Accelerated Processor 3.2 GHz; internal AMD Radeon™ HD7560D; 4GB DDR3 SDRAM; Win7x64)


Post Reply