images added via verify do not show up

Post Reply
User avatar
fbungarz
Posts: 3115
Joined: 08 Dec 06 5:03
Location: Galapagos, Ecuador

images added via verify do not show up

Post by fbungarz » 16 Feb 17 16:52

Hi all,
I am traveling with a copy of my database and an external hard drive with all my photos. Works well, the hard drive is recognized, I can create copies of the photos, edit them and verify the folder.
They show up correctly in States - Last Import and now it gets really weird...
I cannot then find the files in the folder where they should be located!
After a while I figured out the database correctly recognizes the external hard (F:) drive with the copies of all my files, but it also thinks the original internal hard drive from my desktop PC is still attached as well. So it shows me TWO drives labeled as F:\ to be online: the newly "imported" images that were added by the verify command are in the USB hard drive with a different serial from the internal PC harddrive (which is actually not online, but at home inside my desktop PC).

Here a screenshot:
Harddisk-duplicates.jpg
Harddisk-duplicates.jpg (99.75 KiB) Viewed 575 times
How do I fix this???
Thanks,
Frank

User avatar
fbungarz
Posts: 3115
Joined: 08 Dec 06 5:03
Location: Galapagos, Ecuador

Re: images added via verify do not show up

Post by fbungarz » 16 Feb 17 18:26

HI,
I managed to solve it by "right-click" on the F:\ drive that is shown online despite not being connected and remap it to the external USB drive. Al went well, but oddly enough most files in the folder I have used "verify" on where then no longer versioned. So, I had to run detect version on that folder again.
All a bit mysterious...
... but solved.
Cheers,
Frank

gcorbin
Posts: 51
Joined: 21 Aug 06 12:31
Location: Brisbane

Re: images added via verify do not show up

Post by gcorbin » 17 Feb 17 12:39

Ahh. You got caught by this as well. It is very logical when you understand what is going on.

Photo Supreme recognises each drive uniquely. Despite your old internal drive being F: and the new external drive being F:, Photo Supreme knows that they are different physical drives and treats them as different. In the folder view, you will find two F drives, the old internal one which will be red and off line and the new external F drive which will be grey and online. Now you understand Photo Supreme has two F drives, you will find your recently downloaded photos in the appropriate directory in your new F drive, not the old F drive. Unfortunately, the old F drive is listed before the new F drive and so you will not notice the new F drive exists.

When you copied your photos from the old internal drive to the new external drive, you should have either used Photo Supreme to do the move so it knows the photos are moved, or remaped the base directory to the new drive so Photo Supreme knows the photos are now moved. Photo Supreme is quite smart with its drive recognition and you need to keep it informed when you change drives.

I hope I have explained this clearly. It is really confusing when it first happens to you, but it is very logical and the correct thing to do from Photo Supreme. It is really easy to get out of this bind just by remapping the base photo folder, just as you discovered by accident.

User avatar
fbungarz
Posts: 3115
Joined: 08 Dec 06 5:03
Location: Galapagos, Ecuador

Re: images added via verify do not show up

Post by fbungarz » 21 Feb 17 19:54

Not correct!
Look at the screenshot. BOTH drives are marked as online! It is NOT the case that the internal one (which does not exist) is marked red. It is NOT marked red.

gcorbin
Posts: 51
Joined: 21 Aug 06 12:31
Location: Brisbane

Re: images added via verify do not show up

Post by gcorbin » 22 Feb 17 8:27

Sorry. I did not look too close at the screenshot. As to why the offline old F drive is not red is beyond my simple knowledge of drive behaviour in PS. Someone more knowledgable will need to explain why the offline drive is not red.

You can see that the two F drives have different numbers in the square brackets. This is the 'identifier' that Photo Supreme uses for drives and how it differentiates the old drive from the new drive even though they have the same drive letter. The remainder of my logic is correct as to my understanding and experience. I just cannot explain why the old F drive is not red the same as the G drive in the screenshot.

Preston B
Posts: 389
Joined: 24 Feb 10 19:01
Location: Columbia, CA

Re: images added via verify do not show up

Post by Preston B » 22 Feb 17 16:35

I do not understand why Frank's off-line drive is not marked in red, either. I have a drive S:\ that is currently off-line, and it is marked 'red' in PSu. My guess is that what Frank is seeing not a bug, but lies in the manner in which the OS is seeing the drive.

Frank, if you are using Windows, open Disk Management and look to see which drives are shown. Off-line drives should not appear there.
--P
Preston Birdwell
Columbia, CA

Photo Supreme on Puget Systems Obsidian: Win 10-64 bit Intel i5Quad Core 3.3Ghz 32GB RAM, and Puget Systems Traverse Laptop. Chamonix 4x5 and Nikon D-7100.

Please visit my web site at www.gildedmoon.com

Post Reply