Share to Facebook

germie
Posts: 13
Joined: 27 Apr 15 22:43

Share to Facebook

Post by germie » 24 May 15 1:42

Ha All,

Recently my share to Facebook stopped working.
I tried deleting the transfer protocol and creating a new one but it always end up just after authentication.
At that moment a message appears in the browser:
Application object error 'ASP 0102 : 80004005'
Expecting string input
/facebook/facebooksuccess.asp, line 92
The function expects a string as input.


Has anyone else experienced this problem?
Any help is appreciated.

Regards from Holland
Germie

Hert
Posts: 20950
Joined: 13 Sep 03 7:24

Re: Share to Facebook

Post by Hert » 24 May 15 9:38

Oh no, Facebook changed something in their login and authorization structures again. Unfortunately they killed the old format. An update is needed for this.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

mantras
Posts: 209
Joined: 24 Dec 12 8:36

Re: Share to Facebook

Post by mantras » 07 Jun 15 6:43

IDimager wrote:Oh no, Facebook changed something in their login and authorization structures again. Unfortunately they killed the old format. An update is needed for this.
Hi Hert

updated photo supreme 3.1.0.2068 this morning , the update changed my photo supreme settings and the facebook loop is still present under windows

thanks
Photo Supreme Evangelist ,windows 10 & macos Sierra & high sierra ,photosupreme 4, lightroom & photoshop cc

Hert
Posts: 20950
Joined: 13 Sep 03 7:24

Re: Share to Facebook

Post by Hert » 07 Jun 15 8:40

Did you disconnect and re-authenticate in the profile?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

mantras
Posts: 209
Joined: 24 Dec 12 8:36

Re: Share to Facebook

Post by mantras » 07 Jun 15 9:26

IDimager wrote:Did you disconnect and re-authenticate in the profile?
hi
yes i did it
but everytime i click ok , photo supreme opens another page

i noticed that i can't select english language , the folder contains an empty file


Image

thanks
Photo Supreme Evangelist ,windows 10 & macos Sierra & high sierra ,photosupreme 4, lightroom & photoshop cc

Hert
Posts: 20950
Joined: 13 Sep 03 7:24

Re: Share to Facebook

Post by Hert » 07 Jun 15 9:36

This is the process:
1. Create a Share Profile
2. Click Authenticate
3. PSU will open a call to Facebook. If not logged in already, FB will ask you to do so
4. You must Login at FB and optionally authenticate IDimager there. Once you're FB authentication is complete you're taken to a page on the idimager.com site with a message "You've succesfully authenticated the application."
5. Now return to PSU
6. Click OK to indicate that you've authenticated successfully (don't click OK until *after* you've authenticated at FB and you get the message from step 4)
7. That's it

When does it differ for you?

PS. You should select the English language in the Preferences. The translation file is indeed empty and it's supposed to be empty for English
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

mantras
Posts: 209
Joined: 24 Dec 12 8:36

Re: Share to Facebook

Post by mantras » 07 Jun 15 9:49

IDimager wrote:This is the process:
1. Create a Share Profile
2. Click Authenticate
3. PSU will open a call to Facebook. If not logged in already, FB will ask you to do so
4. You must Login at FB and optionally authenticate IDimager there. Once you're FB authentication is complete you're taken to a page on the idimager.com site with a message "You've succesfully authenticated the application."
5. Now return to PSU
6. Click OK to indicate that you've authenticated successfully (don't click OK until *after* you've authenticated at FB and you get the message from step 4)
7. That's it
i did exactly it, to authenticate i have to click cancel and i can record a video and send via email
When does it differ for you?

PS. You should select the English language in the Preferences. The translation file is indeed empty and it's supposed to be empty for English
i tried to switch language via preferences ->english ->close photo supreme -> restart ps it's still in italian , i can select every language outside english
Photo Supreme Evangelist ,windows 10 & macos Sierra & high sierra ,photosupreme 4, lightroom & photoshop cc

Hert
Posts: 20950
Joined: 13 Sep 03 7:24

Re: Share to Facebook

Post by Hert » 07 Jun 15 11:11

Thank you for the Video that clearly shows what you see.

Can you try this:
1. Open Facebook
2. In Settings->Apps delete the IDimager app
3. Start the Authentication again with PSU

BTW; the language thing was a bug and the release was instantly updated. The update may not be detected automatically (due to this same reason) so please use Help->Check for Updates.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

mantras
Posts: 209
Joined: 24 Dec 12 8:36

Re: Share to Facebook

Post by mantras » 07 Jun 15 15:20

IDimager wrote:Thank you for the Video that clearly shows what you see.

Can you try this:
1. Open Facebook
2. In Settings->Apps delete the IDimager app
3. Start the Authentication again with PSU
sure i did it
nothing , there is a loop everytime i click on OK like the video, i tried to delete the app from facebook , i tried to disconnect from facebook and re-connect
no luck
i have only 1 browswer and it's firefox 38.0.5 , could be the culprit?
thanks
Photo Supreme Evangelist ,windows 10 & macos Sierra & high sierra ,photosupreme 4, lightroom & photoshop cc

vlad
Posts: 967
Joined: 01 Sep 08 15:20

Re: Share to Facebook

Post by vlad » 07 Jun 15 17:01

mantras wrote: no luck
i have only 1 browswer and it's firefox 38.0.5 , could be the culprit?
Not sure how could the browser be responsible for the PSU authentification, but if you really have a suspicion you might want to clear up the browser cache+cookies and try again.

mantras
Posts: 209
Joined: 24 Dec 12 8:36

Re: Share to Facebook

Post by mantras » 07 Jun 15 17:30

vlad wrote:
mantras wrote: no luck
i have only 1 browswer and it's firefox 38.0.5 , could be the culprit?
Not sure how could the browser be responsible for the PSU authentification, but if you really have a suspicion you might want to clear up the browser cache+cookies and try again.
hi
does you ps facebook share work perfecly with the last update?
do you run w7 ?
i did everything , clean chache , history , cookies
Photo Supreme Evangelist ,windows 10 & macos Sierra & high sierra ,photosupreme 4, lightroom & photoshop cc

vlad
Posts: 967
Joined: 01 Sep 08 15:20

Re: Share to Facebook

Post by vlad » 07 Jun 15 17:45

Sorry, I can't answer as I don't share to FB.

flossie
Posts: 23
Joined: 08 May 12 10:25
Location: Christchurch, New Zealand

Re: Share to Facebook

Post by flossie » 14 Sep 15 6:20

Hi folks
I am trying unsuccessfully to set up PSU sharing to Facebook.
I have read the suggestions provided to the user above and cannot get this to work. I'm getting stuck in a loop.

Here's what I've done:

1. Deleted my very old Share Profile (which didn't work)
2. Set up new Share Profile.
3. Clicked Authenticate.
4. (As I was already logged in to FB and already had the IDI app installed:) I was immediately taken to a page on the idimager.com site with the message "You've succesfully authenticated the application."
5. (As per the IDI page's instructions:) I closed the IDI page and returned to PSU where I clicked OK to indicate that I've authenticated successfully. This caused a loop of steps 3-5.

6. I deleted the old IDI app in my FB settings/apps.
7. I again clicked Authenticate in PSU.
8. I went to my Facebook's apps page where I accepted IDI's request to access my FB account. This allowed me to choose what level of access I gave (I accepted the app without sharing my photos and video collection to it).
9. (As I was already logged in to FB and newly had the IDI app installed:) I was immediately taken to a page on the idimager.com site with the message "You've succesfully authenticated the application."
10. (As per the IDI page's instructions:) I closed the IDI page and returned to PSU where I clicked OK to indicate that I've authenticated successfully. This caused a loop of steps 3-5.

Hert
Posts: 20950
Joined: 13 Sep 03 7:24

Re: Share to Facebook

Post by Hert » 14 Sep 15 6:49

Facebook changed their policy. They now want to review every application up front. To do so the application has to state which FB roles an application uses. In order to upload photos a specific role is needed and I asked them to review it. But this is an implicit requirement, it's not used but needed by their uploading features and so without that role the upload won't work. Still they claim that the application hasn't used that role (it doesn't use it by itself but the FB API needs it to upload and raises an error without) and so I can't submit for review. I then filed a bug report and while their support people helped me a lot and eventually they manually submitted the app to bypass the buggy restriction. Then the review denied the app because the role wasn't used...and I can resubmit because they claim the role isn't used and so I'm running circles with them. It's been like this for a few weeks now and nothing seems to help.

This has been frustrating me a lot and has been going on for about 2 months now and during all that time nobody was able to upload to FB (apart from one email, you're the first to report this so it seems that hardly anyone still uses FB as a sharing tool). FB support will be dropped in the next update until after FB was able to fix this bug and I can submit for review.
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

flossie
Posts: 23
Joined: 08 May 12 10:25
Location: Christchurch, New Zealand

Re: Share to Facebook

Post by flossie » 15 Sep 15 0:35

OK thanks for letting me know, I can see how that would be frustrating.

"...(apart from one email, you're the first to report this so it seems that hardly anyone still uses FB as a sharing tool)..."
I think this is conditionally true - true for perhaps the majority of your current users, but totally not true for the majority of your potential users.
(Just that when I read through this user forum, the impression I get is that I'm in the company of mostly men who are also serious photographers and generally pretty clued up about IT (would know difference between SMTP and POP etc...). I don't fit that profile (have to Wikipedia everything tech ;), but enjoy PSU because its the best tool out there for giving me control over my collection, and I think if only it was a little more social then a lot more people like me would also want to use it. After all, its also a very friendly and helpful community :)

Post Reply