Can't Remove Image from Portfolio

A forum for questions about how IDimager works
Post Reply
MikeA01730
Posts: 60
Joined: 29 Sep 11 22:52

Can't Remove Image from Portfolio

Post by MikeA01730 » 29 Nov 13 15:07

Hi,

I have a portfolio of around 650 images. I need to remove a few of the images from the portfolio, but for some of the images I can't make that happen. What happens is that when I select the image and press the Del key, the pop-up menu doesn't provide a choice to remove the image from the portfolio. I see choices to remove the image from the data base and to remove it from the data base and delete it, but that's it. I know the image is in the portfolio because when I pass the pointer over the image the pop-up indicates that the image is in the portfolio, and if I view the portfolio the image is included.

In all the cases I've looked into in detail the image has been in a version with a similarly named image, e.g. IMG_0123.jpg and IMG_0123a.jpg. Often one image was in the portfolio, and I indexed the new image, added it to the portfolio, tried to remove the first image from the portfolio, and I couldn't do it. I've tried breaking the versions, renaming one or both files, and other things I don't recall right now, and nothing works. The problem persists even if I unindex the files and reindex them.

Any ideas how to delete the unwanted images from the portfolio?

Thanks,
Mike

Hert
Posts: 20348
Joined: 13 Sep 03 7:24

Re: Can't Remove Image from Portfolio

Post by Hert » 29 Nov 13 16:28

Can you delete it when you open the portfolio collection for that image?
This is a User-to-User forum which means that users post questions here for other users.
Feature requests, change suggestions, or bugs can be logged in the ticketing system

Mike Buckley
Posts: 4561
Joined: 10 Jul 08 14:18

Re: Can't Remove Image from Portfolio

Post by Mike Buckley » 30 Nov 13 7:07

Try compacting the database and then deleting those images.

MikeA01730
Posts: 60
Joined: 29 Sep 11 22:52

Re: Can't Remove Image from Portfolio

Post by MikeA01730 » 03 Dec 13 1:44

Hi,

Two files involved in this are mja_13-06-06_021x.jpg and mja_13-06-06_021a.jpg which are both in the same folder. The first image has been in the portfolio a while, and I recently tried to replace it with the second newer image. There are also various cr2, tif, psd, and dop files for each image.

As I did the following operations I logged each one as I did it to make sure I got an accurate record. Here's what happened.

First I compacted the DB, unindexed the 2 images, and then re-indexed them using Scan this folder for uncataloged images.

When I selected the folder for viewing, both images were shown. When I passed the pointer over each image, the pop-up box indicated that both were in the portfolio. When I invoked delete for each, neither one offered deletion from the portfolio. That's one problem: the delete isn't offering a choice to delete from the portfolio when the image appears to be in the portfolio.

When I selected the portfolio for viewing, the first image was included and the second was not. When I passed the pointer over the image, the pop-up box indicated that it was in the portfolio. That's a second problem: when the portfolio is selected for viewing, an image apparently in the portfolio isn't shown. When I invoked delete for the (first) image, deletion from the portfolio was offered. When I did the delete, it appeared to work.

When I selected the portfolio again for viewing, the first image was included and the second was not. When I passed the pointer over the image, the pop-up box indicated that it was in the portfolio. That's a third problem: the delete from the portfolio appeared to work but apparently didn't actually do the delete.

When I selected the folder for viewing again, both images were shown. When I passed the pointer over each image, the pop-up box indicated that both were in the portfolio. When I invoked delete for each, neither one offered deletion from the portfolio.

This is bizarre behavior. It's been a while since I've done any programming, but it seems to me that there are multiple data structures that store portfolio membership information and that they've become inconsistent with each other. Do you agree? Is there any way to get IDimager to fix this?

I've got over 650 images in this portfolio, so I rather not have to reconstruct it from scratch.

Thanks,
Mike

Mike Buckley
Posts: 4561
Joined: 10 Jul 08 14:18

Re: Can't Remove Image from Portfolio

Post by Mike Buckley » 03 Dec 13 3:19

I have never tried to reproduce the scenarios that you are describing and am having trouble following them in my imagination. So, I will bow out of the discussion except to say just one thing: Considering that Hert and his team are now developing the upcoming version that is two generations later than the version you are using, if you have come upon something that is not working as intended, it will surely be addressed in that upcoming version but will not be fixed in IDimager V5.

MikeA01730
Posts: 60
Joined: 29 Sep 11 22:52

Re: Can't Remove Image from Portfolio

Post by MikeA01730 » 03 Dec 13 4:34

Hert,

Actually, I think it's time to step back. We could spend a lot more time with this problem (if you were up for a long pursuit), but I think there's a better alternative.

I believe a better choice is for me to create a new label named Portfolios, create my portfolio name under that, and assign that label to everything in my portfolio. I'll then manipulate labels using reliable label assignments instead of wobbly (at least for me) portfolio management. If I ever need a feature only available with portfolios I can delete all my portfolios, repopulate them using my portfolio labels, and try again with a brand new and hopefully-more-predictable portfolio.

Unless I'm missing a problem with this approach that you can point out, I think I'll do it this way.

Thanks for your help.

Mike

Post Reply