Some PDF thumbnails fail to render

A forum for questions about how IDimager works
Post Reply
bssmith
Posts: 17
Joined: 09 Mar 08 18:34

Some PDF thumbnails fail to render

Post by bssmith » 06 Jul 13 16:05

I have over 3,000 PDF files which I have categorized using IDimager (v5.1.3.6). The vast majority of these PDF files render a thumbnail as expected within the main view.

However, there are several (~50) which do not render a thumbnail of the title page of the PDF - instead, what is rendered is a white box with the correct dimensions of the title page of the PDF in question.

The file titled "3193" in the attached screen shot shows one example.
Item 3193 as an example.png
Item 3193 as an example.png (126.15 KiB) Viewed 2756 times
Note that if I look at the same file's thumbnail from Windows Explorer, it is indeed rendered there correctly. You can see in the above screenshot (in the Versions panel) that I have separately generated a JPG equivalent of the title page of the PDF, and that thumbnail also displays as expected.

Update Selected Thumbs (F8) produces no change for these problematic PDF files.

Any ideas?

-- Ben

Mike Buckley
Posts: 4561
Joined: 10 Jul 08 14:18

Re: Some PDF thumbnails fail to render

Post by Mike Buckley » 06 Jul 13 16:29

Try the following, but beware that it's only a guess, especially considering that almost all of your PDF thumbnails are displayed as expected:

View a list of all non-image file formats that are registered: Tools >> Options >> Expand: General Settings >> File Handling

Notice the list of Non-Image Formats. You can add other file formats to that list by clicking inside the list window and typing additional formats. >> Click Apply.
>> Click OK

bssmith
Posts: 17
Joined: 09 Mar 08 18:34

Re: Some PDF thumbnails fail to render

Post by bssmith » 06 Jul 13 17:28

Mike - thanks for the quick response!

As you suspected, I already have .PDF listed there as a Non-Image Format.

Looking at this strictly from the perspective of the problematic PDF files themselves - maybe this is the source of the issue, not IDimager - I have not yet been able to determine if there is anything materially different between a "good" PDF file (which correctly displays the thumbnail within IDimager) and a "bad" PDF file (which displays the thumbnail as expected everywhere *but* IDimager).

I'll let this question percolate here for a couple of days to see if anything else might surface. Thanks again,

-- Ben

Mike Buckley
Posts: 4561
Joined: 10 Jul 08 14:18

Re: Some PDF thumbnails fail to render

Post by Mike Buckley » 06 Jul 13 18:10

Try opening each malcontent PDF and saving it using a different file name. Another guess.

Post Reply